VirtualBox

Ticket #11446 (reopened defect)

Opened 15 months ago

Last modified 4 months ago

Sound dies after a few minutes of playback

Reported by: Rafcio Owned by:
Priority: major Component: audio
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I believe this bug is related to the one reported by me in ticket #9735 and I have noted this in the other ticket, but here it is again. This problem is not consistent, but it happens frequently. Sometimes it takes only a few minutes of a sound playback for the sound to die and sometimes a much longer time. In almost every case if the sound dies it requires a VM reboot to recover, however it happened a few times that after the sound died the shutdown sound did play while I was rebooting. It does not really matter what player I use to "kill" the sound. It can be Winamp playing a local mp3 file or it can be music streamed from Internet in Firefox using an embedded player, which is I believe Flash based. After the sound dies Winamp will refuse to play. Sometimes it will seem frozen and sometimes it will try to play, but there will be no progress at all. The VLC media player will load and "play" the file, but there will be no sound, however the progress bar will increase. I won't be able to play any sound from the Sound applet in the Control Panel either. The player in Firefox will change the status to "buffering", which is not true, because I confirmed that it does not really stream (at least not the pieces I frequently listen to), but loads the whole file first and then plays it from cache I believe. Anyway, it seems as the audio subsystem is messed up badly, and it seems to be far worse now (means happens sooner or more frequently) than it used to be in the early VBox 4.1.x days.

Attachments

VBox.zip Download (15.2 KB) - added by Rafcio 15 months ago.

Change History

Changed 15 months ago by Rafcio

comment:1 Changed 15 months ago by frank

Just to understand you correct: A guest reboot (without stopping the VM) is sufficient to fix the sound or do you have to shutdown the guest and restart the VM?

comment:2 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

comment:3 Changed 4 months ago by Rafcio

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Sorry, I did not see the question. Just rebooting the guest without stopping the VM is sufficient to "fix" the issue. The sound comes back while shutting down - the shutdown sound is played. It seems that something gets reset when shutdown is initiated. It looks to me that the problem is with the sound card emulation. When the audio controller was set to ICH AC97 the problem was really, really bad. When I changed the controller to SoundBlaster 16 for the same client it improved things a lot. It is not perfect, but it is much better.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use