VirtualBox

Opened 12 years ago

Closed 11 years ago

#11395 closed defect (fixed)

virtualbox-4.2_4.2.6-82870 64bit crashes host (Ubuntu 12.10 64bit) when starting guest

Reported by: jbeiter Owned by:
Component: other Version: VirtualBox 4.2.6
Keywords: ubuntu 12.10 4.2.6 64bit Cc:
Guest type: other Host type: Linux

Description

Ubuntu 12.10 64bit

Kernel: 3.5.0-17-generic

Virtualbox: virtualbox-4.2_4.2.6-82870~Ubuntu~quantal_amd64.deb

CPU: Intel Core 2 Quad Q9550 Yorkfield 2.83GHz LGA 775 95W Quad-Core Desktop Processor BX80569Q9550

Guest: Win 7 Home Premium 64bit

Installed dependancies and deb package for virtualbox, created new guest "Windows 7 64bit" with defaults except for 100G disk (thin) and 1G RAM (have 4) No extended graphics selected.

When I try to run the VM, it prompts to confirm to select the dvd drive. Once I select it, the system panics and dumps registers to the console and freezes. The fault appears to be in libc-2.15.30 (based on the screen vomit, I'm not a programmer)

It says it is dumping core but I haven't been able to locate a core file.

A couple of other folks have reported these same symptoms (also with 64bit ubuntu 12.10) on the ubuntu forums under the virtualization forum.

Attachments (5)

VBox.log (51.2 KB ) - added by jbeiter 12 years ago.
Guest Log
kern.log (1005 bytes ) - added by jbeiter 12 years ago.
snippit of kernel log when starting virtualbox up
VBox.2.log (52.7 KB ) - added by jbeiter 12 years ago.
VBox.log.2 (45.4 KB ) - added by rviana 11 years ago.
rviana vbox log
VBox.3.log (41.9 KB ) - added by chrisnord12 11 years ago.

Download all attachments as: .zip

Change History (21)

by jbeiter, 12 years ago

Attachment: VBox.log added

Guest Log

by jbeiter, 12 years ago

Attachment: kern.log added

snippit of kernel log when starting virtualbox up

comment:1 by jbeiter, 12 years ago

Note: when the system crashes, nothing has been written to syslog.

comment:2 by Frank Mehnert, 12 years ago

I'm a bit confused. Does your host crash or does the VM process crash? I wouldn't expect a core dump if the host crashed. Can you clarify? Also, did you ever tried an older version of VirtualBox on that host?

comment:3 by jbeiter, 12 years ago

The host crashes. I have not tried an older version of vbox yet. I can try that tonight.

comment:4 by Frank Mehnert, 12 years ago

Could you reproduce the crash and take a photo from your screen with a digicam? The register dump you mentioned would be interesting. Also, are you 100% sure that the host froze or can you (for instance) alter the state of NumLock and switch to another virtual terminal (e.g. Ctrl+Alt+F1)?

comment:5 by jbeiter, 12 years ago

I can do that.

yes, I tried numlock, caps lock.. ALT+F1-F8 (X was completely gone and it was at a console text screen) and tried pinging from a different host.

comment:6 by jbeiter, 12 years ago

Went to reproduce a crash and got this pop up message this time:

VT-x/AMD-V hardware acceleration has been enabled, but is not operational. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot. Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer.

I'm wondering if my motherboard just needs a bios update to support the cpu, and if this is actually the problem. (new motherboard)

comment:7 by Frank Mehnert, 12 years ago

Looking at your VBox.log file there are indeed some questions. Your CPU seems to be a more recent Intel CPU, 4 cores but there is no full name of that CPU available, this is very unusual. Also the VBox.log file shows that VT-x is enabled and operational. So why is it different now? Can you also attach the VBox.log file from the VM session where VBox reported missing 64-bit support?

And you don't run VBox itself in a VM, do you?

comment:8 by Perry G, 12 years ago

Adding my name to follow this ticket.

comment:9 by jbeiter, 12 years ago

This was the problem. My motherboard is an Asus Striker II NSE and required a bios update to support the newer CPU. Once I updated the bios this version of vbox and ubuntu and now windows 7 64bit is installing just fine.

Sorry, not actually a defect with virtualbox :) I'll attach my guest log again for an after-bios update comparison.

Last edited 12 years ago by jbeiter (previous) (diff)

by jbeiter, 12 years ago

Attachment: VBox.2.log added

comment:10 by Frank Mehnert, 12 years ago

Resolution: worksforme
Status: newclosed

Yes, this log makes more sense now.:) So I guess we can close this ticket. Thanks for your information.

by rviana, 11 years ago

Attachment: VBox.log.2 added

rviana vbox log

comment:11 by rviana, 11 years ago

Resolution: worksforme
Status: closedreopened

Have the exact same issue described here, with slightly different hardware specs. VBox: 4.2.10 r84104

Host: $ more os-release NAME="Ubuntu" VERSION="12.10, Quantal Quetzal" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu quantal (12.10)" VERSION_ID="12.10"

Guest: Debian w/ Linux 2.6.32-5-686 (turnkey-joomla15-12.0-squeeze-x86.vmdk from http://downloads.sourceforge.net/project/turnkeylinux/vmdk/turnkey-joomla25-12.0-squeeze-x86-vmdk.zip)

Processor: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz

As suggested by jbeiter, i looked on HP's website (pc is hp h8-1520t) but doesn't appear to be any bios update. After starting the Guest, it sometimes takes between 30 to 60 seconds to cause the Host to immediately crash and reboot.

I don't see anything stand out in VBox.log, although I'll attach. The machine appears to immediately die, and simply return to the BIOS POST screen.

comment:12 by chrisnord12, 11 years ago

I get the exact same issue described here. Vbox 4.2.16
Host: Ubuntu Linux 12.04.3 64bit with kernel 3.2.0-52-generic
Guest: Windows 2000 Professional 32bit
CPU: Intel(R) Xeon(R) CPU E5-1620 @ 3.60GHz

I checked if there was a bios update and there was none as the two others suggested. This is a brand new install of Ubuntu and a new install of Virtualbox. I go in and add a machine with 2gb memory (out of my 64gb) and a 50gb hdd, other than that the settings are defaults.
When I start the virtual machine I see the virtualbox bios screen and then the host crashes without any kernel panic or dump and I am taken to the bios post screen for my host.
I have looked in my VBox.log as well and I don't see anything in it that stands out. I will attach though.

by chrisnord12, 11 years ago

Attachment: VBox.3.log added

in reply to:  12 comment:13 by chrisnord12, 11 years ago

I do know that this is an issue only with Vbox 4.2.x. When I used to run Vbox 4.1.26 I didn't get any issues, so I guess I will be reverting back some versions.

comment:14 by Frank Mehnert, 11 years ago

chrisnord12, it seems to me like you did not enable VT-x in the VM settings. Please activate this setting and try again.

comment:15 by Frank Mehnert, 11 years ago

chrisnord12, can you also check the output of 'dmesg' on your host? Please check if there are one or more lines 'Enabling x2api'. Thank you!

comment:16 by Frank Mehnert, 11 years ago

Resolution: fixed
Status: reopenedclosed

Please reopen if you can reproduce the problem with VBox 4.2.18.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use