VirtualBox

Ticket #11382 (closed defect: duplicate)

Opened 15 months ago

Last modified 10 months ago

'Alt Gr' key messed up after aborting seamless mode -> duplicate of #2537

Reported by: SlankySloop Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.4 Keywords: Alt Gr, seamless mode, abort, linux
Cc: Guest type: other
Host type: Windows

Description

Hi!

Using: 4.2.4-81684 (Host: Win7-64Bit; Guest: Ubuntu 11.4)

Today I accidentally hit the key combination for Seamless mode, but hit "Cancel" in the message box that comes up and asks for confirmation. After that I could not use "Alt Gr" anymore inside the virtual machine. After I switched to seamless mode (this time confirming the dialog) and back, everything was back to normal.

This is 100% reproducible for me - hit "Cancel" in the confirmation dialog and "Alt Gr" is broken. According to "xev" inside the virtual machine instead of just "keycode 108 (ISO_Level3_Shift)" hitting the broken "Alt Gr" key sends "keycode 37 (Control_L)" and then "keycode 108 (ISO_Level3_Shift)" - so it basically prepends a "Ctrl" press to any "Alt Gr" press which messes things up.

Likely others key don't work properly either in this state because I couldn't use "Alt + Tab" anymore inside the VM. Instead the host OS would react to them although key presses were captured.

The very same error occurs with Ubuntu 12.04. However, when I tried with a VM running Windows XP SP3 or Windows 7 SP1 respectively (got key presses with  http://www.donationcoder.com/Software/Skrommel/index.html#ShowOff) I noticed that it will *always* get a LControl+RAlt sequence when I press "Alt Gr" no matter what. I'm not sure if this is normal for Windows or also related to this bug.

Change History

comment:1 Changed 15 months ago by michael

See also ticket #3536.

comment:2 Changed 12 months ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from 'Alt Gr' key messed up after aborting seamless mode to 'Alt Gr' key messed up after aborting seamless mode -> duplicate of #2613

I will close this as a duplicate of #2613. Please re-open if you disagree.

The thing with Windows and LCtrl+RAlt is historical - Microsoft decided long ago to always make AltGr produce that sequence in Windows because non-international US keyboards do not have that key. Please do not ask me to defend the logic behind that decision though.

comment:3 Changed 10 months ago by michael

  • Summary changed from 'Alt Gr' key messed up after aborting seamless mode -> duplicate of #2613 to 'Alt Gr' key messed up after aborting seamless mode -> duplicate of #2537

Duplicate of #2537 in fact.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use