VirtualBox

Ticket #11370 (new defect)

Opened 15 months ago

virtualbox on win7 64bit unable to use host only networking

Reported by: twjnorth Owned by:
Priority: major Component: network
Version: VirtualBox 4.2.6 Keywords: host only network
Cc: Guest type: Linux
Host type: Windows

Description

I had virtualbox 4.1.17 installed on Windows 7 64bit. On a VM i have an Oracle Enterprise linux machine with an IP address of 192.168.56.102 and in preferences on the host, i have a IPV4 address of 192.168.56.101 and a subnet mask of 255.255.255.0

I upgraded virtualbox to the latest version 4.2.6 which updated the host preferences to set the ipv4 and subnet mask both to 0.0.0.0

I tried to reset these using File, Preferences, Network and clicking save but (after a popup window asking for permission from Windows to update), it saved the values as 0.0.0.0 so host only networking cannot work as the host and guest are not on the same network.

I tried this running as administrator as well as normally, and after rebooting the host but it doest help.

I then downloaded and installed 4.2.4 instead but had the same issue.

I downloaded 4.2.2 and this one works ok so seems to be a problem that was introduced in 4.2.4 but is also present in latest 4.2.6

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use