VirtualBox

Ticket #11349 (closed defect: obsolete)

Opened 6 years ago

Last modified 17 months ago

VirtualBox 4.2.6 will not install on Windows 7

Reported by: cjstewart7 Owned by:
Priority: major Component: installer
Version: VirtualBox 4.2.6 Keywords: 4.2.6 not install
Cc: Guest type: other
Host type: Windows

Description

Ill try and keep this short but feel free to probe for further information. As a complete amature I cannot locate the log file, many .log files are found when I search but I cannot open them (files cannot be located).

I have been running the older version of VB no problem for a while, however, since trying to update I have not been unable to install the new version. I have tried everything, including removing the older version so now I cannot even run that.

I follow setup wizzard. I think IMPORTANTLY I am prompted with 'WARNING NETWORK INTERFACES' which I select proceed with install. It then begins to install, however the copying files step is cut short and it comes up rolling back files. The screen then reads setup wizard ended prematurely because of an error leaving me to click finish. A pop up then appears saying 'installation failed: fatal error during installation'.

This happens everytime. I now also have a red cross over my internet icon on my toolbar (although my internet still works). I think the problem is related to this as it only happened after the first failed attempt. The same error occurs when I try to install older versions.

Please help! Thanks in advance,

Chris

ps Im running windows 7, dell, i5, 4GB

I should add - installing VirtualBox-3.1.8-61349-Win.exe works and actually removes the little red X over the internet icon

Attachments

VBoxInstallLog.txt Download (371.3 KB) - added by silverpef 6 years ago.
VBoxInstallLog
VBoxInstallLog2.txt Download (351.2 KB) - added by silverpef 6 years ago.
VBoxInstall2log
vbox_4.3.16.zip Download (83.7 KB) - added by vteich 4 years ago.
Logs vbox_4.3.16.zip

Change History

Changed 6 years ago by silverpef

VBoxInstallLog

Changed 6 years ago by silverpef

VBoxInstall2log

comment:1 Changed 6 years ago by silverpef

I have been experiencing the same symptom as well. It seems to happen on appr 33% of my workstations, and these workstations are same hardware and OS configured. Windows 7 (x64). I have provided to logs from the install logs for review and assistance on this matter.

comment:2 Changed 6 years ago by frank

The error in the log hints that some root certificate cannot be found. Please read  here (this is not for Oracle but describes the solution). Does updating the certificates on your host fix your installation issues?

comment:3 Changed 6 years ago by silverpef

Since Oracle released VirtualBox version 4.2.8, I have moved past 4.2.6 and version 4.2.8 appears to be installing with no difficulties.

comment:4 Changed 6 years ago by GITNE

This error persists in the MSI package of VirtualBox 4.2.10 and judging by other previous posts this error has a long record. The MSI package has not been authored correctly.

The error is due to an action trying to access keys in the registry belonging to the impersonated account token when installing via UAC or explicit impersonation (so even on Windows XP or Server 2003). While running under an impersonated account (usually a user in the administrator's group or with priviledges to install software) that account's regsitry portion (HKCU) is not available, instead the impersonated account inherits the impersonator's HKCU. Hence, the error.

To reproduce, please try the following while logged in as a simple user (account in the "Users" group only:

cd <folder with VirtualBox MSI packages>
runas /user:Administrator /noprofile /env "msiexec /I VirtualBox-4.2.10-r84104-MultiArch_amd64.msi /L*vx VirtualBox-4.2.10-install.log /QB TARGETDIR=\"C:\Program Files\VirtualBox\""

The installation should die silently with an 1603 error in the log. The above commands are actually equivalent to what UAC does when running an application with administrative privileges.
Now, try running while loading the profile.

runas /user:Administrator /profile /env "msiexec /I VirtualBox-4.2.10-r84104-MultiArch_amd64.msi /L*vx VirtualBox-4.2.10-install.log /QB TARGETDIR=\"C:\Program Files\VirtualBox\""

The installation should proceed successfully.

The administered installation is broken also, try:

runas /user:Administrator /noprofile /env "msiexec /A VirtualBox-4.2.10-r84104-MultiArch_amd64.msi /L*vx VirtualBox-4.2.10-admin-install.log /QB TARGETDIR=C:\Repositroy"

Running that command you should see the registry key in question. Where as while loading the profile it should work fine:

runas /user:Administrator /profile /env "msiexec /A VirtualBox-4.2.10-r84104-MultiArch_amd64.msi /L*vx VirtualBox-4.2.10-admin-install.log /QB TARGETDIR=C:\Repositroy"

According to Microsoft's specification on MSI packages, this behavior is not compliant with well authored MSI packages, even those that install device drivers. Please fix this issue, since it prevents pushing those packages via third party deployment tools which often indeed perform installs under impersonated accounts.

comment:5 Changed 4 years ago by hazarmhmad@…

I was trying to install Version 4.3.12.

so i have downloaded it and installed it.

While installing the installation bar goes till copying files and then suddenly it appears to roll back. Then at final VM VirtualBok 4.1.12 setup wizard ended .Prematurely because of an error.Your system has not been modified.Please install at another time. I have tried to install it lot of time. need help guys ty

Last edited 4 years ago by hazarmhmad@… (previous) (diff)

comment:6 follow-up: ↓ 11 Changed 4 years ago by PatrickE

Machine: Windows 7 (64), Dell Precision M6400. This is my first attempt at installing any version of VirtualBox on this machine.

I was also trying to install 4.3.12, but it fails. It gets past the copying files part all the way to publishing product information, but right before it looks like the whole install is over, it starts rolling back, and I get the Installation ended prematurely message. I hit finish, and then an alert pops up saying:

Installation failed! Error: Fatal error during installation.

If I tell the installer to add shortcuts, they will briefly appear before the rollback happens and I can actually launch VirtualBox. The application actually appears to be working, and I can try to create a new VM, but when I hit the final create button after picking all the settings, I get a

Failed to create the hard disk storage C:\Users\PatrickE\VirtualBox VMs\Ubuntu 1\Ubuntu 1.vdi.

Callee RC: TYPE_E_CANTLOADLIBRARY (0x80029C4A)

Taking a cue from user GITNE, I tried

C:\Downloads\VirtualBox-4.3.12-93733-Win.exe -extract

Followed by

msiexec /A VirtualBox-4.3.12-r93733-MultiArch_amd64.msi /L*vx VirtualBox-4.3.12-admin-install.log /QB TARGETDIR="C:\ProgramFiles\VirtualBox"

It claims to have installed correctly, which is great, but when I navigate to C:\Program Files\VirtualBox\PFiles\Oracle VM VirtualBox and attempt to run VirtualBox.exe, I get

Failed to create the VirtualBox COM object.

The application will now terminate.



Callee RC: REGDB_E_CLASSNOTREG (0x80040154)

Which probably just means I didn't actually install it (at least not correctly). Lastly, after the first failed attempt, I followed the instructions on https://www.virtualbox.org/wiki/MSI_Logging for both installation and driver logging, but I've yet to see any files appear in C:\Users\PatrickE\AppData\Local\Temp after more than a dozen attempts in various ways. Also, everything I did from the command line was in an administrator-privileged command prompt.

Last edited 4 years ago by PatrickE (previous) (diff)

comment:7 Changed 4 years ago by kludge

Same thing here. Some useful things we see in the log include:

DIFXAPP: ERROR: Unable to start service 'VBoxDrv' because of error 0x422M and

VBoxNetCfgWinInstallComponent failed, hr (0x8004a029)

when I run the msi file manually from the prompt. Nothing manages to actually install properly, though. Help! --scott

comment:8 Changed 4 years ago by 3vi1J

I'm seeing the same 0x422 issue with VBox 4.3.16 on 32-bit Win7. Extracting the msi and experimenting with all the different runas options above has not produced a working solution.

Last edited 4 years ago by 3vi1J (previous) (diff)

comment:9 Changed 4 years ago by VVP

please, when you describe your case, upload here installation log (if one exists). Or add more information and not only couple lines.

Standard procedure which you can try in the case of abnormal installation:

  1. Uninstall previous version separately.
  2. Stop and delete vboxdrv, vboxusbmon, vboxnetflt, vboxnetadp services (if someone of them still exists).

It shall be done with administrative privileges, of course.
Try next:
"sc query vboxdrv/vboxusbmon/vboxnetflt/vboxnetadp"
"sc stop vboxdrv/vboxusbmon/vboxnetflt/vboxnetadp"
"sc delete vboxdrv/vboxusbmon/vboxnetflt/vboxnetadp"

  1. Reboot machine
  2. Try to install a new version
  3. Can repeat 3-4 steps one more time.

comment:10 Changed 4 years ago by vteich

After successfully installing Vbox 4.3.10-93012 on Windows 7 32 bits, I could not upgrade it to 4.3.16-95972. The installation failed. I had a FAILURE report in C:\Windows\Inf\setupapi.app.log

[SetupUninstallOEMInf - oem79.inf] Section start 2014/11/07 12:32:47.501

cmd: C:\Windows\system32\MsiExec.exe -Embedding D996C4C057ED8CA4D04D56128E48E5DB M Global\MSI0000

! inf: Error uninstalling INF 'oem79.inf', device 'USB\VID_80EE&PID_CAFE\3E462912172907210307' is still using it ! inf: Error uninstalling INF 'oem79.inf', device 'USB\VID_80EE&PID_CAFE\17142400306BD004' is still using it !!! inf: Error uninstalling OEM INF 'C:\Windows\INF\oem79.inf' !!! inf: Error 0xe000023d: One or more devices are presently installed using the specified INF. <<< Section end 2014/11/07 12:32:48.102 <<< [Exit status: FAILURE(0xe000023d)]

I tried several things.

What finally worked (making a long story short): I added the VirtualBox Extension Pack and was able to run VirtualBox again.

I also had the error: Bridged Networking does not find any adapters

See https://www.virtualbox.org/ticket/3654

I fixed it with the following change and running the below command.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network]

"MaxNumFilters"="0x20"

msiexec /i VirtualBox-4.3.18-r96516-MultiArch_amd64.msi /L*vx VirtualBox-4.3.18-install.log /QB TARGETDIR="C:\Program Files\Oracle\VirtualBox" DDLOCAL=VBoxNetworkFlt

HTH others.

Last edited 4 years ago by vteich (previous) (diff)

Changed 4 years ago by vteich

Logs vbox_4.3.16.zip

comment:11 in reply to: ↑ 6 ; follow-up: ↓ 13 Changed 4 years ago by vteich

Installation log file is in C:\Users\PatrickE\AppData\Local\Temp and driver log file in c:\Windows or c:\Windows\Inf

Replying to PatrickE:

Which probably just means I didn't actually install it (at least not correctly). Lastly, after the first failed attempt, I followed the instructions on https://www.virtualbox.org/wiki/MSI_Logging for both installation and driver logging, but I've yet to see any files appear in C:\Users\PatrickE\AppData\Local\Temp after more than a dozen attempts in various ways. Also, everything I did from the command line was in an administrator-privileged command prompt.

comment:12 Changed 4 years ago by Planningexpert.nl

Hi cjstewart7, I was suffering the same problems with latest version 4.3.20 for Windows hosts. Installed previous version 4.2.26 with success. Good luck!

comment:13 in reply to: ↑ 11 Changed 4 years ago by frank

Replying to vteich:

Installation log file is in C:\Users\PatrickE\AppData\Local\Temp and driver log file in c:\Windows or c:\Windows\Inf

Replying to PatrickE:

Which probably just means I didn't actually install it (at least not correctly). Lastly, after the first failed attempt, I followed the instructions on https://www.virtualbox.org/wiki/MSI_Logging for both installation and driver logging, but I've yet to see any files appear in C:\Users\PatrickE\AppData\Local\Temp after more than a dozen attempts in various ways. Also, everything I did from the command line was in an administrator-privileged command prompt.

Looks like the old problem with the host networking drivers. Try to completely uninstall VirtualBox, then reboot, then install VirtualBox again. If you don't need Host networking or bridged networking in your VMs, try to omit host networking during the installation.

We are working on NDIS6 drivers which should fix these issues.

comment:14 follow-up: ↓ 15 Changed 4 years ago by neocec

This fixed it for me. Follow these step by step:

  1. Uninstall Virtualbox
  2. Uninstall Any Virtual Box Network Adaptors from Device Manager
  3. Go into the registry at: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network
  4. Change "MaxFilters" from 8 to 20 (decimal)"
  5. Reboot your PC
  6. Install VirtualBox 4.3.X (Run as Administrator)

I found these steps from this post:  https://forums.virtualbox.org/viewtopic.php?f=6&t=61785

Note: I edited the steps and I added the step 2, not sure if it's necessary but I did it anyway.

comment:15 in reply to: ↑ 14 Changed 4 years ago by rio197

Thank you, neocec!

When installing the latest version of Virtualbox the installer managed to uninstall the previous version successfully but when installing the new one it ended with the error message "setup ended prematurely" (or something similar to that).

Only after doing the exact steps that neocec wrote I can install Virtualbox successfully.

Thanks again,

Replying to neocec:

[...]

[...]

Last edited 4 years ago by rio197 (previous) (diff)

comment:16 Changed 4 years ago by SouzaRM

Thanks @NeoCec [2014-12-10 06:06:22]...

100% working in Rwindows 7 Ultimate x64...

comment:17 Changed 3 years ago by Mr. Hatcher

Thank you @NeoCec.

I was having the same issue installing VirtualBox v4.3.26 on Win7 Enterprise Edition SP1 x64.

All I had to do was modify the Registry Key (didn't even have to reboot) and the install finally worked.

comment:18 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use