VirtualBox

Ticket #11331 (closed defect: fixed)

Opened 16 months ago

Last modified 6 months ago

VIrtualBox 4.2.6 crashes WIndows 8 guests with 3D Games

Reported by: gojul Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.2.6 Keywords: Windows 3D crash
Cc: Guest type: Windows
Host type: Linux

Description

DO : launch Windows 8 Guest under GNU/Linux (Kubuntu 12.10 used in the example) DO : within the guest, launch a game like Age Of Empires 3 or Age Of Mythology EXPECT : the game works fine (at least it used to, using VBox 4.2.4 - for AOE3 this required to tweak a bit parameters to ensure minimum parameters were set) ACTUAL : the game actually aborts the VM.

I tried to reinstall VBox Guest Additions 4.2.6 but the result is always the same.

The issue is not reproducible with Windows XP Guests on the same platform.

Host platform : AMD Phenom x4 9850 8 GB RAM GeForce GTX 460 1 GB RAM Ubuntu Linux 12.10 w/ PAE kernel NVidia proprietary driver 304.43 VirtualBox 4.2.6 installed from VBox Debian repository

Reproducitibility : always

Last log lines are the following ones : 00:00:27.078264 NAT: DHCP offered IP address 10.0.2.15 00:01:36.395164 Starting host clipboard service 00:01:36.395221 Initializing X11 clipboard backend 00:01:36.395246 Guest Additions capability report: (0x4) seamless: no, hostWindowMapping: no, graphics: yes 00:01:36.427849 Shared clipboard: starting shared clipboard thread 00:01:36.497943 Guest Additions capability report: (0x5) seamless: yes, hostWindowMapping: no, graphics: yes 00:01:44.674465 RTC: period=0x20 (32) 1024 Hz 00:01:44.705196 RTC: period=0x200 (512) 64 Hz 00:01:44.736909 RTC: period=0x20 (32) 1024 Hz 00:01:49.236294 RTC: period=0x200 (512) 64 Hz 00:01:50.283968 RTC: period=0x20 (32) 1024 Hz 00:01:53.486077 RTC: period=0x200 (512) 64 Hz 00:02:24.862232 RTC: period=0x20 (32) 1024 Hz 00:02:33.219888 OpenGL Warning: Cleared gl error 0x506 on context creation

Attachments

VBox.log Download (68.1 KB) - added by gojul 16 months ago.
VBox.log file

Change History

Changed 16 months ago by gojul

VBox.log file

comment:1 Changed 16 months ago by gojul

I've found out the two following elements : 1/ The bug is a graphic card context change related issue. I mean that if I reset AOE3 configuration, the game starts up fine once, but once it has save its settings, the bug is reproducible again. 2/ The error produced by the log is always OpenGL Warning: Cleared gl error 0x506 on context creation just before crashing.

I suspect these are problems while initializing the graphic card with a certain amount of memory which lead the entire VM to crash. The behaviour was fine with VBox 4.2.4 but there's a regression around it in VBox 4.2.6.

comment:2 Changed 15 months ago by misha

Could you create a core dump for you crash, upload it to  ftp://ftp.oracle.com:/appsdev/incoming and post me a name of the uploaded file to mikhail dot sennikovsky at oracle dot com so that I can get it.
Note that this directory is write-only for public users for security reasons.

comment:3 Changed 15 months ago by gojul

Hi,

File is named bug_11331.tgz. Sent you an email about the issue.

Rgds,

comment:4 Changed 15 months ago by misha

Unfortunately it's hard to say what have caused the crash based on your crash dump, since the crash occurred inside nvidia propriate opengl library.
To localize the issue, could you check if the crash occurs with:

  1. VBox 4.2.6 host installation and 4.2.4 Guest Additions
  2. VBox 4.2.4 host installation and 4.2.6 Guest Additions

comment:5 follow-up: ↓ 6 Changed 15 months ago by gojul

Hi,

Since the issue is not reproducible with the same apps on WinXP, this seems clearly to be a good candidate.

However :

  • Could you please provide me a direct link to VBox Guest Additions 4.2.4 and 4.2.6 ?
  • And please provide me the command so that I could downgrade VBox to version 4.2.4 in case the crash is reproducible with VBox 4.2.6 + 4.2.4 Guest additions.

Thanks,

Rgds,

comment:6 in reply to: ↑ 5 Changed 15 months ago by misha

Replying to gojul: here are the links:
4.2.6 additions :  http://download.virtualbox.org/virtualbox/4.2.6/VBoxGuestAdditions_4.2.6.iso
4.2.4 additions :  http://download.virtualbox.org/virtualbox/4.2.4/VBoxGuestAdditions_4.2.4.iso
4.2.4 host distro, assuming you have Ubuntu 12.10 x86:  http://download.virtualbox.org/virtualbox/4.2.4/virtualbox-4.2_4.2.4-81684~Ubuntu~quantal_i386.deb . I expect you can just install this package in a regular way for downgrade.

comment:7 Changed 15 months ago by gojul

OK issue comes from the VBox guest additions. With VBox 4.2.6 + Guest Additions 4.2.4 the issue is not reproducible anymore. Thanks !

Thus, I've remarked that 3d performance is much better with this combination in guests than with Guest Additions 4.2.6. (Game tested : Warcraft III : under VBox 4.2.4 -> perfectly playable - with 4.2.6 -> not playable but playable under WinXP with the same settings...)

Last edited 15 months ago by gojul (previous) (diff)

comment:8 follow-up: ↓ 9 Changed 15 months ago by gojul

I've also remarked one very positive side effect with combination VBox 4.2.6 + Additions 4.2.4 on W8 guest : it turns out that W8 in such a configuration does no longer have the usual startup problems with VirtualBox one could encounter "normally"...

comment:9 in reply to: ↑ 8 Changed 15 months ago by misha

Replying to gojul:

I've also remarked one very positive side effect with combination VBox 4.2.6 + Additions 4.2.4 on W8 guest : it turns out that W8 in such a configuration does no longer have the usual startup problems with VirtualBox one could encounter "normally"...

Could you elaborate on what kind of startup problems do you encounter, and with which VBox host and additions version?

comment:10 follow-up: ↓ 11 Changed 15 months ago by gojul

Well, actually this was a false impression.

The startup problem is as follows :

  • Start Windows 8
  • Windows 8 hangs on startup (randomly). Actually you're blocked on the startup screen with the blue square, nothing happens.

This is reproducible randomly, but with any version of VBox 4.2.x and any version of the additions inside.

It seems that I'm not an isolated case : https://www.virtualbox.org/ticket/10700

comment:11 in reply to: ↑ 10 Changed 15 months ago by misha

Replying to gojul:

Well, actually this was a false impression.

The startup problem is as follows :

  • Start Windows 8
  • Windows 8 hangs on startup (randomly). Actually you're blocked on the startup screen with the blue square, nothing happens.

This is reproducible randomly, but with any version of VBox 4.2.x and any version of the additions inside.

Does the issue occur if you disable the 3D acceleration in VM settings (on a "Display" page of VM settings GUI)?

It seems that I'm not an isolated case : https://www.virtualbox.org/ticket/10700

comment:12 Changed 15 months ago by gojul

Yep it does.

comment:13 Changed 14 months ago by gojul

Issue still present in release 4.2.8. The bug is located within the guest additions, with VBox 4.2.8 + GA 4.2.4.

comment:14 Changed 14 months ago by frank

So why did you not update the GA to 4.2.8 then?

comment:15 Changed 14 months ago by gojul

Actually I did, but I could then reproduce the issue presented in this bug, so I reverted back to GA 4.2.4.

comment:16 Changed 14 months ago by misha

I believe your crash issue is most likely caused by the bug in the host part of VBox 3D. The reason you started seeing it with 4.2.6 Additions is because they started to use an other, more optimal rendering mechanism in D3D impl.
We have fixed this host side issue. The fix will be available in the next major release.
I can give you a trunk test build though, that you could use to test whether the issue is solved for you.

Note that the trunk is under heavy development now, and thus this build can be used for testing purposes only, and can NOT be used in production environment.

Here are the links:
Linux 32bit host distro:  http://www.virtualbox.org/download/testcase/VirtualBox-4.2.51-84161-Linux_x86.run
Extension pack:  http://www.virtualbox.org/download/testcase/Oracle_VM_VirtualBox_Extension_Pack-4.2.51-84166.vbox-extpack

You can use either 4.2.8 Additions or Additions from this test build package with it.
Please let me know how it goes.

comment:17 Changed 13 months ago by gojul

Still not fixed with VBox 4.2.10. Actually I also could reproduce the problem on a W7 VM with Aero. In that case the game seems to start normally, but once it's loaded we only get a black screen, and after exiting the whole VM crashes.

Unfortunately I don't have any possibility to test VBox 4.2.51 as my machines are used in a production environment, however if you could make a build consisting in backporting the fix and package it for Ubuntu I'd be veeeery interested. However I'm almost sure you could also test your fix with this AOE3 demo :  http://www.microsoft.com/en-us/download/details.aspx?id=6009

Last edited 13 months ago by gojul (previous) (diff)

comment:18 Changed 13 months ago by gojul

After upgrading Ubuntu to 13.10 with new NVidia drivers (310.32 the issue is still there. So I can confirm that the issue does not look to come from NVidia but rather from VBox, unless the issue wasn't fixed on NVidia side...

comment:19 Changed 13 months ago by misha

Did you try the test build I gave you? The fix is not included in 4.2 branch and will be available in the next major release only.
This is why the only way to try it so far is via a trunk test build. Let me know if you want me to give you a fresh test build to verify whether the issue is fixed for you with it.

comment:20 Changed 12 months ago by gojul

Hi,

I cannot currently, but I'll do it as long as the 4.3 branch is in beta or something like this, when it's package for my Linux distro.

Rgds

comment:21 Changed 12 months ago by gojul

For the freeze problem, I think it's related to DKMS. With latest kernels on Ubuntu 13.04, DKMS installation of VBox does not work anymore, but we can recompile the VBox module using vboxdrv, and the startup problem is gone using this method !

comment:22 Changed 10 months ago by gojul

The fix introducted with VBox 4.2.14 actually seems to work for Windows 7, but not for Windows 8.

comment:23 Changed 6 months ago by gojul

Updated to VBox 4.3.0 under Ubuntu Saucy (13.10) AMD64 with NVidia driver 319.

The crash bug is actually fixed, but there are many regressions in this release :

  • Cannot launch a 3D game in full screen, the window actually always gets minimized and when we switch on it it is minimized again and again.
  • Many artifacts on some games, such as AOE3 where the sky does not appear, and in game there are many problems.

comment:24 Changed 6 months ago by misha

Thanks for the update! We've reproduced some issues with AOE3 here and are now working on solving them.

comment:25 Changed 6 months ago by misha

We have fixed the AOE3 rendering issues we've found here.
Please give a try to the following test build containing the fix and let me know how it goes for you.

Linux x86 host distro:
 http://www.virtualbox.org/download/testcase/VirtualBox-4.3.1-90197-Linux_x86.run
Extpack:
 http://www.virtualbox.org/download/testcase/Oracle_VM_VirtualBox_Extension_Pack-4.3.1-90197.vbox-extpack
Let me know if you need a test build for any other host OS type.

comment:26 Changed 6 months ago by misha

Note that you'll need to update Guest Additions to those supplied with the test build.

comment:27 Changed 6 months ago by gojul

Hi,

Actually I need a build for AMD64 Ubuntu Saucy. Could you please package it in debian format if possible, also ?

Thanks

comment:28 Changed 6 months ago by misha

comment:29 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 4.3.2, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use