VirtualBox

Ticket #11320 (closed defect: duplicate)

Opened 16 months ago

Last modified 8 months ago

Windows 7 SP1 x32 reboots after some time when x64 guest is runs

Reported by: Mc.Sim Owned by:
Priority: critical Component: other
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: other
Host type: other

Description

Hi, Environment:

Version of VirtualBox installed - 4.2.6 r82870 Type and version of the Host Operating System - Windows 7 Ent SP1 x32 Type and version of the Guest OS - Windows 2k8 R2, RHEL6 x64

Problem: I installed the guest OS (Win 2k8 r2). I have run the guest OS. My host is rebooted after a while. This problem is found in the previous version VB (4.2.4). This problem was not only in Win x64, in RHEL x64 too.

Attempted Resolutions: I try to reinstall guest OS. I try to change settings guest machine (more memory, en\dis IO APIC). When host restarted minidump-file not created. I try to change settings to create full-dump, but it does not work. dump-file not created.

Attachments

VBox.log Download (227.0 KB) - added by Mc.Sim 16 months ago.
log file Win 2k8 r2
DSC_0792.jpg Download (466.4 KB) - added by Mc.Sim 15 months ago.
NO in BIOS
auto_restart.PNG Download (104.6 KB) - added by Mc.Sim 15 months ago.
Disable auto restart
VBox.2.log Download (56.8 KB) - added by Mc.Sim 15 months ago.
today log after reboot
VBox.log.1 Download (103.2 KB) - added by Mc.Sim 15 months ago.
After last reboot ( VBox.2.log ), I noticed that the corrupted filesystem inside the VM. And VM was terminated.
VBox.3.log Download (71.6 KB) - added by Mc.Sim 15 months ago.
After that. I try to run the vm, but host-system reboots again.
VBox.4.log Download (224.6 KB) - added by Mc.Sim 14 months ago.
today my laptop again crashed. Log attached
VBox.5.log Download (70.3 KB) - added by Mc.Sim 13 months ago.
Debian x64 on Windows 7 x32.
AutoRuns.arn.zip Download (110.2 KB) - added by Mc.Sim 13 months ago.
Drivers in AutoRuns-file format (File-Save...) and in zip

Change History

Changed 16 months ago by Mc.Sim

log file Win 2k8 r2

comment:1 Changed 16 months ago by Mc.Sim

Additionally, I checked my host HDD and memory. No error. x32 guest OS worked many time without error or reboot host.

comment:2 Changed 16 months ago by MikeInMaine

I think I'm seeing the same thing.

Host: Windows 7 sp1 32bit. VM: Windows 7 sp1 64bit. Host reboots without any update to Windows logs shortly after starting VM.. but not always. Has happened twice in last day. VB 4.2.6

comment:3 follow-up: ↓ 4 Changed 16 months ago by mhanor

Mc.Sim: Disable Trusted Execution in the host's BIOS and try again.
MikeInMaine: Attach a VM log.

Both of you should try to disable the OS "automatic reboot on system failure" option. It may still be a BSOD.  http://www.evga.com/support/faq/afmviewfaq.aspx?faqid=59175

Changed 15 months ago by Mc.Sim

NO in BIOS

Changed 15 months ago by Mc.Sim

Disable auto restart

comment:4 in reply to: ↑ 3 Changed 15 months ago by Mc.Sim

Replying to mhanor:

Mc.Sim: Disable Trusted Execution in the host's BIOS and try again.

I don't have that parameter in BIOS: Att DSC_0792.jpg May be this option is "Data Execution Prevention"?

Both of you should try to disable the OS "automatic reboot on system failure" option. It may still be a BSOD.  http://www.evga.com/support/faq/afmviewfaq.aspx?faqid=59175

Automatic restart were disabled before. But BSOD is not show and minidump-file not created. Only restart host at this time. Att auto_restart.PNG

Last edited 15 months ago by Mc.Sim (previous) (diff)

comment:5 Changed 15 months ago by Mc.Sim

Today my host-system reboots again.

Changed 15 months ago by Mc.Sim

today log after reboot

Changed 15 months ago by Mc.Sim

After last reboot ( VBox.2.log ), I noticed that the corrupted filesystem inside the VM. And VM was terminated.

Changed 15 months ago by Mc.Sim

After that. I try to run the vm, but host-system reboots again.

comment:6 Changed 15 months ago by mhanor

What laptop model are you using?

comment:7 Changed 15 months ago by Mc.Sim

HP Elitebook 8400p (p\n VQ667EA#ACB)

comment:9 Changed 15 months ago by mhanor

Have you read this, on how to enable/disable Trusted Execution?  http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c02620201/c02620201.pdf

comment:10 Changed 15 months ago by Mc.Sim

This doc do not accept for my nout. And TXT on this laptop is turned off by BSU (BIOS Config Util). Support service helped me to understand how work Disable TXT ))) This technology was disabled before.

comment:11 Changed 15 months ago by mhanor

If TXT is disabled, I would expect MSR_IA32_FEATURE_CONTROL to be 5, no 7, as seen in your logs.

comment:12 Changed 15 months ago by Mc.Sim

Hmm .. Very strange ... I have not changed the configuration (only did exports). When I saw export config - TXT parameter was Disable. (maybe I accidentally changed something in the settings ...)

Now I am sure that TXT off. Next I will observe the work and if anything, I will write about the problem and will put the log here ....

comment:13 Changed 15 months ago by mhanor

When changing the VT-x/TXT options, the CPU must power down in order to reinitialize the IA32 Feature control MSR. If the BIOS config tool doesn't do it, you must do it, by shutting down the laptop.

Changed 14 months ago by Mc.Sim

today my laptop again crashed. Log attached

comment:14 Changed 14 months ago by Mc.Sim

Forgot to clarify - Power Off was done. To be sure the battery and the power cord has been removed.

comment:15 Changed 14 months ago by mickmm

I'm having the same problem:

Host: Windows 7 x32

Guest: Fedora 14 x64, Windows server 2008 R2, Fedora 16

In all cases, the host reboot without blue screen of death. I haven't found any solution yet.

comment:16 Changed 13 months ago by Mc.Sim

Today I updated VirtualBox to last version 4.2.10 r84104. I tried to install Debian x64 after that. But after some time my host crashed again. :(((

Changed 13 months ago by Mc.Sim

Debian x64 on Windows 7 x32.

comment:17 Changed 13 months ago by Mc.Sim

Please, help me for resolve the problem.

comment:18 Changed 13 months ago by mhanor

Do you have other virtualization software installed, such as Windows XP Mode or Virtual PC?

comment:19 Changed 13 months ago by Mc.Sim

No, I have not installed any other virtualization. From Virtualized vendors I have installed VMware Converter and vSphere Client 5.1. But this bug was before install Vmware's utils.

comment:20 Changed 13 months ago by mhanor

I find it strange that the IA32_FEATURE_CONTROL MSR is 7, in most of your logs. Maybe there is a BIOS bug. Do you use suspend-to-RAM, to put your laptop to sleep, or do you use the regular shutdown option?

If you have a firewire port, you could use it to set up a remote kernel debugging session, to see if that gives you any clues.

Also, could you post a listing of loaded drivers? You can use livekd or Autoruns, from Sysinternals.

comment:21 follow-up: ↓ 22 Changed 13 months ago by Mc.Sim

I find it strange that the IA32_FEATURE_CONTROL MSR is 7, in most of your logs. Maybe there is a BIOS bug.

Maybe... But how can I fix this fact?

Do you use suspend-to-RAM, to put your laptop to sleep, or do you use the regular shutdown option?

Yes, I use sleep function very often. But I use shutdown option from time to time (maybe once in the two or three days).

If you have a firewire port, you could use it to set up a remote kernel debugging session, to see if that gives you any clues.

Now I don't have other PC to connect over firewire port. ( Maybe I will have other PC - 1 April, but I didn't work with debugging never . Can you give me howto-link? I'll be very grateful.

Also, could you post a listing of loaded drivers? You can use livekd or Autoruns, from Sysinternals.

List drivers attached.

Changed 13 months ago by Mc.Sim

Drivers in AutoRuns-file format (File-Save...) and in zip

comment:22 in reply to: ↑ 21 ; follow-up: ↓ 23 Changed 13 months ago by mhanor

Replying to Mc.Sim:

I find it strange that the IA32_FEATURE_CONTROL MSR is 7, in most of your logs. Maybe there is a BIOS bug.

Maybe... But how can I fix this fact?

Do you use suspend-to-RAM, to put your laptop to sleep, or do you use the regular shutdown option?

Yes, I use sleep function very often. But I use shutdown option from time to time (maybe once in the two or three days).

You can't fix it, but you can report it to the manufacturer and get them to fix it. But first, you have to do some investigations. Download the RW utility from rweverything.com, use it to monitor the IA32_FEATURE_CONTROL MSR. You'll have to add it to the MSR User list (add the 0x3A value). Make sure TXT is off, in BIOS. First, shutdown the laptop, then start it again and never reboot it, until I mention so. After the OS has loaded, check the MSR value using that tool. All CPU cores must have the same value, 0x5. Now, put the laptop to sleep. Wake it up, check the MSR value, it should be unchanged. You can try another sleep/wake cycle and check the MSR value. Next is the first laptop reboot, followed by a sleep/wake cycle. Check the MSR value.

If you have a firewire port, you could use it to set up a remote kernel debugging session, to see if that gives you any clues.

Now I don't have other PC to connect over firewire port. ( Maybe I will have other PC - 1 April, but I didn't work with debugging never . Can you give me howto-link? I'll be very grateful.

 http://msdn.microsoft.com/en-us/library/windows/hardware/ff556866%28v=vs.85%29.aspx
On the host, you'll have to install the Windows Debugging Tools, which are a part of the Windows Software Development Kit (SDK) or the Windows Driver Kit (WDK). It's important that the host (the PC that is remotely debugging the laptop) is using the corect symbols. I use the MS Symbol Server:
 http://support.microsoft.com/kb/311503

comment:23 in reply to: ↑ 22 Changed 12 months ago by Mc.Sim

Replying to mhanor:

You can't fix it, but you can report it to the manufacturer and get them to fix it. But first, you have to do some investigations. Download the RW utility from rweverything.com, use it to monitor the IA32_FEATURE_CONTROL MSR. You'll have to add it to the MSR User list (add the 0x3A value). Make sure TXT is off, in BIOS. First, shutdown the laptop, then start it again and never reboot it, until I mention so. After the OS has loaded, check the MSR value using that tool. All CPU cores must have the same value, 0x5. Now, put the laptop to sleep. Wake it up, check the MSR value, it should be unchanged. You can try another sleep/wake cycle and check the MSR value. Next is the first laptop reboot, followed by a sleep/wake cycle. Check the MSR value.

Sorry for the long silence. Today I created new support ticket 4644731726 in HP for that problem. I sent them screenshot RW utility. When I reboot laptop (Next is the first laptop reboot) , 0x3A value changed to all zero. Next I will keep informed of further developments.

 http://msdn.microsoft.com/en-us/library/windows/hardware/ff556866%28v=vs.85%29.aspx
On the host, you'll have to install the Windows Debugging Tools, which are a part of the Windows Software Development Kit (SDK) or the Windows Driver Kit (WDK). It's important that the host (the PC that is remotely debugging the laptop) is using the corect symbols. I use the MS Symbol Server:
 http://support.microsoft.com/kb/311503

The debug I did not do. I don't have many components for debug (time,other firewire host, firewire cable, knowledge and other ))) )

comment:24 Changed 11 months ago by Mc.Sim

HP's technical support say that this problem is Microsoft products. (((

comment:25 Changed 11 months ago by mhanor

What MS product? Windows? Ask them to explain how is it Windows at fault.

comment:26 Changed 11 months ago by Mc.Sim

What MS product?

MS Win7 Ent

Ask them to explain how is it Windows at fault.

Unfortunately, I closed ticket. And I get new license for Vmware Workstation, and soon I reinstall Win from x32 to x64.

Thank you very much for your help.

comment:27 Changed 8 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I'm quite sure this is a duplicate of #11979. Please try the test build which I provided in #11979 and report success or failure there. Thank you!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use