VirtualBox

Ticket #11255 (closed defect: duplicate)

Opened 17 months ago

Last modified 17 months ago

Could not able to allocate and lock memory

Reported by: ericderaps Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

i was trying to install oracle 64-bit os in my virtual box when i reached a stage where partioning has to be done and i clicked "Write changes to disk" and a window popped up saying "Could not able to allocate and lock memory". Can you help me with this. Thanks in advance.

Attachments

VBox.png Download (32.6 KB) - added by ericderaps 17 months ago.
VBox.log.1 Download (85.4 KB) - added by ericderaps 17 months ago.
VBox.log.2 Download (85.3 KB) - added by ericderaps 17 months ago.
VBox.log Download (91.1 KB) - added by ericderaps 17 months ago.

Change History

Changed 17 months ago by ericderaps

Changed 17 months ago by ericderaps

Changed 17 months ago by ericderaps

Changed 17 months ago by ericderaps

comment:1 Changed 17 months ago by ericderaps

Hope the above log files are helpful.

comment:2 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Yes. Duplicate of #10219. Please continue the discussion there.

comment:3 Changed 17 months ago by Perryg

Frank,

Are you sure this isn't the problem?

00:00:00.902062 Host RAM: 1917MB total, 519MB available 
00:00:01.975928   RamSize         <integer> = 0x000000003b500000 (995 098 624, 949 MB)

The others on #10219 have ample memory available

comment:4 Changed 17 months ago by frank

Perry, you are right, actually there are two issues here: There is a VirtualBox bug which makes the guest trigger a Guru Meditation if the guest wants to allocate memory but isn't able to do so. The other problem is that on Windows hosts, sometimes there appears enough memory available but VirtualBox is not able to allocate more memory for the guest.

To make our life a bit easier I always mark such defects as duplicate of #10219 because sometimes it's not easy to decide if there is enough available memory or not.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use