VirtualBox

Ticket #1122 (closed enhancement: duplicate)

Opened 6 years ago

Last modified 5 years ago

[feature-request] Mount host filesystem as guest CD/DVD-ROM

Reported by: Technologov Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Asked on Forum by "LlamaNerds".

Please allow inserting any folder (chosen folder, a USB storage device, a network folder) into guest's CD-ROM, not just ISO.

Guest CD-ROM is always iso9660 FS, and currently to mount CD-ROM into guest, you need to specially prepare ISO image.

It would be easier to mount any host's folder, into guests CD-ROM device, and VirtualBox should make iso9660 FS on-the-fly (in RAM), without taking any extra hard disk space.

Of course this FS will be virtual and point to host's files.

Qemu does something very similar - they allow mounting virtual hard disk and floppy that way, on-the-fly trasferring calls from hosts FS into guest's FAT. It looks like: "-hda fat:/yourdir/" command.

Exceptions: of course exceptions must be handled, because ISO 9660 is more limited than other file systems, and put into a virtual file, seen from guest: "errors.txt", that will list all problematics files, such as over 2 GB, incorrect file name/encoding and stuff like that.

NOTE: This will partially replace the "shared folders" feature, without even requiring GuestAdditions !

-Technologov, 23.01.2008.

Change History

comment:1 Changed 6 years ago by Technologov

update: maybe current code of the "shared folders" could even be reused... just output into ISO9660 FS instead of VBoxFS. Change part of backend.

-Technologov

comment:2 Changed 5 years ago by Technologov

This bug is a duplicate of bug #1970

comment:3 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use