VirtualBox

Ticket #1117 (closed defect: worksforme)

Opened 6 years ago

Last modified 5 years ago

Windows BSOD during shutdown

Reported by: k776 Owned by:
Priority: critical Component: VMM
Version: VirtualBox 1.5.4 Keywords: crash,bsod,critical
Cc: Guest type: other
Host type: Windows

Description

I can load VBox, and close it (without loading a system). I can open it, load a system, and use it, but the moment I try to shut down, with any method (from in the system, from VBox gui, or using CTRL+ALT+DEL, I get a Blue Screen Of Death.

Host: Windows XP SP2 (all updates) Guest: Mandriva Linux 2008.1 (Alpha 2) with KDE4

I don't think its the host or guest themselves, cause on their own machines, they work fine. It only happens when I try to shut down, then I get one of several errors. I cant remember them all, but I remember something about "mutex"

VBox is great, and worked well in the past. It could just be this combination, but whether it is or not, it shouldn't cause a BSOD with windows xp.

Change History

comment:1 Changed 6 years ago by k776

"A kernel thread terminated while holding a mutex"

was the error I believe.

comment:2 Changed 6 years ago by sandervl73

  • Summary changed from Constant Windows BSOD very annoying to Windows BSOD during shutdown

You really need to give more information if you want us to help. First of all the VM log. Second a summary of software you've installed in the XP guest. Third if you have installed the VBox additions.

comment:3 Changed 6 years ago by k776

I don't have the log sorry (I uninstalled VirtualBox for now). I can say though that I tried another guest, and it worked fine. So it may have something to do with the new Mandriva 2008.1 alpha release (although I don't see how errors from that would cause windows to BSOD :S).

I have Windows XP SP2, all updates, and (at the time) no other virtualisation tools. I'm a web developer, so I mostly have browsers, editors, image editing, and other such multimedia tools. None of these cause the BSOD.

At the time, things like XAMPP, AVG, Comodo, Synaptics Touchpad, Power Management (on laptop), and wireless drivers were running (all of them are constantly on, never cause BSOD).

Mandriva supports VBox (probably 1.5.2), so the tools were installed when it first starts up. Is it possible old tools are causing the crashes?

And it actually gets to the end of shutdown. The BSOD is caused somewhere between the guest finishing, and the host going back to normal display (closing VBox window).

Anything else you need?

comment:4 Changed 6 years ago by sandervl73

If you have time, could you try to see if you get the same BSOD with the 1.5.4 additions installed? If so, then uninstall them afterwards and try again. A VM log might also help.

It's kind of hard to say what's going wrong right now.

comment:5 Changed 6 years ago by k776

Argh, I filed a new report. Thought this one had been deleted. Can someone mark this as duplicate? (the new ticket with updated information and log can be found here:  http://www.virtualbox.org/ticket/1354 )

comment:6 Changed 6 years ago by michael

#1354 has been marked a duplicate of this ticket.

comment:7 Changed 6 years ago by sandervl73

  • Host type changed from other to Windows

comment:8 Changed 6 years ago by frank

  • Component changed from other to VMM

k776, please provide a VBox.log file. Does this problem still exists with version 1.6.2?

comment:9 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Reopen if required. No reply for 5 months. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use