VirtualBox

Ticket #11155 (closed defect: worksforme)

Opened 18 months ago

Last modified 17 months ago

Second host-only network stuck on 169.254.x.y

Reported by: Ken Hagan Owned by:
Priority: minor Component: network/hostif
Version: VirtualBox 4.2.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

(From  https://forums.virtualbox.org/viewtopic.php?f=6&t=52404.)

In 4.2.2 (and now also in 4.2.4), if I create a second host-only adapter and try to set the IP address to 192.168.66.1 then VirtualBox accepts the input but ignores me. When I reboot the machine, there is a two-minute delay and I find that the adapter has been given an APIPA address that I cannot change. Equally, if I select the adapter in Windows' Control Panel (the host is Server 2008 R2) and try to change IPv4 settings there, I can type in the values but the adapter remains resolutely stuck on the 169.254.x.y. address.

This all worked in every version up to 4.2.0 (inclusive).

Attachments

VirtualBox.zip Download (10.0 KB) - added by Ken Hagan 18 months ago.

Change History

comment:1 Changed 18 months ago by aleksey

Could you please provide the log and VM config (.vbox) files? I was not able to reproduce the problem on win7 host. The second adapter was configured without any issues and stayed configured after host's reboot.

Changed 18 months ago by Ken Hagan

comment:2 Changed 17 months ago by Ken Hagan

I've attached the host's log and config files. The log seems rather spartan. Is there a more detailed log for the host's operations that I've missed?

The process of collecting those files proved rather painful. Upgrading back to 4.2.4 and reproducing the problem was painless enough. However, uninstalling 4.2.4 and reverting to 4.2.0 no longer fixes the problem. I'm now running with just the one host-only network and (since that works) I'm using 4.2.4 because there's no reason to stick with the earlier version.

comment:3 Changed 17 months ago by aleksey

I think you actually have two problems: (1) Both host-only adapter and DHCP server have the same IP address; you should change the address of DHCP server (one associated with the second host-only interface; the first adapter actually has the same problem, so you should experience communication trouble between the host and the guest with the first adapter too) in VirtualBox preferences dialog; (2) I think you have the host-only adapter configured to 'obtain IP address automatically' (that is, via DHCP) in Windows IPv4 properties. I believe the later causes the symptoms you have described.

comment:4 Changed 17 months ago by Ken Hagan

I'm a little confused. At least in the UI, the DHCP server facility of VBox is disabled, since I have a DHCP server running on the host, and the address in Windows IPv4 properties is static.

This is a configuration that has worked for a few versions of VBox now, and funnily enough it now seems to be working again. Sigh. The most likely explanation at this point is that my DHCP server on the host decided to start acting up just when I upgraded VBox and the latter has been blamed for the former's mis-behaviour.

Thanks for looking into it, aleksey. I no longer think there is a bug here. Can I close this ticket, or is that someone else's job?

comment:5 Changed 17 months ago by aleksey

I'm glad to help, Ken. I'll close the ticket.

comment:6 Changed 17 months ago by aleksey

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use