VirtualBox

Ticket #11079 (closed defect: fixed)

Opened 18 months ago

Last modified 2 months ago

VB does not save settings on Windows system where C:\Users\[User] directory is a junction point

Reported by: phoneguy Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.0 Keywords: NTFS junction
Cc: Guest type: other
Host type: Windows

Description

Host: Windows 7 Home Premium, 64-bit SP1 VirtualBox 4.2

My C:\Users\[User] directory is mapped via a Windows junction point to D:\Users\[User]. VirtualBox is unable to load/save settings from the [User]\.VirtualBox\VirtualBox.xml file.

VirtualBox starts without error. However, if I navigate to File > Preferences and make changes, nothing is saved. For instance, no matter what I do, these settings always come up the same: General > Default Machine Folder = <reset to default> General > VRDP Authentication Library = <reset to default> etc...

Attachments

VBoxSVC.log Download (1000 bytes) - added by phoneguy 18 months ago.

Change History

Changed 18 months ago by phoneguy

comment:1 Changed 2 months ago by bird

  • Status changed from new to closed
  • Resolution set to fixed

Cannot reproduce this with 4.3 or trunk on windows 7. Moving the user directory to a different drive and placing a junction point in c:\users to link to it works fine. I've also tried linking just the c:\users\xxxx\.VirtualBox directory to a different place and that work fine to (in fack I've been doing that during all of 4.3 development).

Upgrade to 4.3 and reopen the defect if the propblem persists.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use