VirtualBox

Ticket #11066 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

OSX-Guest on VirtualBox

Reported by: typoworx Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.0 Keywords: OSX Guest
Cc: Guest type: other
Host type: other

Description

I installed OSX on a previous Version of Virtualbox 4.2 and was able to get it running using Original Install-CD using EFI-Mode in Virtualbox.

Since upgrading to VirtualBox 4.2.0 which seems to have an upgraded/altered EFI-Interface (new Menu?) I cannot boot into OSX any more.

Instead of booting EFI (either OSX-CD or existing OSX-System from VDI) I see the UEFI Helper-System coming up...

Is there any info on this bug yet? I see some errors showing up shortly while the VirtualBox BIOS Screen is shown.

Btw. I'm using the Windows-Binary (Windows PC).

Attachments

I7ay.jpeg Download (73.8 KB) - added by typoworx 3 years ago.
Virtualbox Bootup throwing some errors (see left upper corner)
I7aK.jpeg Download (74.7 KB) - added by typoworx 3 years ago.
Screenshot of UEFI Boot -- here usually my OSX-Guest would boot-up…

Change History

comment:1 Changed 3 years ago by Hachiman

Could you please attach your log and what do you mean by "cannot boot" (UEFI command line, OSX kernel panic)?

Changed 3 years ago by typoworx

Virtualbox Bootup throwing some errors (see left upper corner)

Changed 3 years ago by typoworx

Screenshot of UEFI Boot -- here usually my OSX-Guest would boot-up...

comment:2 Changed 3 years ago by typoworx

See the screenshots attached above. It was not easy to catch the first one (VirtualBox BIOS)... on the 2nd. Screenshot I previously had a working OSX-Boot progress. It was working on a previous version of VirtualBox (Sorry, cannot say which one I had before the upgrade).

comment:3 Changed 3 years ago by Hachiman

comment:4 Changed 3 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to fixed

comment:5 Changed 3 years ago by typoworx

I can agree that Version 4.2.1 seems to have fixed the errors thrown in the screenshots that have been attached.

BUT the OSX Guest-Machine (using EFI-Mode) still doesn't boot properly. It runs into something like a kernel error.

To be shure there is no configuration mistake (since the upgrade to 4.2.x) I've downgraded VirtualBox back to latest 4.1.22 (r80657) and voila - the OSX Guest worked again without any change to the VBox configuration!

So there still must be any other error that blocks booting of OSX/EFI Guests on 4.2.x.

Is there anybody who can confirm/disconfirm that? If there is anybody able to run OSX Guests using EFI please let us know how.

So please re-open these bugtrack...

BTW: I also tried the EFI-Hacks for X86 Machines using a tiny Bootloader-ISO that should help PC's running (Intel-based) OSX-Guests without EFI (also known as "Hackintosh" Loaders). But none of these tools worked yet for me (tested on real PC and VirtualBox).

Version 1, edited 3 years ago by typoworx (previous) (next) (diff)

comment:6 Changed 2 years ago by grahamperrin

This is a significant, and most welcome change.

Please, is the changeset reference known?

fixed in 4.2.1

Is it too late to improve the changelog https://www.virtualbox.org/wiki/Changelog for 4.2.2?

Thanks :-)


General public awareness

In #9388 I was unaware of the improvements –

Support Mac OS X 10.7 Lion Guest


(Side note: in an earlier edition of this comment I was a bit stroppy. It was misplaced anger, a reaction to bad manners that were shown to me in a different area of the virtualbox.org domain. This ticket with its fix was a rotten place for me to throw a strop – sorry!)

Last edited 2 years ago by grahamperrin (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use