VirtualBox

Ticket #10980 (closed defect: duplicate)

Opened 19 months ago

Last modified 19 months ago

Guru Meditation -400 on Win 2008 R2 Guest

Reported by: Jeffska Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Guru Meditation -400 (VERR_NET_IO_ERROR) on Windows 2008 R2 Guest running on Linux host. Happened twice since upgrading to 4.2.0. Logs attached.

Attachments

VBox.log.tar.gz Download (84.7 KB) - added by Jeffska 19 months ago.
Log file
MountainLion-2012-09-23-00-30-34.log.bz2 Download (47.8 KB) - added by HuronMaramba 19 months ago.
Guru Meditation -400 Mac OS X, Gentoo Linux x86_64
MountainLion-2012-09-24-20-42-21.log.bz2 Download (20.3 KB) - added by HuronMaramba 19 months ago.
Host Gentoo x86_64, Guest Mac OS X Mountain Lion 10.8.1 Network errors

Change History

Changed 19 months ago by Jeffska

Log file

comment:1 Changed 19 months ago by HuronMaramba

I have a similar problem under VirtualBox 4.2.0, host - Gentoo Linux x86_64, guest - Mac OS X MountainLion. Reproducible as much as you want. It happened always while saving file from RPP application to NFS or Samba share on Linux host from the Guest Mac OS X. Sometimes on the first file, in rare case on second file. It reproducible when just copying files by NFS or SMB from guest also. Not reproducible when saving files from RPP to local drive in VM.

Last edited 19 months ago by HuronMaramba (previous) (diff)

Changed 19 months ago by HuronMaramba

Guru Meditation -400 Mac OS X, Gentoo Linux x86_64

comment:2 Changed 19 months ago by aleksey

Can you try to disable R0/GC for e1000 and reproduce the problem? To disable R0 use the following command lines:

VBoxManage setextradata <vm_name> VBoxInternal/Devices/e1000/<adapter_number_starting_with_0>/Config/GCEnabled 0
VBoxManage setextradata <vm_name> VBoxInternal/Devices/e1000/<adapter_number_starting_with_0>/Config/R0Enabled 0

Note that you will need to do it for each adapter used in VM. If later on you change the type of any adapter (to pcnet or virtio) you will get an error while starting VM. To get rid of it use the same commands as above but without '0' at the end of the line. After you disable RO/GC you may get a different error (not Guru Meditation). Please attach the resulting log file as well.

comment:3 Changed 19 months ago by HuronMaramba

Hi, Aleksey, Thank you for reply!

I'm not absolutely sure that my commands were correct. In the my VM, that called MoutainLion, only the second network adaptor was enabled and it mode was set to bridged. When I did the following command: "VBoxManage setextradata MountainLion VBoxInternal/Devices/e1000/0/Config/R0Enabled 0", I've got error VM couldn't be started with message "Failed to get mac address" and "NS_ERROR_FAILURE (0x80004005)".

So I leave the following commands and all look OK:

VBoxManage setextradata MountainLion VBoxInternal/Devices/e1000/1/Config/R0Enabled 0
VBoxManage setextradata MountainLion VBoxInternal/Devices/e1000/1/Config/GCEnabled 0

 $ VBoxManage list vms
"MountainLion" {a712dae7-3186-47a8-a97f-f84762ce0a80}

 $ VBoxManage setextradata MountainLion VBoxInternal/Devices/e1000/1/Config/R0Enabled 0
 $ VBoxManage setextradata MountainLion VBoxInternal/Devices/e1000/1/Config/GCEnabled 0
 $ egrep 'R0E|GCE' .VirtualBox/Machines/MountainLion/MountainLion.vbox
      <ExtraDataItem name="VBoxInternal/Devices/e1000/1/Config/GCEnabled" value="0"/>
      <ExtraDataItem name="VBoxInternal/Devices/e1000/1/Config/R0Enabled" value="0"/>

After boot I tried to reproduce Guru Meditation -400 error. On the second file I usually get error but this time I've got only network problems in the VM . Ping to both default router or host was not work. But network adapter state was good - flags UP and RUNNING, and it has IP-address and routing was correct. I've downed and then upped network interface with ifconfig. After some seconds connection was restored and NFS got working too. After 20 - 30 seconds connection lost again. Down and up interface was helpful again.

I was unable to reproduce error by copying large data by network between guest and host. More than 1.2 Gb was transferred without any problems but slowly (1 gb/15 minutes). My target application - RPP still born network errors when trying to save files by network.

Last edited 19 months ago by HuronMaramba (previous) (diff)

Changed 19 months ago by HuronMaramba

Host Gentoo x86_64, Guest Mac OS X Mountain Lion 10.8.1 Network errors

comment:4 Changed 19 months ago by aleksey

Thanks a lot for the log. It confirms the problem: TX descriptor cache is too small to fit large TSE packets. The fix will be included into the next maintenance release. Meanwhile you can try to work around the problem by disabling 'Large Send Offload' property in 'Advanced' tab of adapter properties in the guest.

comment:5 Changed 19 months ago by aleksey

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10936.

comment:6 Changed 19 months ago by aleksey

The test build with the fix can be downloaded from here:  http://www.virtualbox.org/download/testcase/VirtualBox-4.2.1-80944-Linux_amd64.run

Version 1, edited 19 months ago by aleksey (previous) (next) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use