VirtualBox

Ticket #10969 (closed defect: duplicate)

Opened 19 months ago

Last modified 19 months ago

Mac OS X VM crashes when accessed via VNC

Reported by: hgoshev Owned by:
Priority: blocker Component: guest control
Version: VirtualBox 4.2.0 Keywords: crash VNC remote
Cc: Guest type: OSX Server
Host type: Mac OS X

Description

I am using the latest VirtualBox with the Extension Pack installed. I am running a Mac OS X Server VM and have configured screen sharing on it through the system preferences. However each time I try to access the VM remotely via VNC, it crashes almost immediately with the following message: "A critical error has occurred while running the virtual machine and the machine execution has been stopped". This happens regardless of what type of VNC client I use. I tried modifying the VM's properties like CPU count, RAM size, video memory, 2D/3D acceleration and so on, but nothing has helped.

Attachments

VBox.log Download (361.5 KB) - added by hgoshev 19 months ago.

Change History

Changed 19 months ago by hgoshev

comment:1 Changed 19 months ago by aleksey

Can you try to disable R0/GC for e1000 and reproduce the problem? To disable R0/GC use the following command lines:

VBoxManage setextradata <vm_name> VBoxInternal/Devices/e1000/<adapter_number_starting_with_0>/Config/GCEnabled 0
VBoxManage setextradata <vm_name> VBoxInternal/Devices/e1000/<adapter_number_starting_with_0>/Config/R0Enabled 0

Note that you will need to do it for each adapter used in VM. If later on you change the type of any adapter (to pcnet or virtio) you will get an error while starting VM. To get rid of it use the same commands as above but without '0' at the end of the line. After you disable RO/GC you may get a different error (not Guru Meditation). Please attach the resulting log file as well.

comment:2 Changed 19 months ago by aleksey

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10936.

comment:3 Changed 19 months ago by aleksey

The test build with the fix can be downloaded from  here.

Version 2, edited 19 months ago by frank (previous) (next) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use