VirtualBox

Ticket #10965 (closed defect: fixed)

Opened 19 months ago

Last modified 9 months ago

Cannot start VM in Mac OS X 10.8.2 => Fixed in SVN

Reported by: rdwdivx Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.2.0 Keywords: 10.8.2 vmx
Cc: Guest type: Linux
Host type: Mac OS X

Description

I have already upgraded to Vbox 4.2 and it was working fine. I then upgraded to OS X 10.8.2 today, and when booting any VM, I get the following error:

VT-x is being used by another hypervisor. (VERR_VMX_IN_VMX_ROOT_MODE). VirtualBox can't operate in VMX root mode. Please close all other virtualization programs. (VERR_VMX_IN_VMX_ROOT_MODE).

Apparently this was an issue already present in the 10.8.2 beta, but it was not fixed on Apple's side.

Attachments

VBox.log Download (78.2 KB) - added by rdwdivx 19 months ago.

Change History

Changed 19 months ago by rdwdivx

comment:1 Changed 19 months ago by russ

I'm finding this too.

Failed to open a session for the virtual machine Windows XP.

VT-x is being used by another hypervisor. (VERR_VMX_IN_VMX_ROOT_MODE).

VirtualBox can't operate in VMX root mode. Please close all other virtualization programs. (VERR_VMX_IN_VMX_ROOT_MODE).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

comment:2 Changed 19 months ago by snowyau

I can confirm this after the 10.8.2 update on my mid-2012 11" macbook air. None of the virtual machines start.

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}''

comment:3 Changed 19 months ago by Jan

Same problem here. During the addition of another virtual machine this happened. The update for the OS 10.8.2 came automatically. Now none of the virtual machines is running. Will try to go back on the OS from Apple. My MacBook Pro is just two weeks old. The Apple software seems to be running still.

comment:4 Changed 19 months ago by kemptenkid

I just upgraded to 10.8.2 on MacBook Air. Tried to execute Guest VM's with same errors experienced by fellow users. Guest VM's include SUse Linux, RedHat and Windows, all with same errors.

comment:5 Changed 19 months ago by chadwhitaker

Many have noted that this issue might be due to an EFI Firmware upgrade.

It appears that Ivy Bridge 2012 Macbook Pros & Macbook Airs have an EFI Firmware Update and this is causing the error, not the 10.8.2 upgrade.  http://support.apple.com/kb/DL1592

http://f.cl.ly/items/3Y0f3l1N1N0E280R0z1F/Snapshot%209:20:12%209:01%20AM.png

comment:6 Changed 19 months ago by frank

Why do you think it's the EFI update?

comment:7 Changed 19 months ago by leepa

It's not the EFI Update - I haven't installed the EFI update on an Ivy Bridge 2012 Air and I do have 10.8.2.

comment:8 Changed 19 months ago by SteveMarshall

Definitely not the EFI update: I installed that (because I was suffering from constant reboots, which the MBP EFI update fixes) but not 10.8.2 and VirtualBox 4.2 is working just fine for me. (But isn’t working on an identical, bought-at-same-time, 10.8.2’d Mac with the EFI update.)

comment:9 Changed 19 months ago by logatron

I am also experiencing this issue on a MacBook Air 5,2 running 10.8.2 and VirtualBox 4.2 with the EFI update.

comment:10 Changed 19 months ago by ogre

Seeing this as well, 10.8.2, VirtualBox 4.2.

comment:11 follow-up: ↓ 14 Changed 19 months ago by frank

Just to mention it, we are aware of that issue and working on a fix. Once we have one we will quickly provide test builds for VBox 4.2.x and 4.1.x.

comment:12 Changed 19 months ago by GregK

Time frame for the fix?

comment:13 Changed 19 months ago by Haldor

I have a 2012 MBA and a 2011 iMAC. Both are upgraded to 10.8.2. Virtualbox WORKS on the iMac but does not work on the MBA. Virtualbox did work on the MBA prior to the firmware upgrade.

comment:14 in reply to: ↑ 11 Changed 19 months ago by zx5000

Replying to frank:

Just to mention it, we are aware of that issue and working on a fix. Once we have one we will quickly provide test builds for VBox 4.2.x and 4.1.x.

Thanks for working on it!

comment:15 Changed 19 months ago by gmclelland

Just an FYI.. we have new(purchased in August) non-retina MacBook Pros that are experiencing this problem as well.

Also for reference here is the Virtualbox forum thread  https://forums.virtualbox.org/viewtopic.php?f=8&t=51331 for this issue.

comment:16 Changed 19 months ago by xuhdev

I also have this problem with retina display MacBook Pro after the upgrade. The guest is OpenSUSE.

comment:17 Changed 19 months ago by mukul_d

I am also having the same issue. I updated the thread as well.

Again: If you need someone to test the new builds, I am volunteering myself.

comment:18 follow-up: ↓ 19 Changed 19 months ago by oraclewebaccount

Same problem on MacBookAir5,2 (Late 2012, Core i7) after EFI Firmware 2.5 update and Mac OS X 10.8.2 upgrade.

comment:19 in reply to: ↑ 18 Changed 19 months ago by Mark Gregory

Its NOT the EFI Firmware update it's the way 10.8.2 enables the switching, I had the same issue, but I always backup to Time Machine before an update / upgrade. Restored back to 10.8.1 and everything is working fine again. The interesting thing is that the change to the VTx switching also causes issues with Parallels and VMWare.

So restore from Time Machine, Or if you have no backup built a new (smaller) 10.8.1 partition boot to it and you will see VB operates fine.

comment:20 Changed 19 months ago by spoutnikfr

Disabling the VT-x acceleration in the configuration of the guest totaly freeze your Mac so don't try it. Agree that it's NOT the EFI update that caused this issue. After using an old clone running 10.8.1 it work fine.

comment:21 follow-ups: ↓ 35 ↓ 38 Changed 19 months ago by frank

A 4.1.23 hotfix package is now available  here.
A 4.2.1 hotfix package is now available  here.

Please confirm that these builds fix the problems you saw on Mac OS X 10.8.2.

comment:22 Changed 19 months ago by mag

Just tested VirtualBox-4.2.1-80871-OSX.dmg and it works now. Good work guys.

comment:23 Changed 19 months ago by erikhl

Just tested VirtualBox-4.1.23-80870-OSX.dmg and now vagrant and VirtualBox works fine. Great work!

comment:24 Changed 19 months ago by kdom

Tested with VirtualBox-4.1.23-80870-OSX.dmg and it works. Thanks

comment:25 Changed 19 months ago by spoutnikfr

Seem's to be working fine with 4.2 fixe

Thanks a lot for this super speed fix :D

comment:26 Changed 19 months ago by d2kagw

Brilliant stuff. The 4.2 fixed the errors.

comment:27 Changed 19 months ago by beaufour

Fixed the problem for me. Thanks for the quick turnaround. Much appreciated!

comment:28 Changed 19 months ago by SteveH

The 4.2.1 hotfix works for me!

comment:29 in reply to: ↑ description Changed 19 months ago by EricD

The 4.2.1 hotfix resolved the problem on a 2010 Retina MBP: 2.3 GHz Intel Core i7

Thank you for the expedient fix.

comment:30 Changed 19 months ago by mak10

Works for me as well. I tried the 4.1.23 hotfix package.

I am on MBP with Retina display, OSX 10.8.2 and have the latest EFI firmware update installed.

Thank you very much! Appreciate the lighting fast turn around.

Last edited 19 months ago by mak10 (previous) (diff)

comment:31 Changed 19 months ago by kemptenkid

OSX 10.8.2 on MacBook Air, with VB 4.2.1 with hotfix works now, Thanks for the quick fix.

comment:32 Changed 19 months ago by frank

  • Summary changed from Cannot start VM in Mac OS X 10.8.2 to Cannot start VM in Mac OS X 10.8.2 => Fixed in SVN

Thank you all for the positive feedback! Leaving this bug open. Of course, the fix will be also part of the next maintenance releases.

comment:33 Changed 19 months ago by kwrl

Great work! Had some headache for the last 24 hours! :) Thank you for the quick fix.

MBPro Mid 2012, non-Retina, OSX 10.8.2, newest EFI, VBox 4.2

comment:34 Changed 19 months ago by zx5000

Thank you!

comment:35 in reply to: ↑ 21 Changed 19 months ago by dettix59

VirtualBox-4.2.1-80871-OSX.dmg works fine on Mac OS X 10.8.2 Thanks for the quick fix.

comment:36 Changed 19 months ago by RoadKing89

Fixed my issue too. Thanks as well for the quick fix!!!

comment:37 Changed 19 months ago by emc2

Just wanted to give my own kudos to you guys. I just ran into the problem this morning after updating OS X last night. Pretty amazing to have a fix available already. Thanks!

comment:38 in reply to: ↑ 21 Changed 19 months ago by rafa

4.2.1 hotfix package is working fine with Mac OSX 10.8.2 in a Mac Book Pro Core i7 8GB non-retina display. Thank you Guys!!

comment:39 Changed 19 months ago by designdream

NM> Just found the hotfix above. Thank you!

Last edited 19 months ago by designdream (previous) (diff)

comment:40 follow-up: ↓ 43 Changed 19 months ago by kimus

It's only me or with this hotfix 4.2 when I do cmd+e (to start Explorer) it starts Explorer but also inputs the character 'e' in the current focused application (ex: Notepad).

comment:41 Changed 18 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Closing as the fix is now also part of the 4.2.2 release. kimus, if you still have this problem, please open another ticket.

comment:42 Changed 18 months ago by kimus

I still having problems and I already open another issue (#10993).

comment:43 in reply to: ↑ 40 ; follow-up: ↓ 44 Changed 9 months ago by crm system

I'm having this issue too .

Kind regards Crm system

comment:44 in reply to: ↑ 43 ; follow-up: ↓ 45 Changed 9 months ago by crm system

Ups a bit too quick on the keyboard. I was refering to kimus's comment, but i can see from franks comment that another ticket needs to be make.

Replying to crm system:

I'm having this issue too .

Kind regards Crm system

Replying to kimus:

It's only me or with this hotfix 4.2 when I do cmd+e (to start Explorer) it starts Explorer but also inputs the character 'e' in the current focused application (ex: Notepad).

Replying to  crm system:

Closing as the fix is now also part of the 4.2.2 release. kimus, if you still have this problem, please open another ticket.

Version 0, edited 9 months ago by crm system (next)

comment:45 in reply to: ↑ 44 Changed 9 months ago by kimus

Replying to crm system:

Ups a bit too fast on the keyboard. I was refering to kimus's comment, but i can see from franks comment that another ticket needs to be make.

Hi, did you notice that I already open another ticket (#10993) about keyboard problems? If you have the same problem please comment on that ticket and do not open a duplicate.

If you have another problem please open another ticket of course. :-)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use