Ticket #10958 (new defect)

Opened 9 years ago

Last modified 3 years ago

Windows guest does not recognized Broadcom 5880 smart card reader

Reported by: armillz Owned by:
Component: USB Version: VirtualBox 4.2.0
Keywords: smart card Cc:
Guest type: Windows Host type: Windows


I have a Dell Latitude E6520 with a built in Broadcom 5880 smart card reader that refuses to work inside my Windows Guest OS. Some relevant notes:

  • the 5880 reader works fine on my host system.
  • if I plug in an external USB smart card reader (SCR3310), that works fine inside the guest OS
  • the built in 5880 reader works fine in a guest if I use VMware.

Virtual box will allow me to connect the 5880 from the USB devices menu. It then indicates a lot of flashing red/green lights on the USB icon, but my smart card software inside the guest (ActivClient) does not recognize that a reader is present. Inserting/removing the card has no effect.

My configuration:

  • Windows 7 64-bit Professional on the host, 8GB RAM
  • Windows 2008 R2 64-bit as the guest, 3.5GB RAM

I just updated to VirtualBox 4.2 but have tried this on a bunch of previous 4.0 and 4.1 versions. I was hoping this would eventually be fixed. My googling through the community indicates that others have had this problem and it has never been solved.

Any idea how to make this work or whether it will be fixed?

Change History

comment:1 Changed 9 years ago by Hachiman

Could you please attach your log file?

comment:2 Changed 9 years ago by AllTheVbox!

It's been a perennial pain trying to get VirtualBox to properly recognize integrated Broadcom 5880 Smart Card readers on Dell laptops (in my case using an Ubuntu 11.04 host and Windows guests), even when the card reader checks out fine under on the host and you pass the device through exclusively to the guest. Worse yet, as of my installation of a Windows 7 guest, I can't even get my trusty SCR3310 reader to work on the guest OS. :(

I know virtual machines can handle this hardware - see VMWare - and this is a well known problem for VirtualBox, so I'm at a loss as to why crickets chirp whenever a user submits one of these tickets. Will someone at Oracle please, PLEASE at least acknowledge that this is a problem, explain why it's happening, and provide a sense of whether there is a technical approach to fix it in a future release?


Last edited 9 years ago by AllTheVbox! (previous) (diff)

comment:3 Changed 9 years ago by ubeinges

I've got the same problem with a Windows XP SP3 guest. The error remains the same throughout all versions of VB 4.1.x and 4.2.x I tried. The same card reader works fine with the same guest installation when I use it in VMware player. So this must be a Virtualbox issue.

Could you please fix this!

comment:4 Changed 9 years ago by ubeinges

Tested today with brandnew version 4.2.2. Issue is still present.

comment:5 Changed 8 years ago by MatNe

Still the same problem - please fix it, I need the smartcard driver in Virtualbox too.

Last edited 8 years ago by MatNe (previous) (diff)

comment:6 Changed 8 years ago by mobbingmaster

Still the same problem! Please fix it - this is currently the only reason why we still need the VMWare Player - all other VMs are running under VirtualBox.

comment:7 Changed 8 years ago by Jon Roach

I have the same problem with a Dell E6400 internal reader. VMWare Player can pass the Broadcomm card reader through with no problem, so why can't VirtualBox? VB has been dogged by this particular problem for years, and I'm starting to think it will never be fixed.

Please fix it: I'm dying to get rid of VMWare Player, but am currently stuck with it because the Smart Card is a critical part of the remote access solution for our company and VirtualBox just can't support it. Yet.

I'm running 64-bit Ubuntu 12.04 LTS with a 64-bit Windows 7 Pro guest.

Last edited 8 years ago by Jon Roach (previous) (diff)

comment:8 Changed 7 years ago by slowhog

Sam problem here. Tried enable/disable EHCI, tried filter(and not) the device.

Host is Arch Linux, guest is Windows XP SP3.

comment:9 Changed 5 years ago by x314ce

version 5.0.22 ... still not working

comment:10 Changed 5 years ago by championofcyrodiil

Running 5.0.24 on Debian Jessie 64-bit, backports (kernel 4.6)

I also have had the same issue. For years I've used a USB Keyboard w/ Built-in card reader because the broadcom smartcard reader in the laptop always had issues.

I recently received a new Dell Precision 7710. This model has replaced the previously common Dell Precision M6500/M6700/M6800 series that is no longer in production. To my surprise the same smart card reader is detected, Bus 001 Device 003: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor.

I am able to attach this USB device to Virtualbox, and I can also see the Card Reader from the device manager and 3rd party smart card reader software we use on the windows 10 VM.

However when i physically insert a smart card, nothing happens. The Debian OS can read the card from the laptop's broadcom 5880 using opensc, and Virtualbox works fine with the Dell USB Keyboard w/ Built-in card reader. But the 5880 still doesnt work w/ virtualbox.

I've wondered recently if this has anything to do with the TPM and CPU. Code execution on the TPM i believe works with the card reader, so maybe this is related?

comment:11 Changed 4 years ago by sandman

this problem still exists in v5.1.22

my host is win7x64 Enterprise on a dell e7450 with a Broadcom 5880 reader

my guest is win7x64 Pro; the guest OS sees the card reader devices but when I insert the smartcard the guest os does not recognize the card. I've tried everything I've read on the web and the virtualbox forum.

using a 3rd party card reader with the guest OS, I can access the smartcard. but this requires me dragging around the external card reader

also, I exported/imported the VM to VMWare Player, the VMWare can access the smartcard via the Broadcom 5880 reader.

what do we need to do/provide to get this fixed? I really want to use VirtualBox!

comment:12 follow-up: ↓ 13 Changed 4 years ago by socratis

If you read the  USB basics and troubleshooting how-to, in part 3 you'll see that your device most probably falls in the "Uncapturable" category.

comment:13 in reply to: ↑ 12 Changed 4 years ago by sandman

Replying to socratis:

If you read the  USB basics and troubleshooting how-to, in part 3 you'll see that your device most probably falls in the "Uncapturable" category.

how can i verify this? what would I look for in the log, or Guest OS

comment:14 Changed 4 years ago by socratis

No, you should look in the host. "Uncapturable" would be a device that the host has gotten a hold of most probably via a service and won't let go as long as the service is active.

A similar old discussion ( Broadcom 5880 Smart Card Reader) just woke up in the forums. Let's continue the discussion in the forums (that's their purpose ;) ).

comment:15 Changed 4 years ago by LiamH

This problem is not guest-OS specific. I am using Debian 9.1 with the  PCSC lite software and find that it fails (while in the host OS, Windows 7, it works fine). The problem seems to be that USB commands are not getting through

00000004 -> 000000 65 00 00 00 00 00 00 00 00 00
00000246 ccid_usb.c:797:WriteUSB() write failed (1/3): -1 LIBUSB_ERROR_IO
00000008 -> 000000 65 00 00 00 00 00 01 00 00 00
00000487 ccid_usb.c:797:WriteUSB() write failed (1/3): -1 LIBUSB_ERROR_IO
00000020 -> 000000 65 00 00 00 00 00 02 00 00 00
00000485 ccid_usb.c:797:WriteUSB() write failed (1/3): -1 LIBUSB_ERROR_IO
00000006 ifdhandler.c:195:CreateChannelByNameOrChannel() failed

comment:16 Changed 3 years ago by aeichner

Please attach at least a VBox.log of the affected VM and if possible the kernel log from the Debian inside the VM.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use