VirtualBox

Ticket #10942 (closed defect: obsolete)

Opened 4 years ago

Last modified 6 weeks ago

Crash on RDP disconnect of Windows XP Guest

Reported by: tgrundle Owned by:
Priority: major Component: RDP
Version: VirtualBox 4.2.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Stating with 4.1.22 and continueing 4.2, when i disconnect an RDP client from a Windows XP SP3 Guest, the VM aborts.

I will attack the Guest Log (thought there is not much in it) and upload a core to ftp.oracle.com:/appsdev/incoming as per the docs.

Attachments

VBox.log Download (56.0 KB) - added by tgrundle 4 years ago.
VBox.2.log Download (132.7 KB) - added by ...don 6 months ago.

Change History

Changed 4 years ago by tgrundle

comment:1 Changed 4 years ago by sunlover

Do you mean that the VirtualBox crashes, when the RDP client disconnects? Does this happen always? I'm asking because the attached log contains a number of successful connections. Which client do you use, rdesktop?

Also please give more details. Which RDP client option do you use? What are exact steps to reproduce this?

We never seen this problem so any additional info will be useful.

comment:2 Changed 4 years ago by frank

Thanks for the core dump. Please give me 1-2 more days time.

comment:3 Changed 4 years ago by frank

I've analyzed the core dump. Looks like some stack corruption, therefore hard to find the actual reason. Therefore it would help further if you could answer the questions from sunlover, especially if this happens always and which RDP client you use.

comment:4 Changed 4 years ago by tgrundle

Yes VirtualBox crashes when the RDP client disconnects. I've seen it both with rdesktop and remmina. It was happening on the first disconnect, however, when I went to take the core dump it took a couple of connects/disconnects before it occurred. Since then the frequency has decreased, but still present. I run the VM in headless mode as a "system" account so any user on the box can remote into the VM.

Here are the RDP clients installed.

timothy@james:~$ dpkg -l |grep rdesktop

ii rdesktop 1.7.0-1ubuntu2 RDP client for Windows NT/2000 Terminal Server

timothy@james:~$ dpkg -l |grep remmina

ii remmina 1.0.0-1ubuntu6.1

Client arguments:

rdesktop -r sound:local localhost
remmina -c .remmina/Diesel.remmina

Remmina File:

[remmina] disableclipboard=0
ssh_auth=0
clientname=
quality=9
ssh_charset=
ssh_privatekey=
console=0
resolution=1280x960
group=
password=
name=Diesel
ssh_loopback=0
shareprinter=0
ssh_username=
ssh_server=
security=rdp
protocol=RDP
execpath=
sound=local
exec=
ssh_enabled=0
username=
sharefolder=
domain=
server=localhost
colordepth=32
viewmode=1
window_maximize=1

comment:5 Changed 6 months ago by ...don

My Windows 10 VMs abort whenever I disconnect from the RDP display defined on the host using the Settings/Display/RemoteDisplay option. This happens for multiple Windows clients and using various RPD client software.

Changed 6 months ago by ...don

comment:6 Changed 6 months ago by ...don

To reproduce: 1) Setup and enable an RDP connection using the Settings/Display/Remote Display option on the host. 2) Start the VM. 3) Connect to the VM using a standard Microsoft RDP client. 4) do some work. 5) Disconnect the RDP client. 6) The state of the VM immediately changes to 'Aborted'.

comment:7 Changed 6 months ago by sunlover

Does the crash happen if you disable 3D acceleration in the VM settings?

comment:8 Changed 6 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use