VirtualBox

Ticket #10936 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Guru Meditation VERR_NET_IO_ERROR: Windows 2008 R2 during update request to WSUS => Fixed in SVN

Reported by: yesoos Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.2.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

With latest virtualbox 4.2.0, my virtual Windows 2008 R2 machine hosting WSUS for other machines crashes when requested updates. This happens everytime. All machines use bridged networking, guest additions are at latest version.

Attachments

VBox.log Download (486.5 KB) - added by yesoos 3 years ago.
Log file from crashing machine
VBox.png Download (106.6 KB) - added by yesoos 3 years ago.
PNG file

Change History

Changed 3 years ago by yesoos

Log file from crashing machine

Changed 3 years ago by yesoos

PNG file

comment:1 Changed 3 years ago by frank

  • Summary changed from Windows 2008 R2 machine crash during update request to WSUS. to Guru Meditation VERR_NET_IO_ERROR: Windows 2008 R2 during update request to WSUS

comment:2 Changed 3 years ago by aleksey

Can you try to disable R0/GC for e1000 and reproduce the problem? To disable R0/GC use the following command lines:

VBoxManage setextradata <vm_name> VBoxInternal/Devices/e1000/<adapter_number_starting_with_0>/Config/GCEnabled 0
VBoxManage setextradata <vm_name> VBoxInternal/Devices/e1000/<adapter_number_starting_with_0>/Config/R0Enabled 0

Note that you will need to do it for each adapter used in VM. If later on you change the type of any adapter (to pcnet or virtio) you will get an error while starting VM. To get rid of it use the same commands as above but without '0' at the end of the line. After you disable RO/GC you may get a different error (not Guru Meditation). Please attach the resulting log file as well.

comment:3 Changed 3 years ago by aleksey

This is a confirmed 4.2 regression. The fix will be included into the next maintenance release. You can temporarily disable 'Large Send Offload' property in 'Advanced' tab of adapter properties in the guest to work around the problem.

comment:4 Changed 3 years ago by aleksey

  • Summary changed from Guru Meditation VERR_NET_IO_ERROR: Windows 2008 R2 during update request to WSUS to Guru Meditation VERR_NET_IO_ERROR: Windows 2008 R2 during update request to WSUS => Fixed in SVN

comment:5 Changed 3 years ago by aleksey

The test build with the fix can be downloaded from here:  http://www.virtualbox.org/download/testcase/VirtualBox-4.2.1-80944-Win.exe

Version 1, edited 3 years ago by aleksey (previous) (next) (diff)

comment:6 Changed 3 years ago by linarms

FYI, even with the stated workaround, Windows 2008 R2 guests still eventually crash with "Guru Meditation -400 (VERR_NET_IO_ERROR)" -- after moving ~55GB of data, in my case, and the server was running Exchange, not WSUS (although I first came across the issue on a WSUS guest). I mention this just in case the issue is bigger than it seems so far. Happy to provide further log files if needed.

EDIT: Host is Linux (Debian) running 4.2.0 (no hotfix available yet?)

Last edited 3 years ago by linarms (previous) (diff)

comment:7 Changed 3 years ago by frank

 Here is a .deb package for Debian 6.0 / AMD64 and  here is a 64-bit .run package as universal installer.

comment:8 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.2.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use