VirtualBox

Ticket #10933 (closed defect: fixed)

Opened 19 months ago

Last modified 12 months ago

Hold key rate slow afer resume state guest machine => Fixed in SVN

Reported by: yann458 Owned by:
Priority: major Component: guest control
Version: VirtualBox 4.2.0 Keywords: keyboard,rate,slower
Cc: Guest type: all
Host type: all

Description

Hello, Since version 4.2 of VirtualBox, When I call the user function Restore State guest machine that's OK,with out problem. The only problem: when I hold press a key of keyboard (without upping) the timer (rate) repeat character is slower.

To reproduce: _ Start the guest machine and boot Windows XP , Seven _ Run NotePad.exe

The everything is OK.

_ Suspend state guest machines _ Resume state guest machines _ Run NotePad.exe _ Press and hold a key of keyboard then the rate of repeat is slower.

Thank you.

Change History

comment:1 Changed 19 months ago by yann458

I forget [BR]

Hello, Since version 4.2 of VirtualBox, When I call the user function Restore State guest machine that's OK,with out problem. The only problem: when I hold press a key of keyboard (without upping) the timer (rate) repeat character is slower.

To reproduce:

_ Start the guest machine and boot Windows XP , Seven

_ Run NotePad.exe


The everything is OK.

_ Suspend state guest machines

_ Resume state guest machines

_ Run NotePad.exe

_ Press and hold a key of keyboard

Then the rate of repeat is slower.



Thank you.

comment:2 Changed 17 months ago by danf84

I find myself having to set keyboard repeat rate in my Windows XP Guest now and then. Although it is set to maximum, I have to slide it away and back to max again; then the repeat rate is as it should be; VirtualBox 4.2.4 thanks.

comment:3 Changed 15 months ago by bjh

I have the same problem. Key repeat rate drops to minimum speed after resuming a suspended VM. VirtualBox 4.2.6. Host is Linux Mint 14 64 bit Seems to affect all windows guests (tried 2K, XP, 7-32 & 7-64) and OS/2. Linux guests are fine.

comment:4 Changed 13 months ago by frank

  • Summary changed from Hold key rate slow afer resume state guest machine to Hold key rate slow afer resume state guest machine => Fixed in SVN

Thanks for the report. This bug will be fixed with one of the next maintenance releases.

comment:5 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.2.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use