VirtualBox

Ticket #10901 (closed defect: invalid)

Opened 20 months ago

Last modified 19 months ago

vboxvideo fails to auto-load on Ubuntu 12.10 Guest

Reported by: darkxst Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.22 Keywords: drm driver 3D
Cc: Guest type: other
Host type: other

Description

On Ubuntu 12.10 beta, the virtualbox 3D driver fails to auto-load. Unless its manually added to /etc/modules.

Since vboxvideo does not export modalias, udev does not know how to find the correct driver.

Attachments

vbox.patch Download (52 bytes) - added by darkxst 20 months ago.
patch to export modalias, so udev can autoload vbox drm driver

Change History

Changed 20 months ago by darkxst

patch to export modalias, so udev can autoload vbox drm driver

comment:1 Changed 19 months ago by frank

Ubuntu 12.10 runs X.org 1.13 and this one is not yet supported by the VirtualBox Guest Additions. And that's the actual reason why the drm module does not load.

comment:2 Changed 19 months ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

Actually by design (of the kernel graphics subsystem) vboxvideo.ko is not supposed to autoload. It is loaded manually by X.Org when needed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use