VirtualBox

Ticket #10882 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

VirtualBox 4.1.20 Failed to start guest (gcc-4.7 problem)

Reported by: corbie Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.20 Keywords:
Cc: Guest type: all
Host type: Linux

Description

After upgrading the kernel and Virtualbox, it may not run a guest VM

Attachments

dmesg.log.cut Download (4.0 KB) - added by corbie 3 years ago.
dmesg output
VBox.log Download (1.5 KB) - added by corbie 3 years ago.
VBox.log
config.zip Download (21.0 KB) - added by corbie 3 years ago.
my .config

Change History

Changed 3 years ago by corbie

dmesg output

Changed 3 years ago by corbie

VBox.log

comment:1 follow-up: ↓ 2 Changed 3 years ago by frank

Which Linux kernel version is that exactly? Did you build it yourself or are you using some distro package?

Changed 3 years ago by corbie

my .config

comment:2 in reply to: ↑ 1 Changed 3 years ago by corbie

Replying to frank:

Which Linux kernel version is that exactly? Did you build it yourself or are you using some distro package?

Linux kernel version 3.5.0, self-assembled the .config file is attached.

comment:3 Changed 3 years ago by frank

Are you using gcc-4.7? We saw some reports that VBox modules compiled with this compiler don't properly work.

comment:4 Changed 3 years ago by corbie

Yes, gcc-4.7.1

comment:5 Changed 3 years ago by corbie

When can we expect to improve the situation of compile your modules with gcc-4.7?

comment:6 Changed 3 years ago by frank

The modules compile fine here with gcc-4.7. I still think this is a bug in the compiler you are using. So far I was not able to reproduce the problem locally.

comment:7 Changed 2 years ago by frank

  • Summary changed from VirtualBox 4.1.20 Failed to start guest to VirtualBox 4.1.20 Failed to start guest (gcc-4.7 problem)

comment:8 Changed 2 years ago by corbie

GCC rehabilitated. The fault is not in it: System module assembly does not verify that the required kernel configuration options are included - particularly PAE.

comment:9 Changed 2 years ago by frank

I don't understand, can you explain that a bit more in detail? And, btw, I've seen modules provided by a user compiled with gcc-4.7.something which indeed contained invalid code.

comment:10 Changed 2 years ago by corbie

All the same MB, compiler, virtualbox. Changed only support memory size in kernel from 4G to 64G and miraculously it worked.

cat .config

--- cut -----

# CONFIG_HIGHMEM4G is not set

CONFIG_HIGHMEM64G = y

CONFIG_VMSPLIT_3G = y

# CONFIG_VMSPLIT_2G is not set

# CONFIG_VMSPLIT_1G is not set

CONFIG_PAGE_OFFSET = 0xC0000000

CONFIG_HIGHMEM = y

CONFIG_X86_PAE = y

CONFIG_ARCH_PHYS_ADDR_T_64BIT = y

CONFIG_ARCH_DMA_ADDR_T_64BIT = y

CONFIG_NEED_NODE_MEMMAP_SIZE = y

CONFIG_ARCH_FLATMEM_ENABLE = y

CONFIG_ARCH_SPARSEMEM_ENABLE = y

CONFIG_ARCH_SELECT_MEMORY_MODEL = y

CONFIG_ILLEGAL_POINTER_VALUE = 0

CONFIG_SELECT_MEMORY_MODEL = y

# CONFIG_FLATMEM_MANUAL is not set

CONFIG_SPARSEMEM_MANUAL = y

CONFIG_SPARSEMEM = y

CONFIG_HAVE_MEMORY_PRESENT = y

CONFIG_SPARSEMEM_STATIC = y

CONFIG_HAVE_MEMBLOCK = y

--- cut ----

I can not say exactly when did this dependence, because not used every version of VirtualBox. Blame the GCC4.7 or not - is not explored.

Offtopic:

By the way the latest version VB4.2 is fine with this kernel, whereas with the old configuration even installation bills fail.

Version 0, edited 2 years ago by corbie (next)

comment:11 Changed 2 years ago by frank

Could you attach both vboxdrv.ko modules, once compiled for a kernel with 4G memory limit, the other for a kernel with 64G memory limit? Thank you!

comment:12 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use