VirtualBox

Ticket #10878 (closed defect: duplicate)

Opened 20 months ago

Last modified 20 months ago

3D Acceleration Lag - Redraw - Refresh Issues On Various Guests

Reported by: DasFox Owned by:
Priority: critical Component: 3D support
Version: VirtualBox 4.1.20 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I run Linux and it doesn't matter what distro because this happens for people on various distros, so the problem is not distro specific, but a problem related to 3D Acceleration.

Many people seem to be experiencing a problem on various Guests with 3D Acceleration enabled, causing lag or slow refresh of the GUI window...

On my system when I move back and forth across the virtual desktops and return to the desktop that VirtualBox is running, or roll the window up the GUI will be empty.

In order for the system to reappear, I either have to just sit and wait, sometimes as long as 30 seconds for it to reappear, or on occassion it will reappear immediately when I left click the GUI window, or move my mouse cursor around in the window.

I've also noticed that whatever gui window I have open on another desktop, after I've closed it, this window will get redrawn back into the VirtualBox gui window for some reason, even though I've shut it down, closed it.

For me personally the only two Guest OS I've had 3D Acceleration problems like this, is with Windows 7 and Ubuntu 12.04 LTS. Windows seems to be an issue with Aero, Linux with desktop effects like Compiz running...

The specs on laptop that I run Linux on are not what I would consider slow, so I'm at a loss to understand why I have such poor 3D Acceleration, other than it's still not a very well supported feature in any Guest OS, not just Windows...

These are my hardware specs;

Intel i3 2.3ghz Nvidia 410M - 512MB

I've also tried 3 different Nvidia driver versions with no success, the only thing that makes a Guest OS run normal is to disable the 3D Acceleration.

I hope the Oracle team will be able to do something in the near future to improve this situation. I had hoped to think that anyone with fairly new/recent hardware would not be running into these types of problems with the speed and quality of our technology in 2012, I guess it seems as if there is still a way to go in this...

Please see the attached screen shots;

Win7-1.png - Is when I move around, or roll up the Window the VM GUI is empty.

Win7-2.png - Is when I move the mouse around, bits and pieces of Windows 7 slowy reappear.

Win7-3.png - Is when a gui that I had opened, but closed on another desktop in the Linux host will reappear on the VM gui window when it begins to reappear.

THANKS

Change History

comment:1 Changed 20 months ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate #10879

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use