VirtualBox

Ticket #1087 (closed defect: fixed)

Opened 6 years ago

Last modified 3 years ago

Varying screen resolution not handled well (may be related to xrandr 1.2)

Reported by: ugemkow Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description

We are using VBox OSE on Fedora 7 as host, Windows XP as guest with guest additions. We added randr-1.2 enabled drivers to Fedora 7.

When using VBox on systems with varying screen resolution (Notebooks with internal panel / external display), there are some problems:

  • When starting VBox when the resolution is high (i.e 1600x1200), stopping it and later restarting it when the system has a lower resolution (i.e. 1400x1050), VBOX tries to restore the greater resolution and fails. It then displays scroll bars which are not moveable. Minimizing the window and restoring it makes VBox usable again.
  • When VBox is in full screen mode with the higher resolution, stopped and restarted when the system has a lower resolution, this fails completely and in some cases even crashes the X server (which is also a X/driver bug of course).

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by Lelik

Can't reproduce such behaviors. If I start the VM in the high resolution screen with maximized guest resolution then power it off and start in the low resolution screen it starts with scrollers, but then switches guest video mode that fit into the new VM windos size.

Are you sure you have installed fresh additions in the guest? Try to boot in safe mode->Uninstall->reboot. Boot in safe mode->Install->reboot.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 6 years ago by ugemkow

Replying to Lelik:

Can't reproduce such behaviors. If I start the VM in the high resolution screen with maximized guest resolution then power it off and start in the low resolution screen it starts with scrollers, but then switches guest video mode that fit into the new VM windos size.

Do you use xrandr 1.2 drivers? They are not standard in Fedora 7. I am not sure, whether the problem depends on xrandr 1.2 (cant easily go back to the standard drivers).

Are you sure you have installed fresh additions in the guest? Try to boot in safe mode->Uninstall->reboot. Boot in safe mode->Install->reboot.

Yes, I am sure. The guest was created with 1.5.4, not updated and so older additions were never installed.

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 6 years ago by Lelik

Replying to ugemkow:

Do you use xrandr 1.2 drivers? They are not standard in Fedora 7. I am not sure, whether the problem depends on xrandr 1.2 (cant easily go back to the standard drivers).

Could you give me some information how to create the same configuration? What card you have, driver, etc, etc.

comment:4 in reply to: ↑ 3 Changed 6 years ago by ugemkow

Replying to Lelik:

Replying to ugemkow:

Do you use xrandr 1.2 drivers? They are not standard in Fedora 7. I am not sure, whether the problem depends on xrandr 1.2 (cant easily go back to the standard drivers).

Could you give me some information how to create the same configuration? What card you have, driver, etc, etc.

We are using the following configuration:

  • Fedora 7 with bundled Xorg server, vanilla kernel 2.6.22 on different IBM/Lenovo notebooks
  • KDE 3.5.7, compiled from sources
  • Graphic cards: Radeon-based mobility chips (different) with the prerelease xrandr 1.2 driver and intel GMA based graphic with latest intel xorg driver (released version), both compiled from sources, output auto-detection. The problem happens with both drivers.

I made some more experiments and the problem _may be_ related to the KDE window manager, for us this problem is always reproducible.

comment:5 Changed 6 years ago by bundabrg

Virtual Box: 1.6.2 Host: Ubuntu Hardy Heron 8.04 i386 Guest: Ubuntu Hardy Heron 8.04 i386

I can confirm the following:

  • I boot up the host, with an LCD that supports 1280x1024.
  • I start the Guest, and it starts up with a screen resolution of 1280x1024. I've set this under the Ubuntu Screen Resolution.
  • I turn everything off, and plug in a CRT that only supports 1024x768
  • I boot the host, which gets 1024x768
  • I start the guest, which boots correctly all the way to the Login screen
  • When I log in, the guest then attempts to change the screen resolution to 1280x1024, which results in Xorg (on the host) crashing totally.

I'm using VBoxSDL, no window manager on the host (bare X), with the following startup on the host:

xinit /usr/bin/VBoxSDL --startvm screen0 --fullscreen

(or something like that. Typing from memory)

  • Brendan

comment:6 Changed 4 years ago by Technologov

  1. Retry with VBox 3.1.0
  1. please post VBox log
  1. please post screenshot

-Technologov

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use