VirtualBox

Ticket #10862 (closed defect: worksforme)

Opened 20 months ago

Last modified 16 months ago

Guest unable to ping Host-only interface until host pings guest first

Reported by: derfury Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 4.1.20 Keywords:
Cc: Guest type: all
Host type: Linux

Description

My configuration is as follows:

vboxnet0

  • host interface - 1.1.4.1
  • dhcpserver - 1.1.4.254
  • VM0 - receives 1.1.4.2 from dhcp

vboxnet1

  • host interface - 1.1.5.1
  • dhcpserver - 1.1.5.254
  • VM1 - receives 1.1.5.2 from dhcp

VM0 and VM1 are both isolated from each other and have no internet connection as expected, I only need them to have connectivity to the host. I create and start these programatically, but the issue seems to exist if I do it manually as well.

The issue is that seemingly at random one of these two VMs is unable to ping the Host's interface for it's corresponding network until the host pings them first.

To reproduce this (The ordering of which fails seems random each time I boot them):

VM0: ping 1.1.4.1 -I 1.1.4.2    :Success
VM1: ping 1.1.5.1 -I 1.1.5.2    :Timeout

Now if I ping the guest and try again...

Host: ping 1.1.5.2 -I 1.1.5.1   :Success
VM1: ping 1.1.5.1 -I 1.1.5.2    :Success

Attachments

test_1_1355863683570_AttackerAppliance_eth1.pcap Download (7.4 KB) - added by derfury 16 months ago.
Guest VM eth1
test_1_1355863683643_GatewayAppliance_eth1.pcap Download (7.5 KB) - added by derfury 16 months ago.
DHCP Server eth1

Change History

comment:1 Changed 20 months ago by aleksey

I cannot reproduce the problem as you described it. Did 1000 pings in each VM without any trouble. Please provide logs from both VMs. It would greatly help if you could provide a part of packet dump showing the problem. Ideally both tcpdump output from the host on the interface that cannot be pinged as well as an internal packet capture described here: https://www.virtualbox.org/wiki/Network_tips . If security is a concern you can omit everything except ICMP, ARP, DHCP and send the dumps to me at aleksey dot ilyushin at oracle dot com.

comment:2 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Changed 16 months ago by derfury

Guest VM eth1

Changed 16 months ago by derfury

DHCP Server eth1

comment:3 Changed 16 months ago by derfury

Ok, sorry this too so long. I thought we dealt with the problem but we didn't. Here are some pcaps. Two VMs, one is gateway device with dhcp server at 1.2.1.1 and the other is an XP VM that requests an address. The network is created using the Java API. The XP VM took a minute+ to get an IP.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use