VirtualBox

Ticket #10859 (closed defect: fixed)

Opened 20 months ago

Last modified 18 months ago

Memory leak while running a long process in guest

Reported by: SamuraiJack Owned by: pentagonik
Priority: major Component: guest control
Version: VirtualBox 4.1.20 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello,

I'm experiencing a memory leak, while running a long process in guest with:

vboxmanage guestcontrol VMNAME execute ...

My host is ubuntu 10.04, guest Win7. Host has 4GB RAM, 2GB is assigned for guest.

The exact command line I'm using:

vboxmanage guestcontrol nightlies execute --image "c:
Windows\System32
cmd.exe" --username bryntum --wait-exit -- "/C l:
siesta
bin
webdriver  http://local/workspace/Bryntum/ExtScheduler2.x/tests --browser=chrome > $SAVETO
scheduler-chrome.txt"

It launches cmd.exe, with /C key, which launches some other bat file. That bat file then runs some lengthy tests. The output is redirected to file (inside of guest, not in the host).

I've choose such design because the bat file is on network share, and I was not able to launch it directly.

While running the tests, I'm monitoring memory usage by the VBoxManage process in the host - it steadily grows and never drops down. Over time it grows to 1GB.

For now it works for us (because we have a lot of memory), but would be great to have this fixed.

Thanks, Nickolay

Change History

comment:1 Changed 20 months ago by SamuraiJack

Steps to reproduce the issue:

  1. Find a similar setup (ubuntu 10.04 host, win7 guest, etc)

Additional details:

  • ubuntu kernel 2.6.32.41
  • vbox version : 4.1.20
  • guest is running headless
  • guest need to have guest additions
  1. Launch a VM with "vboxheadless --startvm VMNAME" (I do this in screen)
  2. Launch a long-running command inside of guest, with "--wait-exit" switch:
       vboxmanage guestcontrol VMNAME execute --image "c:\\windows\\system32\\cmd.exe" --username USERNAME --wait-exit
    

(Command above basically will never exit, until you won't close the "cmd" window or type "exit" in it)

  1. In another shell in host, launch this command, which outputs the size of virtual memory used by VBoxManage every 2 seconds:
        watch ps -o vsize $(pgrep VBoxManage)
    
  2. See the number is steadily growing (even that nothing happens neither in guest, nor host)

comment:2 Changed 20 months ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to accepted

Thanks for the report; we've reproduced the issue and this will be fixed in the next upcoming maintenance version.

comment:3 Changed 19 months ago by pentagonik

Unfortunately this was not fixed in 4.1.22 due to lack of time. Will update the defect as soon as there are news on that.

comment:4 Changed 19 months ago by pentagonik

The fix just made it into the next upcoming 4.1 and 4.0 maintenance releases.

Please close this ticket as soon as this then works for you. Thanks again for the report.

comment:5 Changed 19 months ago by SamuraiJack

Great, thank you! Will test shortly after release (I'm on Ubuntu lucid release channel).

comment:6 Changed 18 months ago by SamuraiJack

Is this issue fixed in 4.2.0 ? And 4.2.x branch in general?

comment:7 Changed 18 months ago by klaus

The code has been effectively rewritten for 4.2.0, so it should have different bugs.

comment:8 Changed 18 months ago by SamuraiJack

I've upgraded to 4.2.0. It doesn't seem to have this bug. Sorry, I won't be able to test this issue with 4.1.x. Closing this bug, thanks a lot!

comment:9 Changed 18 months ago by SamuraiJack

The only option I see in "Modify Ticket" is "leave as accepted".. Please close this ticket yourself.

comment:10 Changed 18 months ago by frank

  • Status changed from accepted to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use