VirtualBox

Ticket #10808 (closed defect: fixed)

Opened 21 months ago

Last modified 7 months ago

Large mem leak in vboxtray.exe => Fixed in SVN

Reported by: Brussel Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.18 Keywords: vboxtray leak
Cc: Guest type: Windows
Host type: Windows

Description

On my WinXP guest, the vboxtray.exe gobbles memory at approx 800 KB pr hour. Initial allocation is 2.4 MB and after a day its ~20 MB.

Host: Win2008R2 Guest: Win XP, sp3, 32 bit

I have a attached both the 4.1.18 log as well as the 4.1.16, which displayed similar behaviour.

The winxp guest is lean and mean and all unnessesary service and processes are stopped - this includes normally running services, such as the eventlog. I'm guessing it might be a handle leak when trying to open stopped services.

Attachments

vbox.log Download (37.3 KB) - added by Brussel 21 months ago.
4.1.18 log
vbox16.log Download (72.2 KB) - added by Brussel 21 months ago.
4.1.16 log

Change History

Changed 21 months ago by Brussel

4.1.18 log

Changed 21 months ago by Brussel

4.1.16 log

comment:1 Changed 21 months ago by Brussel

Forgot to mention that the guest os just logs in and then idles the whole time. No application is activly running nor screensaver or power save is active.

comment:2 Changed 20 months ago by frank

  • Summary changed from Large mem leak in vboxtray.exe to Large mem leak in vboxtray.exe => Fixed in SVN

Thanks for the report! Reproduced and fixed.

comment:3 Changed 20 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.1.22.

comment:4 Changed 7 months ago by Devbox

WinXP: vboxtray.exe stops functioning sometimes at around 512kb, which instead of a full restart used to close the vboxtray.exe and relaunch to have it work again however it since one of the early 4.2.0 updates even after relaunching memory of the vboxtray.exe memory goes up to around 2-3MB and only works for a single clipboard act becoming inoperable until machine is restarted.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use