VirtualBox

Ticket #10785 (closed defect: fixed)

Opened 21 months ago

Last modified 11 months ago

VBOX_E_IPRT_ERROR (0x80BB0005)

Reported by: jesustrujillo Owned by:
Priority: critical Component: virtual disk
Version: VirtualBox 4.1.14 Keywords: vhd
Cc: Guest type: Windows
Host type: Windows

Description

Working on a virtual machine, the phisical disk ran out of free space and the virtual machine stopped. After freeing space, i tried to start de virtual machine, but i obtained the following message:

Fallo al abrir el disco duro C:\VirtualBox\WinXP - Ocio\winxp_ocio.vhd.

Could not get the storage format of the medium 'C:\VirtualBox\WinXP - Ocio\winxp_ocio.vhd' (VERR_NOT_SUPPORTED).

Código Resultado: VBOX_E_IPRT_ERROR (0x80BB0005)
Componente: Medium
Interfaz: IMedium {53f9cc0c-e0fd-40a5-a404-a7a5272082cd}
Receptor: IVirtualBox {c28be65f-1a8f-43b4-81f1-eb60cb516e66}

I tried a few different methods: mounting on Windows 7, using VirtualCloneDrive, Gizmo Central, CloneVDI,... All of them reports a corrupted file and cannot continue. I couldn't use VHDTool because it asks for a "FirstSnapshotAVhdFileName" and i don't know what it is.

I read many entries and blogs and I can see this failure happens frequently. Is there any solution for data recovery?

Change History

comment:1 Changed 11 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

The problem is that the VHD image contains a header at the end of the file which is overwritten when there is data appended. VBox is able to to repair such images with the latest version using "VBoxManage internalcommands repairhd --format VHD --filename <image>". Use the "--dry-run" option to check what the tool would do. And also do a backup of the image in case something goes wrong. Closing for now.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use