VirtualBox

Ticket #10770 (closed defect: duplicate)

Opened 21 months ago

Last modified 21 months ago

VirtualBox crashes if guest is shutdown while modal dialog boxes are open

Reported by: danf84 Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.18 Keywords: modal dialogs crash shutdown guest
Cc: Guest type: Windows
Host type: Windows

Description

VirtualBox will not quite shutdown the guest properly (it will set it to aborted) if shutdown was initiated inside the guest while at the same time there are some modal dialog boxes open for the VM. On my Windows 7 host, I get "Oracle VM VirtualBox Manager has stopped working." with a button to check online for a solution and to close the program.

To reproduce: 1) Start the guest. 2) Inside the guest, click Start -> Shutdown -> Shutdown -> OK 3) While the guest OS is shutting down, quickly right the network icon in the status bar then select "Network Adapters". 4) Wait for the error to come up.

I wouldn't have noticed if this didn't happen a few times in the last day or so; so by looking at the reproduction steps there appears to be a slim chance of this happening, it does happen through normal use.

Host: Windows 7 Pro x64 SP1 Guest: Windows XP Pro SP3

Change History

comment:1 Changed 21 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9973. The fix will be in the next major release as it is too intrusive to get into the 4.1.x releases.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use