VirtualBox

Ticket #10728 (closed defect: fixed)

Opened 22 months ago

Last modified 4 months ago

GuruMeditation, NetWare 6.5 SP8, Vbox 4.1.18 w/ VT-x & Nested Paging

Reported by: kumba Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.18 Keywords: netware, guru meditation
Cc: Guest type: other
Host type: Windows

Description

Finally got the chipset in my NetWare 6.5 SP8 VM, swapped out from ICH9 to PIIX3, so I could try and upgrade to VirtualBox 4.1.x, but I am blocked again by something buggering up. All my other VMs boot fine (Windows Server 2003, MS-DOS 7.x, Gentoo/Debian Linux, etc), just not NetWare 6.5.

The cause appears to be VT-x and Nested Paging. If I have these enabled, then when the machine tries to boot NW from the hard disk, I get a GuruMeditation, -4014 (VERR_VMX_INVALID_GUEST_STATE). If I disable Nested Paging, then the Guru goes away, but it hangs at the NW Bootloader prompt (I do not load DR-DOS in this install, just the straight NW kernel). If I disable BOTH VT-x and nested paging, the VM will boot, albeit EXTREMELY slowly and NetWare will be unable to find the SYS volume for unknown reasons.

I backed out to 4.1.14, and that boots fine with VT-x and nested paging enabled, but it boots really slowly as well (not as bad as under 4.1.18 w/o VT-x). Seems to load the NLMs in an entirely different order, although that might be attributed to the slowdown and this ordering is usually very fast and not noticed. However, under 4.1.14, at least, the machine appears to fully boot after about 10 minutes.

I will further experiment with other chipset settings (going back to ICH9, for example), try SMP (ABENDs under 4.0.16, I'll file a separate bug for that), increase/decrease the memory, try different disk controllers, etc. However, I'll probably downgrade back to 4.0.16 when done.

Also, please close Ticket #10402. This one will supersede it. And if someone can look at Ticket #9422 and try to boot the NW65SP8OS.iso off of Novell's site and see if it'll install, then address the bug accordingly, that'd also be great.

Thanks!

Attachments

vbox4118-guru-20120704-nw65sp8.txt Download (168.4 KB) - added by kumba 22 months ago.
VBox.log from NetWare 6.5sp8 under 4.1.18, Guru Meditation
vbox420-guru-20120927-nw65sp8.txt Download (161.7 KB) - added by kumba 19 months ago.
VBox.log from NetWare 6.5sp8 under 4.2.0, Guru Meditation
vbox420-screenshot-20120927-nw65sp8-pagefault-novtx-nonestpage.png Download (31.8 KB) - added by kumba 19 months ago.
Screenshot of NW65SP8 ABEND with no VT-x or Nested Paging
NetWare (Telperion).vbox Download (7.7 KB) - added by kumba 19 months ago.
Machine configuration for the NW65SP8 VM I am using.

Change History

Changed 22 months ago by kumba

VBox.log from NetWare 6.5sp8 under 4.1.18, Guru Meditation

comment:1 Changed 21 months ago by frank

  • Priority changed from blocker to major

comment:2 Changed 19 months ago by kumba

Still broken in VirtualBox 4.2.0. Attempting to boot NetWare 6.5 SP8 gives a GM w/ VT-x and Nested Paging enabled. Disable NP, and it freezes at the bootstrapping screen (I boot SERVER.EXE directly, not via DR-DOS). Disable both NP and VT-x, and it ABENDs at random. In the screenshot I am attaching, it was a Page Fault Exception in NBI.NLM, during the system initialization phase.

Can this get fixed ASAP, please? All of my other VMs boot fine in 4.2.0 (Windows Server 2003, Server 2012, Linux, and MS-DOS 7.10), but the inability of NetWare is holding me back on 4.0.16.

Also attaching a VBox log file and my machine configuration, because I THINK I am using sane settings.

Changed 19 months ago by kumba

VBox.log from NetWare 6.5sp8 under 4.2.0, Guru Meditation

Changed 19 months ago by kumba

Screenshot of NW65SP8 ABEND with no VT-x or Nested Paging

Changed 19 months ago by kumba

Machine configuration for the NW65SP8 VM I am using.

comment:3 Changed 18 months ago by kumba

Just tried 4.1.22 for kicks, and it's hosed as well. Basically same symptoms as 4.2.0, so I'll skip posting logs and such.

comment:4 Changed 18 months ago by kumba

I have to come to the conclusion that the ENTIRE 4.1.x branch is toasted on NetWare 6.5. I've just tried 4.1.0, 4.1.8, 4.1.10, 4.1.12, 4.1.14, 4.1.18, 4.1.20, and 4.1.22 and ALL ARE BROKEN. The culprit is definitely in however Vbox handles the VT-x/Nested Paging support in 4.1.x. Turn those off, and you won't get a Guru Meditation, but then the OS will either not boot at all or boot incredibly slowly.

I was hoping that either 4.1.8 or 4.1.10 would work, as these appear to be close to the same timeframe as Vbox 4.0.16, which does work. No dice, though.

Just for comparison, VMWare Player 9 will boot a clone of my NW65 install just fine, using SMP, VT-x, and everything else. Didn't get networking configured right, but that's trivial compared to the fact that it actually boots. I would really like to continue using VBox, however, as Player lacks snapshot support and VMWare Workstation is too pricey.

If there is some debug build you guys want me to run to better trace this down, let me know. But it'd be awesome if this could get fixed, even if for just one release cycle...

comment:5 Changed 18 months ago by kumba

And just to rub salt into the wound, 4.2.0 can't even boot the Caldera DR-DOS instance that loads NW65. My previous post about 4.2.0 was booting NW directly, bypassing the DOS load. I switched back to that for testing all of the 4.1.x releases, and those could at least load DR-DOS and then load SERVER.EXE. 4.2.0 can't even do that :)

comment:6 follow-up: ↓ 7 Changed 12 months ago by frank

Could you test if  this build allows you to run Netware again?

comment:7 in reply to: ↑ 6 Changed 10 months ago by kumba

Replying to frank:

Could you test if  this build allows you to run Netware again?

Just getting around to this, it looks like that testcase is no longer available. Can you point me to another one to try out?

comment:8 Changed 5 months ago by frank

Such test builds are only available for 2 weeks. Please test VBox 4.2.20 (just released) or VBox 4.3.4 (will be released soon).

comment:9 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.3.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use