VirtualBox

Ticket #10721 (new defect)

Opened 22 months ago

Last modified 21 months ago

Assert(DevATA.cpp:5053) during Windows 98 setup & MS-DOS text is unreadable

Reported by: WinManager Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.18 Keywords:
Cc: Guest type: Windows
Host type: other

Description

After trying several times to successfully install Windows 98 as guest on a virtual machine (and following every bit of advice postet on the internet, including the VirtualBox forums) I still couldn't get Windows 98 running. At first the machine always stopped reacting after restarting itself during the setup during hardware detection (~13/14 minutes stage). After not beeing able to localize the problem I decided to run the virtual machine with VT-x accelaration. This led to unreadable MS-DOS text (but by then I was knowing what commands there were to enter without needing to be able to read anything), but otwerwise worked quite well until VirtualBox crashed (again at about 13 or 14 minutes to go during setup). For further details see attached files. Perhaps there's also a workaround for the unreadable MS-DOS text problem with enabled VT-x acceleration!? (Instead of the text just undefinable nonsense is displayed.)

Attachments

2012-07-01-15-32-26.log Download (48.0 KB) - added by WinManager 22 months ago.
VirtualBox log file
minidump.zip Download (192.1 KB) - added by WinManager 22 months ago.
Windows 7 (64 bit) minidump
BlueScreen.jpg Download (59.4 KB) - added by WinManager 21 months ago.
comment 2: error message (invalid dynamic link call from VMOUSE)

Change History

Changed 22 months ago by WinManager

VirtualBox log file

Changed 22 months ago by WinManager

Windows 7 (64 bit) minidump

comment:1 Changed 22 months ago by Hachiman

  • Summary changed from VirtualBox crashes/hangs during Windows 98 setup & MS-DOS text is unreadable to Assert(DevATA.cpp:5053) during Windows 98 setup & MS-DOS text is unreadable

comment:2 Changed 21 months ago by WinManager

Firstly I must correct myself: The problems described above occure when setup says 11 minutes to go.

Then I noticed a weird circumstance: When the virtual machine is running with VT-x accelaration disabled, the countdown timer (15 seconds) before the restart hangs-up and the machine must be restarted manually by use of the restart now button. After the machine has shut down it boots normally and the Windows 98 boot screen is displayed. Then some DOS text appeares shortly, which says that the codepage xxx has been loaded successfully, and after that the Windows 98 boot screen is shown again. At this point I have discovered three different reactions:

  • Either the boot screen hangs-up (the light blue bar at the bottom stops moving) and the virtual machine does not react anymore in any way (not even with Ctrl + Alt + Del).
  • Or if I hit the Esc-Key the DOS text mentioned above appeares again and shortly afterwards the machine does not react anymore either.
  • Or I recently received another error message (see attachment). As the message is written in German I will translate it in the following: <<Invalid dynamic link call from VMOUSE(03) + 0000122F for device "C001", service D44. The Windows configuration is invalid. Restart windows setup to resolve the bug. To resume Windows press J or Return; to exit the current program press N. By resuming Windows the system can destabilise itself. Continue? J = Yes, N = No: _<< But no input can be made because the machine does not react anymore once again.

If on the other side VT-x accelaration is enabled Virtual Box crashes as mentioned already in my initial post.

P.S.: I hope that I have expressed myself accurately because English is not my native language (as you might have already guessed due to the German error message).

Last edited 21 months ago by WinManager (previous) (diff)

Changed 21 months ago by WinManager

comment 2: error message (invalid dynamic link call from VMOUSE)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use