VirtualBox

Ticket #10714 (closed defect: worksforme)

Opened 22 months ago

Last modified 22 months ago

Can not run/install windows and linux guest on OS X host

Reported by: venj Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.18 Keywords:
Cc: Guest type: all
Host type: Mac OS X

Description

Hardware: MacBook Late 2009 model, optical drive was replaced by an SSD, 8G ram, 500GB HDD.

Software: OS X Lion 10.7.4 with all update installed. OS X is installed on SSD, Virtual box application was on SSD, too. guest home was located on HDD, which location is /Volume/Data/Documents/VirtualBox VMs.

Set up a Windows XP, Windows 7, Ubuntu 12.04 LTS with default settings except set ram to 1024M, and hard drive to 40G.

Run guest, and Guru Meditation appears soon. I can not even install the OSes.

I tried to revert Virtual box to all the way back v4.1.12, and 4.0.x, the problem is all the same.

Attachments

VBox.log Download (162.3 KB) - added by venj 22 months ago.
Ubuntu crash log
VBox.2.log Download (258.6 KB) - added by venj 22 months ago.
crash log for windows xp

Change History

Changed 22 months ago by venj

Ubuntu crash log

Changed 22 months ago by venj

crash log for windows xp

comment:1 follow-up: ↓ 2 Changed 22 months ago by frank

Do you run some other VMM in parallel?

comment:2 in reply to: ↑ 1 Changed 22 months ago by venj

Replying to frank:

Do you run some other VMM in parallel?

What is VMM?

I have installed Parallels Desktop 7, but not running it.

comment:3 follow-up: ↓ 4 Changed 22 months ago by frank

VMM == virtual machine manager. I assume that if you have Parallels installed then it will set your host into VMX root mode. Try to uninstall it before you start a VBox VM.

comment:4 in reply to: ↑ 3 Changed 22 months ago by venj

Replying to frank:

VMM == virtual machine manager. I assume that if you have Parallels installed then it will set your host into VMX root mode. Try to uninstall it before you start a VBox VM.

Thank you frank, but I still got the same error after I uninstalled Parallels Desktop 7 and a reboot. :(

I googled VMX root mode, but I still not quite understand what it is. And I saw forum discussions about android emulator may lead to VMX root mode error, but I didn't see any VMX root mode error message like these guys with that problem. And I do also have android emulator installed.

comment:5 Changed 22 months ago by venj

I devote a whole day on solving this problem, and I finally found out the reason why virtualbox always enter Guru Meditation state. And its not the fault of virtualbox, its my OS X's problem.

For some unknown reason, my OS X failed to switch VT-x on. After a fresh system re-install, VT-x now active, and virtualbox is happy with that.

Thank you again @frank, your helped me ruled out several possible reason for my problem.

Please close this issue. Thanks!

comment:6 Changed 22 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

And thanks for letting us know! Great that it works now for you.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use