Ticket #10694 (closed defect: obsolete)

Opened 6 years ago

Last modified 3 years ago

VirtualBox claims I do not have VT-x support.

Reported by: Inirit Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.18 Keywords:
Cc: Guest type: Windows
Host type: Windows


I am receiving this error when trying to launch a Windows 8 64-bit VM for the first time:

VT-x/AMD-V hardware acceleration has been enabled, but is not operational. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.

Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer.

It is claiming I do not have VT-x enabled, which I know for a fact that I do and that my hardware supports it.

Proof that my CPU supports it:

Proof that my BIOS settings are correct:

I've updated my BIOS to the most recent version and am using the most recent version of VirtualBox. I've searched for similar problems to mine and have only found a solution of disabling a "trusted execution" setting, but my processor does not even have that feature.


VBox.log Download (86.5 KB) - added by Inirit 6 years ago.
VBox.2.log Download (86.5 KB) - added by Inirit 6 years ago.

Change History

Changed 6 years ago by Inirit


comment:1 Changed 6 years ago by frank

Your log file clearly shows that VT-x was detected and is used by the VM. And it does not contain the error message. Wrong log file?

comment:2 Changed 6 years ago by Inirit

It's definitely the most up to date log file I have. I'll take another look.

Changed 6 years ago by Inirit


comment:3 Changed 6 years ago by Inirit

I just ran the VM, got the same error, and immediately looked at the timestamp of this log to make sure it corresponded to the same run.

comment:4 Changed 6 years ago by frank

Oh, your log shows VERR_VMX_IN_VMX_ROOT_MODE. Do you run Windows 7 on real hardware or inside some other VMM? Or do you have some other VMM running in parallel to VirtualBox? Do you run some WinXP compatibility application on your Windows 7 host?

comment:5 Changed 6 years ago by Inirit

I am running Windows 7 on real hardware. I only have VirtualBox installed. I had Virtual PC installed at some point before, but have removed it since by unapplying the Windows update. As far as I am aware I don't have any WinXP compatibility applications running.

comment:6 Changed 6 years ago by frank

But there must be some process which switched your process to VMX root mode, this is what the error message says.

Version 0, edited 6 years ago by frank (next)

comment:7 Changed 6 years ago by Inirit

If there is then I wouldn't know which one it was. Is there some way for me to find out?

comment:8 Changed 6 years ago by Inirit

I have solved it. The Intel HAXM extension I had used for the Android emulator was causing the problem. I uninstalled it, rebooted, and now the VM opens without error. I discovered the problem via this thread: however, I wouldn't have known to search for that error without your aid. Thank you for your help.

comment:9 Changed 6 years ago by veejae.1

Hi Inirit.

I faced the same problem. But I had never installed the HAXM extension. is there another solution to the problem?

comment:10 Changed 6 years ago by frank

Some other application must switch your machine into VT-x root mode. Check for all non-standard Windows applications. Also, the WinXP compatible mode uses VT-x as well.

comment:11 Changed 6 years ago by kyrotomia

Hi, I am having a similar issue, trying to execute a Windows XP 32bits VM inside a Windows 8 64 bits host. I really do have VT-X (CPU : i7-720QM), and just double checked my BIOS.

Error log : 00:00:04.690395 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={VT-x is not available. (VERR_VMX_NO_VMX)}, preserve=false 00:00:04.706856 Power up failed (vrc=VERR_VMX_NO_VMX, rc=E_FAIL (0X80004005))

I do have HAXM extension installed for android emulator, and I also have Hyper-V service installed coming from Windows Phone Emulator 8.0 (but not any VM running at the moment). I'll try disabling them and see if it works.

However, I suspect this is a common setup for developpers. Any idea if this kind of app ecosystem can co-exist?

Edit : Contrary to the original ticket, I am running on VirtualBox 4.2.4

Last edited 6 years ago by kyrotomia (previous) (diff)

comment:12 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use