VirtualBox

Ticket #10690 (closed defect: worksforme)

Opened 22 months ago

Last modified 17 months ago

No sound: Oracle Linux 5u6 host, Vbox 4.1.12 or 14, Win7 guest, pulseaudio

Reported by: amatantsev Owned by:
Priority: major Component: audio
Version: VirtualBox 4.1.14 Keywords: pulseaudio
Cc: Guest type: all
Host type: Linux

Description

No sound received by the pulseaudio daemon from the Windows 7 guest running on Oracle Linux 5.6.

PulseAudio daemon is running as a non-privileged user. It appears to be working when I play a wav sample with paplay.

The server does not have a built-in soundcard - the sound is redirected to the Sun Ray appliance by pulseaudio via the utaudio driver (Sun Ray Server) and the dsp character device it creates for the appliance. The sound DOES work using paplay. I have a similar set-up on another server where all is working with VMWare.

VBox logs show successful pulse connection. Logs for pulse audio daemon show same.

Things I tried:

  • Vbox 4.1.14, same results
  • Custom compiled VBox 4.1.14 - still nothing
  • Fedora Live CD guest, no sound
  • Win XP, SP3 guest, no sound
  • asked the same question on the forum ( https://forums.virtualbox.org/viewtopic.php?f=7&t=49560&p=225562#p225562). The suggestion there was to try newer libsdl-1.2.14 - didn't help
  • RDP from a windows machine straight to the windows 7 guest DOES get sound
  • RDP from the same windows machine to the VBox remote display - DOES NOT get sound
  • installed a local sound card on the server and was able to have the windows 7 guest to play sound on it using ALSA interface, however, when using pulseaudio driver - no sound from the guest going to the local card (paplay did play sounds to the local sound card on the server)

It appears that there is some mis-communication between the the VBox Guest driver and the pulse daemon.

VBox Log is attached.

Thanks!

Alex.

Attachments

VBox.log Download (52.2 KB) - added by amatantsev 22 months ago.
VBox.log file

Change History

Changed 22 months ago by amatantsev

VBox.log file

comment:1 Changed 22 months ago by amatantsev

Forgot to mention that, when the Host sound driver is set to NULL, RDP to VBox remote display interface gets sound successfully. Thus no-sound condition appears to only affect pulse implementation in VBox.

comment:2 Changed 22 months ago by amatantsev

Yet another detail: I have same version of VBox 4.1.14 running on Debian with Win XP guest successfully playing sound onto a Sun Ray via pulseaudio. That is why this problem is frustrating - I had this configuration done a few times before and it worked - this time - not. The difference, of course the Linux version and distribution with the associated libraries. I just don't have the know-how to trace what library may be contributing to this.

Alex.

comment:3 Changed 19 months ago by amatantsev

The problem was resolved by upgrading to a newer pulseaudio. RHEL 5u7, via EPEL, is providing an older version of the 0.9.x vintage. I upgraded the pulseaudio package to a latest 2.x version and VirtualBox had sound through pulse again. I appears that, despite the connection, VirtualBox was setting something wrong on it that the sound ended up being muted or directed to a wrong output. This may be closed, AFAICT. Thanks.

comment:4 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use