VirtualBox

Ticket #10689 (closed defect: fixed)

Opened 22 months ago

Last modified 10 months ago

OVA Import Fails (when OVA Contains Multiple File References) => Fixed in SVN

Reported by: abluesongbird Owned by:
Priority: major Component: OVF
Version: VirtualBox 4.1.16 Keywords:
Cc: Guest type: other
Host type: other

Description

When I attempt to import an OVA I encounter the following error:

Failed to import appliance D:\Users\foo\Downloads\virtual-workstation-vm_OVF10.ova.

Could not open the medium storage unit 'D:\Users\foo\Downloads\system.vmdk'.

VD: error VERR_TAR_END_OF_FILE opening image file 'D:\Users\foo\Downloads\system.vmdk' (VERR_TAR_END_OF_FILE).

Result Code: VBOX_E_FILE_ERROR (0x80BB0004) Component: Appliance Interface: IAppliance {3059cf9e-25c7-4f0b-9fa5-3c42e441670b}

The OVA's OVF descriptor contains two references, in this order:

  1. system.vmdk and
  2. sandbox.vmdk.

*The referenced files appear in the TAR archive in the same order as they do in the OVF descriptor.*

During the import, VirtualBox first loads sandbox.vmdk and then tries to load system.vmdk, resulting in the error above.

Thinking this was an alphebetization/sorting problem, I renamed the files to:

  1. 00system.vmdk and
  2. 01sandbox.vmdk.

This did not help. (VirtualBox still goes for 01sandbox.vmdk first.)

Next I tried reordering the TAR archive, putting 01sandbox.vmdk before 00system.vmdk. This time the import worked! VirtualBox still loaded 01sandbox.vmdk first, but this time it could find 00system.vmdk.

Looking at the OVF spec, I think this is a VirtualBox bug: the spec indicates that the file order of the TAR should match the file order of the descriptor, but VirtualBox expects different orders.

Change History

comment:1 Changed 22 months ago by abluesongbird

I don't see a way to make the following corrections: Host type: other -> Windows Guest type: other -> Linux

comment:2 Changed 22 months ago by abluesongbird

Also, untarring the OVA and importing the OVF file provides a workaround.

comment:3 Changed 10 months ago by klaus

Could you attach the .ovf file to this bug report? So far this is extremely ambiguous, and we have no way of analyzing the issue without knowing what this file contains.

comment:4 Changed 10 months ago by VVP

the problem is in traversal sequence in VB.

Try this: Rearrange image files in the archive in accordance with their traversal sequence in the VB. Disks attached to IDE come at first, disks attached to SATA come afterwards.

for example:

in the archive, files go,

  1. iso1
  2. vmdisk2
  3. vmdisk3

in the VM, files are attached

  1. IDE0 - vmdisk2
  2. SATA0 - iso1
  3. SATA1 - vmdisk3.

you need to rearrange files in the archive like,

  1. vmdisk2
  2. iso1
  3. vmdisk3.

And don't forget to correct the OVF file afterwards.

Last edited 10 months ago by VVP (previous) (diff)

comment:5 Changed 10 months ago by VVP

Summary: OVA Import Fails (when OVA Contains Multiple File References) => fixed in SVN

comment:6 Changed 10 months ago by frank

  • Summary changed from OVA Import Fails (when OVA Contains Multiple File References) to OVA Import Fails (when OVA Contains Multiple File References) => Fixed in SVN

comment:7 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.2.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use