VirtualBox

Ticket #10681 (closed enhancement: wontfix)

Opened 22 months ago

Last modified 22 months ago

VirtualBox lacks of built-in DNS forwarder

Reported by: maxiaojun Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 4.1.16 Keywords:
Cc: Guest type: all
Host type: all

Description

Hi,

I'm using a laptop host where network configuration often change. I may switch between WiFi hotspots. I may connect or disconnect VPN.

I find that I have do DHCP on guest after configuration change. The cause is that VirtualBox's NAT DHCP gives the DNS servers of the host directly to the guest.

I know there is something like Google Public DNS. Applies it to either host or guest would solve my problem, at least in theory.

But sometimes we do need local DNS.

Thank you in advance.

Change History

comment:1 Changed 22 months ago by maxiaojun

To be clear, my purpose is implementing a DNS forwarder in VirtualBox. So guests can stick to a particular DNS server even host encounter configuration change.

This feature should be toggleable. This feature may or may not be enabled by default.

comment:2 Changed 22 months ago by Hachiman

  • Status changed from new to closed
  • Resolution set to wontfix

Perhaps, Using host resolver is what are you looking for.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use