VirtualBox

Ticket #10609 (closed defect: obsolete)

Opened 23 months ago

Last modified 2 months ago

OpenGL bug but work good

Reported by: yann458 Owned by:
Priority: major Component: WDDM
Version: VirtualBox 4.1.16 Keywords: opengl,crash
Cc: Guest type: Windows
Host type: Linux

Description

OpenGL work good but with some bugs.

There are two bugs, it is necessary for reproduce:

_ Download a mini-maze games "gamesok - mini tanga" and install it in the guest machine immutable with two screens and with enabled support 3d

_ Then use the utility "Scenario Game Tanga Configuration" provided by this mini-game installation and check the toggle "GL_COMPILE" and uncheck the toggle "emulated 3d" and click on button "Enregister"

First bug:

When this mini-game is attached since debugger (ex. Visual Studio 2005), when i exit this application, then i have an exception in the library "VBoxoGLutil.dll" after API function "ExitProcess" called.
"First chance exception at 0xfeeefeee in gamesok.exe:0xc0000005:Access Violation reading location 0xfeeefeee".

Call Stack:

See join picture

2nd bug:

When I move the OpenGL window from one screen to another screen , the guest machine crash.
Also , when i resized at left OpenGL Windows since a screen to another screen, the guest machine crash.

Related bug https://www.virtualbox.org/ticket/9996.

Else OpenGL work good with 3d support enabled.

Attachments

vbox.png Download (15.5 KB) - added by yann458 23 months ago.
Call stack about exception
VBox.log Download (125.6 KB) - added by yann458 23 months ago.
VBox.log.1 Download (122.5 KB) - added by yann458 23 months ago.

Change History

Changed 23 months ago by yann458

Call stack about exception

comment:1 Changed 23 months ago by yann458

I forgotten , This bug is present when aero is disabled that's if the option "adjust for best performance" is activated since control panel->system-> .

comment:2 Changed 23 months ago by misha

Please attach a VM log here as well.

Changed 23 months ago by yann458

Changed 23 months ago by yann458

comment:3 Changed 23 months ago by yann458

rather see vbox.log

comment:4 Changed 23 months ago by yann458

I am unsure this bug is only with graphic card NVIDIA Geforce 8400GS . Since i changed my graphics card with NVIDIA Geforce GT 520 and with driver installed, and i tested this game into guest machine immutable , RESULT : no more crash in these condition.

by cons I still have this bug: When this mini-game is attached since debugger (ex. Visual Studio 2005), when i exit this application, then i have an exception in the library "VBoxoGLutil.dll" after API function "ExitProcess" called. "First chance exception at 0xfeeefeee in gamesok.exe:0xc0000005:Access Violation reading location 0xfeeefeee".

comment:5 Changed 6 months ago by misha

Could you please check whether the issue still exists with VBox 4.3 and 4.3 Additions?

comment:6 Changed 2 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use