VirtualBox

Ticket #1059 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

vboxdrv crashes on Fedora 7

Reported by: achapkis Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Almost every time now when I start VirtualBox on Linux Fedora 7 with WindowsXP Pro as a guest OS, I receive kernel: invalid opcode 0000 message on all the consoles and the following in /var/log/messages:

Jan  9 10:17:16 rambam kernel: CPU 0
Jan  9 10:17:16 rambam kernel: Modules linked in: lp parport_pc ppdev parport ipt_MASQUERADE iptable_nat nf_nat nfsd exportfs lockd nfs_acl auth_rpcgss tun vboxdrv(U) autofs4 hidp rfcomm l2cap bluetooth sunrpc bridge nf_conntrack_netbios_ns nf_conntrack_ipv4 xt_state nf_conntrack nfnetlink ipt_REJECT iptable_filter ip_tables xt_tcpudp ip6t_REJECT ip6table_filter ip6_tables x_tables cpufreq_ondemand acpi_cpufreq dm_mirror dm_multipath dm_mod video output sbs battery ac ipv6 snd_usb_audio snd_usb_lib snd_rawmidi snd_hwdep firewire_ohci firewire_core nvidia(P)(U) crc_itu_t snd_hda_intel floppy 3c59x usblp snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq usb_storage iTCO_wdt iTCO_vendor_support snd_seq_device pcspkr atl1 snd_pcm_oss sr_mod i2c_i801 snd_mixer_oss snd_pcm button mii cdrom snd_timer snd soundcore snd_page_alloc i2c_core sg ahci pata_jmicron ata_piix ata_generic libata sd_mod scsi_mod raid456 async_xor async_memcpy async_tx xor raid1 ext3 jbd mbcache ehci_hcd ohci_hcd uhci_hcd
Jan  9 10:17:16 rambam kernel: Pid: 7613, comm: VirtualBox Tainted: P        2.6.23.12-52.fc7 #1
Jan  9 10:17:16 rambam kernel: RIP: 0010:[<ffffffff88c96e4b>]  [<ffffffff88c96e4b>] :vboxdrv:g_abExecMemory+0x2320b/0x180000
Jan  9 10:17:16 rambam kernel: RSP: 0018:ffff81001ced5d30  EFLAGS: 00010046
Jan  9 10:17:16 rambam kernel: RAX: 0000000000000000 RBX: 0000000000000000 RCX: ffffc20001c5a000
Jan  9 10:17:16 rambam kernel: RDX: 0000000000000000 RSI: 0000000000000000 RDI: 0000000000004824
Jan  9 10:17:16 rambam kernel: RBP: ffff81001ced5dc8 R08: 00002aaab425e740 R09: 00002aaab4207000
Jan  9 10:17:16 rambam kernel: R10: 00002aaab43fa190 R11: 00002aaab43ef000 R12: 0000000000000001
Jan  9 10:17:17 rambam kernel: R13: ffff81001ced5d88 R14: ffffc20001c5a980 R15: ffffc20001c5a000
Jan  9 10:17:17 rambam kernel: FS:  0000000041626950(0063) GS:ffffffff813b3000(0000) knlGS:0000000000000000
Jan  9 10:17:17 rambam kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Jan  9 10:17:17 rambam kernel: CR2: 00002aaad1fe9000 CR3: 000000001c624000 CR4: 00000000000026e0
Jan  9 10:17:17 rambam kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jan  9 10:17:17 rambam kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Jan  9 10:17:17 rambam kernel: Process VirtualBox (pid: 7613, threadinfo ffff81001ced4000, task ffff81002308e000)
Jan  9 10:17:17 rambam kernel: Stack:  ffffffff88c77e62 0000000300000000 ffff810000000003 1ec3c00000000000
Jan  9 10:17:17 rambam kernel:  0000001280000b0e 0000000000000000 0000000000000003 0000000000000002
Jan  9 10:17:17 rambam kernel:  0000000000000000 0000000000000000 0000000000000699 0000000000000000
Jan  9 10:17:17 rambam kernel: Call Trace:
Jan  9 10:17:17 rambam kernel:  [<ffffffff88c77e62>] :vboxdrv:g_abExecMemory+0x4222/0x180000
Jan  9 10:17:17 rambam kernel:  [<ffffffff88c76761>] :vboxdrv:g_abExecMemory+0x2b21/0x180000
Jan  9 10:17:17 rambam kernel:  [<ffffffff88c76871>] :vboxdrv:g_abExecMemory+0x2c31/0x180000
Jan  9 10:17:17 rambam kernel:  [<ffffffff88c969ed>] :vboxdrv:g_abExecMemory+0x22dad/0x180000
Jan  9 10:17:17 rambam kernel:  [<ffffffff88c74194>] :vboxdrv:g_abExecMemory+0x554/0x180000
Jan  9 10:17:17 rambam kernel:  [<ffffffff88c6e9c3>] :vboxdrv:supdrvIOCtlFast+0x42/0x56
Jan  9 10:17:17 rambam kernel:  [<ffffffff88c6e065>] :vboxdrv:VBoxSupDrvIOCtl+0x38/0x1c0
Jan  9 10:17:17 rambam kernel:  [<ffffffff8102cc7b>] update_stats_wait_end+0x8b/0xa9
Jan  9 10:17:17 rambam kernel:  [<ffffffff8102ccc5>] pick_next_task_fair+0x2c/0x49
Jan  9 10:17:17 rambam kernel:  [<ffffffff810a3181>] do_ioctl+0x21/0x6b
Jan  9 10:17:17 rambam kernel:  [<ffffffff810a340e>] vfs_ioctl+0x243/0x25c
Jan  9 10:17:17 rambam kernel:  [<ffffffff810a3480>] sys_ioctl+0x59/0x79
Jan  9 10:17:17 rambam kernel:  [<ffffffff8100bd35>] tracesys+0xd5/0xda
Jan  9 10:17:17 rambam kernel:
Jan  9 10:17:17 rambam kernel:
Jan  9 10:17:17 rambam kernel: Code: 0f 79 fe 73 06 b8 5f f0 ff ff c3 75 05 b8 60 f0 ff ff c3 cc
Jan  9 10:17:17 rambam kernel: RIP  [<ffffffff88c96e4b>] :vboxdrv:g_abExecMemory+0x2320b/0x180000
Jan  9 10:17:17 rambam kernel:  RSP <ffff81001ced5d30>

I can provide more information upon the request as I don't know what else to include so far.

Thank you,

Arc C.

Attachments

VBox.log.1 Download (139.2 KB) - added by achapkis 6 years ago.
VBox.log Download (30.5 KB) - added by achapkis 6 years ago.
VBox.2.log Download (29.7 KB) - added by achapkis 6 years ago.

Change History

Changed 6 years ago by achapkis

comment:1 Changed 6 years ago by achapkis

One thing I noticed that it started to crash after I increased the memory size to the guest machine. It was 512MB and I changed it to 1BG. Once I changed it back to 512MB I don't see the crash anymore.

comment:2 Changed 6 years ago by frank

  • Description modified (diff)

comment:3 follow-up: ↓ 4 Changed 6 years ago by frank

How much RAM has your host machine?

comment:4 in reply to: ↑ 3 Changed 6 years ago by achapkis

Replying to frank:

How much RAM has your host machine?

The host has 2GB RAM. So far there's only one guest active at a time.

comment:5 Changed 6 years ago by achapkis

Hello,

Has there been any activity related to this tickets? I have to revise my previous statement - the crash still happens even after I set the memory allocation for the guest OS back to 512MB, it just doesn't happen right away (as it was when I upped it to 1GB), giving me the opportunity to do some work within the guest. However after it does happen, I cannot remove and re-insert the module, as it shows being in use (although no VirtualBox processes are running any more) and I have to reboot the whole system in order to restart VirtualBox guest.

This is somewhat critical issue to me and I'd appreciate if someone can take a look at it. Again, any information I can provide for analysis I will do so.

Thank you,

Arc C.

comment:6 Changed 6 years ago by achapkis

I upgraded VirtualBox to 1.5.6 and the crash is still happening.

comment:7 Changed 6 years ago by frank

Arc, this is a pretty strange problem and quite difficult to debug as long as we can't reproduce the problem here. If you were able to build the debug version of VirtualBox it could help: Maybe an assertion triggers on the debug build which is just a NOP in the release build. Are you familiar with compiling sources on Linux?

comment:8 Changed 6 years ago by achapkis

Although I am not a programmer I think I can follow the instructions if they are included in source code or can be found anywhere on virtualbox.com How do I enable the debug buld and how do I collect and post the output?

comment:9 Changed 6 years ago by frank

You should download the 1.5.6 OSE tarball from  http://www.virtualbox.org/wiki/Downloads. Then please follow the instructions at  http://www.virtualbox.org/wiki/Linux%20build%20instructions.

comment:10 Changed 6 years ago by achapkis

OK, I built it, loaded the debug version of vboxdrv and started the VirtualBox with 1GB memory. Now I got a crash but the /var/adm/messages seems to have similar information as before. Which information should I post here as a result of the debug?

comment:11 Changed 6 years ago by achapkis

Mar 10 10:40:54 rambam kernel: invalid opcode: 0000 [1] SMP
Mar 10 10:40:54 rambam kernel: CPU 0
Mar 10 10:40:55 rambam kernel: Modules linked in: vboxdrv(U) lp parport_pc ppdev parport ipt_MASQUERADE iptable_nat nf_nat nfsd e
xportfs lockd nfs_acl auth_rpcgss tun autofs4 hidp rfcomm l2cap bluetooth sunrpc bridge nf_conntrack_netbios_ns nf_conntrack_ipv4
 xt_state nf_conntrack nfnetlink ipt_REJECT iptable_filter ip_tables xt_tcpudp ip6t_REJECT ip6table_filter ip6_tables x_tables cp
ufreq_ondemand acpi_cpufreq dm_mirror dm_multipath dm_mod video output sbs battery ac ipv6 snd_usb_audio snd_usb_lib snd_rawmidi
snd_hwdep snd_hda_intel snd_seq_dummy firewire_ohci snd_seq_oss firewire_core nvidia(P)(U) snd_seq_midi_event snd_seq crc_itu_t s
nd_seq_device 3c59x snd_pcm_oss snd_mixer_oss floppy snd_pcm snd_timer snd pcspkr usblp soundcore button snd_page_alloc iTCO_wdt
iTCO_vendor_support usb_storage atl1 sr_mod cdrom mii i2c_i801 i2c_core sg ahci pata_jmicron ata_piix ata_generic libata sd_mod s
csi_mod raid456 async_xor async_memcpy async_tx xor raid1 ext3 jbd mbcache ehci_hcd ohci_hcd uhci_hcd
Mar 10 10:40:55 rambam kernel: Pid: 14332, comm: VirtualBox Tainted: P        2.6.23.15-80.fc7 #1
Mar 10 10:40:55 rambam kernel: RIP: 0010:[<ffffffff88cdb6bb>]  [<ffffffff88cdb6bb>] :vboxdrv:g_abExecMemory+0x71a7b/0x180000
Mar 10 10:40:56 rambam kernel: RSP: 0018:ffff81002aa31ac0  EFLAGS: 00010046
Mar 10 10:40:56 rambam kernel: RAX: 0000000000000000 RBX: 0000000000000297 RCX: 0000000000043a91
Mar 10 10:40:56 rambam kernel: RDX: 00000000050a13c7 RSI: 0000000000000000 RDI: 0000000000004824
Mar 10 10:40:56 rambam kernel: RBP: ffff81002aa31d38 R08: 0000000080565779 R09: 0000000000010000
Mar 10 10:40:56 rambam kernel: R10: ffffc20001c5a000 R11: ffffffff88c7fbbc R12: 00000000000056c1
Mar 10 10:40:57 rambam kernel: R13: 0000000000000003 R14: ffff810078462500 R15: 0000000000001000
Mar 10 10:40:57 rambam kernel: FS:  0000000042027950(0063) GS:ffffffff813b5000(0000) knlGS:0000000000000000
Mar 10 10:40:57 rambam kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Mar 10 10:40:57 rambam kernel: CR2: 00002aaadbefa040 CR3: 000000007215d000 CR4: 00000000000026e0
Mar 10 10:40:57 rambam kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Mar 10 10:40:57 rambam kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Mar 10 10:40:57 rambam kernel: Process VirtualBox (pid: 14332, threadinfo ffff81002aa30000, task ffff81007077a820)
Mar 10 10:40:57 rambam kernel: Stack:  ffffffff88c83e65 0000000000000000 ffffffff8102de86 ffff810002c109c0
Mar 10 10:40:57 rambam kernel:  ffffffffffffffff 0000000002c21880 0000000000000000 0000000302c21880
Mar 10 10:40:57 rambam kernel:  0000000000000400 00ff01ff00000003 0000000000000400 0000000000000001
Mar 10 10:40:57 rambam kernel: Call Trace:
Mar 10 10:40:57 rambam kernel:  [<ffffffff88c83e65>] :vboxdrv:g_abExecMemory+0x1a225/0x180000
Mar 10 10:40:57 rambam kernel:  [<ffffffff8102de86>] balance_tasks+0x131/0x16c
Mar 10 10:40:57 rambam kernel:  [<ffffffff88cda17a>] :vboxdrv:g_abExecMemory+0x7053a/0x180000
Mar 10 10:40:57 rambam kernel:  [<ffffffff88cd9893>] :vboxdrv:g_abExecMemory+0x6fc53/0x180000
Mar 10 10:40:57 rambam kernel:  [<ffffffff88c8366e>] :vboxdrv:g_abExecMemory+0x19a2e/0x180000
Mar 10 10:40:57 rambam kernel:  [<ffffffff88c7fc0a>] :vboxdrv:g_abExecMemory+0x15fca/0x180000
Mar 10 10:40:57 rambam kernel:  [<ffffffff88cdb25d>] :vboxdrv:g_abExecMemory+0x7161d/0x180000
Mar 10 10:40:57 rambam kernel:  [<ffffffff88c6adb1>] :vboxdrv:g_abExecMemory+0x1171/0x180000
Mar 10 10:40:57 rambam kernel:  [<ffffffff88cfaa59>] :vboxdrv:g_abExecMemory+0x90e19/0x180000
Mar 10 10:40:57 rambam kernel:  [<ffffffff88c649e2>] :vboxdrv:supdrvIOCtlFast+0x54/0x56
Mar 10 10:40:57 rambam kernel:  [<ffffffff88c649d0>] :vboxdrv:supdrvIOCtlFast+0x42/0x56
Mar 10 10:40:57 rambam kernel:  [<ffffffff88c6406f>] :vboxdrv:VBoxSupDrvIOCtl+0x38/0x1c0
Mar 10 10:40:57 rambam kernel:  [<ffffffff8102d026>] update_curr+0xf8/0x11a
Mar 10 10:40:57 rambam kernel:  [<ffffffff8102cc7b>] update_stats_wait_end+0x8b/0xa9
Mar 10 10:40:57 rambam kernel:  [<ffffffff810a33f1>] do_ioctl+0x21/0x6b
Mar 10 10:40:57 rambam kernel:  [<ffffffff810a367e>] vfs_ioctl+0x243/0x25c
Mar 10 10:40:57 rambam kernel:  [<ffffffff810a36f0>] sys_ioctl+0x59/0x79
Mar 10 10:40:57 rambam kernel:  [<ffffffff8100bd35>] tracesys+0xd5/0xda
Mar 10 10:40:57 rambam kernel:
Mar 10 10:40:57 rambam kernel:
Mar 10 10:40:57 rambam kernel: Code: 0f 79 fe 73 06 b8 5f f0 ff ff c3 75 05 b8 60 f0 ff ff c3 cc
Mar 10 10:40:57 rambam kernel: RIP  [<ffffffff88cdb6bb>] :vboxdrv:g_abExecMemory+0x71a7b/0x180000
Mar 10 10:40:57 rambam kernel:  RSP <ffff81002aa31ac0>
Mar 10 11:38:16 rambam kernel: VirtualBox[14325] trap int3 rip:2aaaadce0c1b rsp:7fffb91a34f0 error:0

Changed 6 years ago by achapkis

comment:12 Changed 6 years ago by achapkis

I've just attached the log file, I think it contains the debug information.

Thank you,

Arc C.

comment:13 Changed 6 years ago by frank

Thanks for these logs! Please could you try to start your VM with VM-x disabled?

comment:14 Changed 6 years ago by achapkis

Hello,

This time with VM-x disabled the vboxdrv did not core dump, and the VM was alive for more than 3 days, but just today it was aborted with another failed assertion. I attached the newest log. Let me know what I should be doing next.

Thank you,

Arc C.

Changed 6 years ago by achapkis

comment:15 Changed 6 years ago by frank

Please could you retry with VirtualBox 1.6.0? There were many improvements for the VT-x support.

comment:16 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use