VirtualBox

Ticket #10580 (closed defect: wontfix)

Opened 2 years ago

Last modified 22 months ago

Can't load vboxdr module into realtime kernel

Reported by: rvega Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.14 Keywords:
Cc: Guest type: Linux
Host type: all

Description

$ sudo modprobe vboxdrv
FATAL: Error inserting vboxdrv (/lib/modules/3.2.0-23-realtime/updates/dkms/vboxdrv.ko): Unknown symbol in module, or unknown parameter (see dmesg)

$ dmesg
...
[ 2600.875176] vboxdrv: Unknown symbol down_write (err 0)
[ 2600.875208] vboxdrv: Unknown symbol up_write (err 0)
[ 2600.875303] vboxdrv: Unknown symbol down_read (err 0)
[ 2600.875373] vboxdrv: Unknown symbol up_read (err 0)

Also, when compiling vboxdrv using the same real time kernel, I get warnings about non-existent symbols "down_write", "up_write", "up_read" and "down_read".

Switching to a lowlatency kernel is a valid workaround in my case.

Change History

comment:1 Changed 2 years ago by frank

Which Linux distribution is that?

comment:2 Changed 23 months ago by rvega

Ubuntu 12.04. Same problem with apt-get version of Virtualbox, the binary downloaded from virtualbox.org and compiled from source. (sorry it took so long to reply)

comment:3 Changed 22 months ago by frank

Ok. So where you have the kernel package from? Because the standard Ubuntu package repository does not provide any realtime kernel.

comment:4 Changed 22 months ago by rvega

I got it from the KXStudio repositories at  http://kxstudio.sourceforge.net/KXStudio:Repositories

comment:5 Changed 22 months ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

Well, I can reproduce the build error here. However, it seems to me that these realtime packages have some problems. For instance, the header file <linux/rwsem_rt.h> is missing. To me it seems that for a RT kernel, up/down_read/write() should be replaced by the corresponding rt_* functions but there are no prototypes for these functions. So I cannot propose a patch.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use