VirtualBox

Ticket #10569 (closed defect: fixed)

Opened 2 years ago

Last modified 23 months ago

VirtualBox crashes on VM start. (parent process: launchd)

Reported by: aberbenni Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.14 Keywords:
Cc: Guest type: other
Host type: other

Description

VirtualBox 4.1.14 for OS X crashes (does not start) on OSX 10.7.4 Server (Macmini5,3)

Attachments

VirtualBox_2012-05-16-175440_localhost.crash Download (36.3 KB) - added by aberbenni 2 years ago.
Diagnostic Report
VBoxSVC.dtruss Download (233.6 KB) - added by aberbenni 2 years ago.
VBox.dtruss Download (359.7 KB) - added by aberbenni 2 years ago.
VBox.2.dtruss Download (368.8 KB) - added by aberbenni 2 years ago.
VBoxSVC.2.dtruss Download (237.9 KB) - added by aberbenni 2 years ago.

Change History

Changed 2 years ago by aberbenni

Diagnostic Report

comment:1 follow-up: ↓ 9 Changed 2 years ago by Hachiman

Could you please attach log and collect the core file which could be uploaded in to  ftp://ftp.oracle.com:/appsdev/incoming , note folder is WO, so please put here file name of the core.

comment:2 Changed 2 years ago by Hachiman

  • Summary changed from VirtualBox does not start to VirtualBox crashes on VM start.

comment:3 follow-up: ↓ 6 Changed 2 years ago by Hachiman

After more careful reading crash report, I found that parent process is launchd. Were you trying launch VM on startup?

potentially it looks like duplicate of #8940

Last edited 2 years ago by Hachiman (previous) (diff)

comment:4 Changed 2 years ago by Hachiman

  • Summary changed from VirtualBox crashes on VM start. to VirtualBox crashes on VM start. (parent process: launchd)

comment:5 Changed 2 years ago by aberbenni

$ ulimit -c unlimited
$ VirtualBox
Segmentation fault: 11
$ /Applications/VirtualBox.app/Contents/MacOS/VirtualBox -startvm Ubuntu12.04LTS
Segmentation fault: 11
$ /Applications/VirtualBox.app/Contents/MacOS/VirtualBox -startvm Windows7\(x64\)
Segmentation fault: 11
Last edited 2 years ago by Hachiman (previous) (diff)

comment:6 in reply to: ↑ 3 Changed 2 years ago by aberbenni

Replying to Hachiman:

After more careful reading crash report, I found that parent process is launchd. Were you trying launch VM on startup?

potentially it looks like duplicate of #8940

No I'm launching VirtualBox via QuickSilver, like any other app. Same result, cliking the icon in dock or double cliking VirtualBox.app in /Application folder.

comment:7 Changed 2 years ago by aberbenni

I downloaded the same version 4.1.14 r77440 on my MacBook Pro with OSX 10.6.8 and it works. After double clicking on VirtualBox.app in /Application folder, it starts. The processes hierarchy is launchd(root) -> launchd (user) -> Virtualbox (user)

comment:8 Changed 2 years ago by aberbenni

It might have something to do with the OS X Lion Update 10.7.4 Server?  http://support.apple.com/kb/DL1530?viewlocale=en_US

comment:9 in reply to: ↑ 1 ; follow-up: ↓ 10 Changed 2 years ago by aberbenni

Replying to Hachiman:

Could you please attach log and collect the core file which could be uploaded in to  ftp://ftp.oracle.com:/appsdev/incoming , note folder is WO, so please put here file name of the core.

No core files generated (with ulimit unlimited), it crashes with "Segmentation fault: 11"

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 13 Changed 2 years ago by Hachiman

Replying to aberbenni:

No core files generated (with ulimit unlimited), it crashes with "Segmentation fault: 11"

please try

# sudo launchctl limit core unlimited

and check /cores folder.

comment:11 follow-up: ↓ 12 Changed 2 years ago by aberbenni

this works:

$ sudo VirtualBox

But i cannot see my VMs because they are in my profile. I have not changed anything in my virtual machines since the last time I used them...

comment:12 in reply to: ↑ 11 ; follow-up: ↓ 14 Changed 2 years ago by Hachiman

Replying to aberbenni:

this works:

$ sudo VirtualBox

But i cannot see my VMs because they are in my profile. I have not changed anything in my virtual machines since the last time I used them...

By "work" do you mean you've got the core files or it works without crash?

comment:13 in reply to: ↑ 10 Changed 2 years ago by aberbenni

Replying to Hachiman:

Replying to aberbenni:

No core files generated (with ulimit unlimited), it crashes with "Segmentation fault: 11"

please try

# sudo launchctl limit core unlimited

and check /cores folder.

no core dump yet...

comment:14 in reply to: ↑ 12 Changed 2 years ago by aberbenni

Replying to Hachiman:

Replying to aberbenni:

this works:

$ sudo VirtualBox

But i cannot see my VMs because they are in my profile. I have not changed anything in my virtual machines since the last time I used them...

By "work" do you mean you've got the core files or it works without crash?

It start without crash.

Version 0, edited 2 years ago by aberbenni (next)

comment:15 follow-up: ↓ 16 Changed 2 years ago by Hachiman

Could you please do

# sudo dtruss -f sudo -u <user> VBoxSVC 2>&1 > VBoxSVC.dtruss 
# sudo dtruss -f sudo -u <user> VirtualBox 2>&1 > VBox.dtruss

and attach the result file here.

Last edited 2 years ago by Hachiman (previous) (diff)

Changed 2 years ago by aberbenni

Changed 2 years ago by aberbenni

comment:16 in reply to: ↑ 15 ; follow-up: ↓ 17 Changed 2 years ago by Hachiman

Replying to aberbenni:

Is "user" is really your account on this mac?

comment:17 in reply to: ↑ 16 ; follow-up: ↓ 18 Changed 2 years ago by aberbenni

Replying to Hachiman:

Replying to aberbenni:

Is "user" is really your account on this mac?

no

comment:18 in reply to: ↑ 17 Changed 2 years ago by Hachiman

Replying to aberbenni:

Replying to Hachiman:

Replying to aberbenni:

Is "user" is really your account on this mac?

no

Sorry, that haven't mentioned it please replace <user> with your account name.

comment:19 follow-up: ↓ 20 Changed 2 years ago by aberbenni

I replaced <user> with my real username and after I ran the command I replaced my real username with "user", I do not think this affects the outcome. Does it really matter the real username?

comment:20 in reply to: ↑ 19 Changed 2 years ago by Hachiman

Replying to aberbenni:

I replaced <user> with my real username and after I ran the command I replaced my real username with "user", I do not think this affects the outcome. Does it really matter the real username?

Yes, it's got meaning, starting that there aren't any /Users/user, which VBoxSVC tries to access. So please attach files with real account.

Changed 2 years ago by aberbenni

Changed 2 years ago by aberbenni

comment:21 follow-ups: ↓ 22 ↓ 23 Changed 2 years ago by aberbenni

Any news?

comment:22 in reply to: ↑ 21 Changed 2 years ago by Hachiman

Replying to aberbenni:

Any news?

Ah, sorry. I have missed the moment when you have attached the files (there isn't notifications on attachment). I'll take a look.

comment:23 in reply to: ↑ 21 Changed 2 years ago by Hachiman

Replying to aberbenni:

Any news?

This part looks suspicious

        57991/0x1a9c2a:  stat64("/Users/bee\0", 0x7FFF5FBF9850, 0x7FFF5FBFFCD0)          = -1 Err#13
	57991/0x1a9c2a:  stat64("/Users/bee\0", 0x7FFF5FBF8410, 0x7FFF5FBF84A0)          = -1 Err#13

what is output of

# ls -@ldae /Users/bee 

on your machine?

Last edited 2 years ago by Hachiman (previous) (diff)

comment:24 follow-up: ↓ 25 Changed 2 years ago by aberbenni

drwxr-xr-x+ 39 bee  staff  1326 May 22 16:53 /Users/bee
 0: group:everyone deny delete

comment:25 in reply to: ↑ 24 ; follow-up: ↓ 26 Changed 23 months ago by Hachiman

Replying to aberbenni:

drwxr-xr-x+ 39 bee  staff  1326 May 22 16:53 /Users/bee
 0: group:everyone deny delete

What is

# id

output of the user starting the VirtualBox. I have same permissions on the home directory, but I haven't problems with accessing home folder.

comment:26 in reply to: ↑ 25 Changed 23 months ago by aberbenni

Replying to Hachiman:

uid=501(bee) gid=20(staff) groups=20(staff),403(com.apple.sharepoint.group.2),504(com.apple.local.ard_manage),505(access_bpf),404(com.apple.sharepoint.group.3),402(com.apple.sharepoint.group.1),500(com.apple.access_ssh),406(com.apple.sharepoint.group.5),401(com.apple.access_screensharing),503(com.apple.local.ard_interact),405(com.apple.sharepoint.group.4),502(com.apple.local.ard_reports),12(everyone),33(_appstore),61(localaccounts),79(_appserverusr),80(admin),81(_appserveradm),98(_lpadmin),100(_lpoperator),204(_developer),407(com.apple.sharepoint.group.6),501(com.apple.local.ard_admin)

comment:27 follow-up: ↓ 28 Changed 23 months ago by Hachiman

Could you please try "Applications->Utilities->Disk Utilities->Verify Disk Permissions"? To verify whether we've met with some file system corruption?

comment:28 in reply to: ↑ 27 Changed 23 months ago by aberbenni

Interesting log, I've never tried this before.

Verifying permissions for “Server HD”
Group differs on “Library”; should be 0, group is 80.
Permissions differ on “Library”; should be drwxr-xr-x , they are drwxrwxr-t .
Permissions differ on “Library/Application Support”; should be drwxr-xr-x , they are drwxrwxr-x .
User differs on “usr/share/collabd/webauthd”; should be 94, user is 221.
Group differs on “usr/share/collabd/webauthd”; should be 94, group is 221.
Group differs on “Library/Java”; should be 0, group is 80.
Permissions differ on “Library/Java”; should be drwxr-xr-x , they are drwxrwxr-x .
Group differs on “Library/Spotlight”; should be 0, group is 80.
Permissions differ on “Library/Spotlight”; should be drwxr-xr-x , they are drwxrwxr-x .
User differs on “usr/share/collabd/webauthd/locales”; should be 94, user is 221.
Group differs on “usr/share/collabd/webauthd/locales”; should be 94, group is 221.
Group differs on “Library/Server/Wiki/FileData”; should be 94, group is 70.
Permissions differ on “Library/Server/Wiki/FileData”; should be drwxrw---- , they are drwxr-x--- .
Permissions differ on “usr/share/devicemgr/frontend/admin/zh_TW.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “usr/share/devicemgr/frontend/admin/zh_CN.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “usr/share/devicemgr/frontend/admin/ko.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “usr/share/devicemgr/frontend/admin/nl.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “usr/share/devicemgr/frontend/admin/it.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “usr/share/devicemgr/frontend/admin/es.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “usr/share/devicemgr/frontend/admin/fr.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “usr/share/devicemgr/frontend/admin/de.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “usr/share/devicemgr/frontend/admin/ja.lproj/app/javascript.js”; should be lrwxrwxrwx , they are lrwxr-xr-x .
Permissions differ on “private/etc/apache2/httpd.conf”; should be -r--r--r-- , they are -rw-r--r-- .
User differs on “Applications/.DS_Store”; should be 0, user is 501.
Permissions differ on “Applications/.DS_Store”; should be -rw-rw-r-- , they are -rw-r--r-- .
Group differs on “Library/Contextual Menu Items”; should be 0, group is 80.
Permissions differ on “Library/Contextual Menu Items”; should be drwxr-xr-x , they are drwxrwxr-x .
Group differs on “Library/Preferences/com.apple.alf.plist”; should be 80, group is 0.
Group differs on “Library/QuickLook”; should be 0, group is 80.
Permissions differ on “Library/QuickLook”; should be drwxr-xr-x , they are drwxrwxr-x .
Permissions differ on “Users”; should be drwxr-xr-x , they are drwxr-x--- .
ACL found but not expected in “Users”
Group differs on “private/etc/hostconfig”; should be 0, group is 20.

comment:29 follow-up: ↓ 30 Changed 23 months ago by Hachiman

Does Repairing Permissions change anything for you ?

comment:30 in reply to: ↑ 29 Changed 23 months ago by aberbenni

Replying to Hachiman:

Does Repairing Permissions change anything for you ?

Yes, now I can start VirtualBox VM without crashes! Thanks.

But the question is, who has changed those permissions? Not me! Maybe a software I've installed or the update to OSX Lion Server 10.7.4?

Anyway I think that VB should not crash in this case, but alert the user of the problem, instead.

comment:31 Changed 23 months ago by Hachiman

The problem, that permissions reported by ls -@ldae was fine, it more looks like some corruption on filesystem level, and hopefully filesystem healing utilities restore normal mapping.

comment:32 Changed 23 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

For your info, VirtualBox 4.1.16 would not crash anymore in this case as we added a sanity check for the correct permissions. So I think we can close this ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use