Ticket #10558 (accepted defect)

Opened 6 years ago

Last modified 3 years ago

Console Mode Mouse Position not moving in Guest

Reported by: ErikW Owned by: michael
Priority: minor Component: guest additions
Version: VirtualBox 4.1.14 Keywords: console mouse text cursor
Cc: Guest type: Linux
Host type: all


The square mouse cursor for the console mode of a Linux guest does not move. When the mouse is moved, the console cursor remains in the center of the text display. Double-clicking the mouse causes the line at the cursor position to be selected. Apparently the mouse clicks are being seen, but not the mouse position updates.

I tested using VirtualBox 4.1.14, 4.1.12 and 4.1.10 on the host. Those versions all behaved the same way. Only the version of Guest Additions seems have an effect on the problem.

I am using the generic Linux version of the Guest Additions, since there is no version specifically for Slackware Linux.

Guest Additions version 3.1.6 and 4.1.2 work in console mode, and the square text mouse cursor moves as expected. Guest Additions versions 4.1.4 through 4.1.14 all have this problem and the console mouse cursor is frozen. My testing for all versions of the Guest Additions was done using VirtualBox 4.1.14 on the host.

I tested both a 64-bit Slackware Linux guest and a 32-bit Slackware Linux guest. I also tested the v2.6 Linux kernel (32-bit) and kernel v3.2.13 (32/64-bit). They all behaved the same way, and the problem occurs (or not) depending on the version of Guest Additions.

My host OS is Windows 7 64-bit. I also tested using a Slackware Linux host with kernel v3.2.13. The host OS does not have any effect on the problem. The console text mouse cursor works in earlier versions of the Guest Additions and does not work in later versions of the Guest Additions.

Change History

comment:1 Changed 6 years ago by michael

Thanks for the report. I see this in an Ubuntu 11.10 guest. Between the 4.1.2 and 4.1.4 Linux Additions we switched from using an X.Org mouse driver to a kernel one as our old one no longer fitted in with the way the X.Org people wished to handle mice. I will investigate this as soon as I find time for it, though I can't immediately say when that will be.

comment:2 Changed 6 years ago by michael

  • Owner set to michael
  • Status changed from new to accepted

comment:3 Changed 6 years ago by michael

It looks to me like our new mouse driver is not sending simulated PS/2 mouse events to /dev/input/mouse* and friends and that this is causing problems for the gpm daemon.

comment:4 follow-up: ↓ 5 Changed 6 years ago by michael

I'm pretty sure there must be some in-kernel code to generate the simulated events for us. I have to say though that gpm is somewhat behind the times if it depends on that functionality.

comment:5 in reply to: ↑ 4 Changed 6 years ago by ErikW

Replying to michael:

I'm pretty sure there must be some in-kernel code to generate the simulated events for us. I have to say though that gpm is somewhat behind the times if it depends on that functionality.

There are a few options for "gpm" to support multiple mouse devices or repeat mouse events to another device. I'm not quite sure how they work but they are documented some in the man page for "gpm". At the moment I think "gpm" is only looking for input from "/dev/mouse".

Here is the "gpm" command on my test Slackware guest if that is helpful.

/usr/sbin/gpm -m /dev/mouse -t imps2

On my system "/dev/mouse" is handled by the "psmouse" module. I tried reloading "psmouse" but that also had no effect on the problem.

/sbin/rmmod psmouse

/sbin/insmod /lib/modules/uname -r/kernel/drivers/input/mouse/psmouse.ko

Perhaps the problem is related to the order of loading some other module versus the virtualbox modules. The commands in "rc.local" are performed after all the other modules are loaded.

The interesting thing is that if I stop and unload the virtualbox guest additions then the console mouse works fine. I thought I'd mention that specifically because I don't know if it is significant.

comment:6 Changed 6 years ago by michael

Unloading the Additions tells VirtualBox to reactivate the PS/2 mouse emulation and the PS/2 driver does work with /dev/input/mouse*.

comment:7 Changed 3 years ago by IvanX

Thought I'd add that I'm still seeing this issue in VirtualBox 4.3.22 on an OS X 10.10.1 host and a Debian 7.8.0 32-bit guest. In my case I am trying to use a mouse in a GUI app that uses the framebuffer. As long as the vboxguest module is loaded -- and even if it was loaded and later unloaded before restart -- the mouse is inoperable.

I've tried installing what I presume are the latest Additions via the script that comes with 4.3.22, as well as what's available from apt-get, with the same issue.

If I "rmmod vboxguest" while the framebuffer application is running, the mouse immediately works properly in the console. However, it does not work if I "rmmod vboxguest" before I run the application, unless I blacklist or remove the module, and restart.

Last edited 3 years ago by IvanX (previous) (diff)

comment:8 Changed 3 years ago by michael

Unless a paying customer has an issue with this it will probably stay too low priority compared to other open issues for us to fix. We would be happy to take a patch if it is high enough priority for someone else to fix.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use