VirtualBox

Ticket #10513 (closed defect: fixed)

Opened 2 years ago

Last modified 7 months ago

NAT: crash with "WSAEnumNetworkEvents tcp error 10038" -> fixed in svn

Reported by: Pinepara Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 4.1.14 Keywords: crash
Cc: Guest type: Linux
Host type: Windows

Description

I have a Arch Linux installed in VirtualBox, and the VirutalBox crashes every time when I tried to install some new packages or perform a system upgrade in it. I believe that it must have something to do with the heavy disk I/O.

I never came to this situation until about two weeks ago, so I believe that this is a latest introduced bug of VirtualBox.

My host system is: Windows 7 SP1 x64; My guest system is: Arch Linux x64.

Upgrading to the latest version of Virtualbox does not solve my problem.

Attachments

VBox.log Download (66.8 KB) - added by Pinepara 2 years ago.
VBox.2.log Download (67.8 KB) - added by Pinepara 2 years ago.
Virtualbox version 4.1.15 r77799
VBox.3.log Download (51.8 KB) - added by ArchEnthusiast 2 years ago.
VirtualBox log with the crash
openbsd-amd64-2012-07-24-18-03-41.log Download (48.3 KB) - added by mkucharski 21 months ago.
VB 4.1.18 crash, Win7 64-bit host, OpenBSD 5.2-beta amd64 guest, NAT
openbsd-amd64-2012-08-21-19-15-09.log Download (48.3 KB) - added by mkucharski 20 months ago.
Crash still happens with VirtualBox 4.1.20 r80170
VBox.4.log Download (72.2 KB) - added by Eric 20 months ago.
Crash on 4.1.20 on eavy bandwidth load
nat-output-2012-09-05.txt Download (38.8 KB) - added by mkucharski 20 months ago.
after replacing VBoxDD.dll with VBoxDD.dll.4.1.20_10513 virtualbox fails to start
openbsd-amd64-2012-09-19-17-54-28.log Download (46.8 KB) - added by mkucharski 19 months ago.
Issue still happening with 4.1.22
openbsd-amd64-2012-09-22-00-16-08.log.gz Download (19.5 KB) - added by mkucharski 19 months ago.
Crashed during capturing (in different way), 4.1.22

Change History

Changed 2 years ago by Pinepara

comment:1 Changed 2 years ago by Pinepara

Sorry for the arbitrary judgement.

I found the following line in the log file:

00:06:21.850 WSAEnumNetworkEvents tcp error 10038

Seems like a network error, not a disk one.

Last edited 2 years ago by Pinepara (previous) (diff)

comment:2 follow-up: ↓ 3 Changed 2 years ago by Hachiman

Thanks for reporting the issue. Have you noticed which networking activity provokes this crush for you?

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 2 years ago by Pinepara

Everytime I run 'yaourt -Syu' or 'yaourt -S blabla' in gnome-terminal, virtualbox crashes in less than five minutes.

Since downloading packages can be continued after reboot, I can perform a full system upgrade within a few times of reboot. But it is very annoying.

Furthermore, I tried to use bridged network instead of NAT after I reported this issue, by which I managed to perform a 30-minutes' system upgrade without crash.

As soon as I switched to NAT again and tried to run 'yaourt -S texlive-most', it crashed in three minutes.

So I think maybe NAT causes this. No idea how.

Replying to Hachiman:

Thanks for reporting the issue. Have you noticed which networking activity provokes this crush for you?

comment:4 in reply to: ↑ 3 Changed 2 years ago by Hachiman

Replying to Pinepara: Thanks for update.

comment:5 Changed 2 years ago by Hachiman

  • Summary changed from VirutalBox crashes every time on heavy disk I/O in Guest Machine to VirtualBox crashes on update of archlinux guest.

comment:6 Changed 2 years ago by Hachiman

  • Component changed from virtual disk to network/NAT

comment:7 follow-up: ↓ 8 Changed 2 years ago by Hachiman

Could you please try the build  VirtualBox-4.1.15-77799-Win.exe whether it fix the issue for you?

comment:8 in reply to: ↑ 7 Changed 2 years ago by Pinepara

Oh, it crashed again during a 'yaourt -Syu'.

I will attach the log, but it looks like nothing different from the last one to me.

Replying to Hachiman:

Could you please try the build  VirtualBox-4.1.15-77799-Win.exe whether it fix the issue for you?

Changed 2 years ago by Pinepara

Virtualbox version 4.1.15 r77799

Changed 2 years ago by ArchEnthusiast

VirtualBox log with the crash

comment:9 follow-ups: ↓ 10 ↓ 11 Changed 2 years ago by ArchEnthusiast

Greetings! I'm also experiencing a similar issue with my Arch Linux disto. The log reports "WSAEnumNetworkEvents tcp error 10038" when I run the command:

wget  ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.1/enu/AdbeRdr9.5.1-1_i486linux_enu.tar.bz2

under ~/AURBuilds as a non-root user.

It's a 4-5 day old installation of Arch on a dynamic 200gb .vmdk, which I just created by cloning a static 8gb .vmdk as by  this tutorial. I ran gparted after the cloning to resize by /dev/sda3 and /dev/sda4 to be about 30gb and 10gb respectively. I was mucking around with the .xml config files for both .VirtualBox and my specific Arch VM previously, so I assumed this crash was caused by something I completely screwed up in the process, but it only seems to happen during intensive network operations (like wget).

This bug is kind of a show-stopper.

Feel free to contact me if you need more information.

Last edited 2 years ago by ArchEnthusiast (previous) (diff)

comment:10 in reply to: ↑ 9 Changed 2 years ago by Pinepara

I also used gparted to resize partions just a few days ago. Besides that I did nothing you mentioned here.

Is there something to do with gparted? That sounds crazy...

Replying to ArchEnthusiast:

Greetings! I'm also experiencing a similar issue with my Arch Linux disto. The log reports "WSAEnumNetworkEvents tcp error 10038" when I run the command:

wget  ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.1/enu/AdbeRdr9.5.1-1_i486linux_enu.tar.bz2

under ~/AURBuilds as a non-root user.

It's a 4-5 day old installation of Arch on a dynamic 200gb .vmdk, which I just created by cloning a static 8gb .vmdk as by  this tutorial. I ran gparted after the cloning to resize by /dev/sda3 and /dev/sda4 to be about 30gb and 10gb respectively. I was mucking around with the .xml config files for both .VirtualBox and my specific Arch VM previously, so I assumed this crash was caused by something I completely screwed up in the process, but it only seems to happen during intensive network operations (like wget).

This bug is kind of a show-stopper.

Feel free to contact me if you need more information.

Last edited 2 years ago by Pinepara (previous) (diff)

comment:11 in reply to: ↑ 9 ; follow-up: ↓ 13 Changed 2 years ago by Pinepara

Are you using NAT? Have you tried bridged network?

My issues won't happen while network set to bridged.

Replying to ArchEnthusiast:

Greetings! I'm also experiencing a similar issue with my Arch Linux disto. The log reports "WSAEnumNetworkEvents tcp error 10038" when I run the command:

wget  ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.1/enu/AdbeRdr9.5.1-1_i486linux_enu.tar.bz2

under ~/AURBuilds as a non-root user.

It's a 4-5 day old installation of Arch on a dynamic 200gb .vmdk, which I just created by cloning a static 8gb .vmdk as by  this tutorial. I ran gparted after the cloning to resize by /dev/sda3 and /dev/sda4 to be about 30gb and 10gb respectively. I was mucking around with the .xml config files for both .VirtualBox and my specific Arch VM previously, so I assumed this crash was caused by something I completely screwed up in the process, but it only seems to happen during intensive network operations (like wget).

This bug is kind of a show-stopper.

Feel free to contact me if you need more information.

comment:12 Changed 2 years ago by Hansel

I'm getting this issue, but with an install of Ubuntu. I'm trying to compile OpenELEC XBMC, but the VM session crashes with "VirtualBox Stopped Responding". It always does it whilst trying to download a package.

I also have "WSAEnumNetworkEvents tcp error 10038" in my log (which is how I found my way here).

This was on the latest release, and also the release prior. I'm now on 4.0.16 to see if that helps :(

comment:13 in reply to: ↑ 11 Changed 2 years ago by ArchEnthusiast

Replying to Pinepara:

Are you using NAT? Have you tried bridged network?

My issues won't happen while network set to bridged.

I've been able to complete my wget after switching to bridged. It was in NAT mode before.

Last edited 2 years ago by ArchEnthusiast (previous) (diff)

comment:14 Changed 2 years ago by Hansel

Just to confirm, it's working fine with the 4.0.16 version, so I guess it's something that was introduced in later versions.

comment:15 follow-up: ↓ 18 Changed 2 years ago by Hachiman

Could you please download the build of  VBoxDD.dll with enabled logging? After downloading please, replace original VBoxDD.dll from VirtualBox 4.1.15 r77799 with downloaded DLL (please, safe original DLL in safe place). Then please launch your VM in the following way

# set VBOX_LOG_DEST=file=nat.log
# set VBOX_LOG=drv_nat.e.f.l2
# VirtualBox -startvm <your-vm>

Result log please attach to the defect. Note: VBoxDD.dll compiled against revision pointed (4.1.15 r77799) earlier to the defect.

Last edited 2 years ago by Hachiman (previous) (diff)

comment:16 follow-up: ↓ 17 Changed 2 years ago by Jacek_

Seems that I have the same problem with "WSAEnumNetworkEvents tcp error 10038"

My setup is:

Host: Win7
VBox: 4.1.12 r77245
Guest: xubuntu
Network: NAT

I'm pretty sure that in my case the VM Abort appears after sometime of using FileZilla to access some FTP server. Unfortunately, I can't use the bridged mode and need to access the FTP server, which make this issue a real pain.

comment:17 in reply to: ↑ 16 ; follow-up: ↓ 36 Changed 2 years ago by Hachiman

Replying to Jacek_: Would you mind to try instructions I've provided in the comment 15 and attach result log to the defect?

comment:18 in reply to: ↑ 15 ; follow-up: ↓ 19 Changed 2 years ago by Pinepara

I did as you said. It crashed again, as it always does.

But the log files is too big to be uploaded here. I will upload them to somewhere else and post the urls here, just in a few minutes.

Replying to Hachiman:

Could you please download the build of  VBoxDD.dll with enabled logging? After downloading please, replace original VBoxDD.dll from VirtualBox 4.1.15 r77799 with downloaded DLL (please, safe original DLL in safe place). Then please launch your VM in the following way

# set VBOX_LOG_DEST=file=nat.log
# set VBOX_LOG=drv_nat.e.f.l2
# VirtualBox -startvm <your-vm>

Result log please attach to the defect. Note: VBoxDD.dll compiled against revision pointed (4.1.15 r77799) earlier to the defect.

Version 1, edited 2 years ago by Pinepara (previous) (next) (diff)

comment:19 in reply to: ↑ 18 Changed 2 years ago by Hachiman

Replying to Pinepara: Thank you. I will take a look.

comment:20 follow-ups: ↓ 21 ↓ 22 ↓ 28 Changed 2 years ago by Hachiman

Still log doesn't clarify what wrong is going on so could you please to apply instructions from comment 15 and use DDL with improved logging  VBoxDD.dll. Additionally could you please, dump network traffic using following instructions.

comment:21 in reply to: ↑ 20 Changed 2 years ago by Pinepara

Replying to Hachiman:

I have done so many times of system update recently that I have nothing to upgrade now...

So I try to do some downloading using wget but haven't triggered any bug yet.

Very weird, I will try again later.

comment:22 in reply to: ↑ 20 ; follow-up: ↓ 23 Changed 2 years ago by gendouhydeist

Replying to Hachiman:

Ok I've tried what you instructed and replace VBoxDD.dll and got an error Unable to load R3 module VBoxDD.dll GetLastError=193 (VER_BAD_EXE_FORMAT)

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

Still log doesn't clarify what wrong is going on so could you please to apply instructions from comment 15 and use DDL with improved logging  VBoxDD.dll. Additionally could you please, dump network traffic using following instructions.

comment:23 in reply to: ↑ 22 ; follow-up: ↓ 24 Changed 2 years ago by Hachiman

Replying to gendouhydeist:

Replying to Hachiman:

Ok I've tried what you instructed and replace VBoxDD.dll and got an error Unable to load R3 module VBoxDD.dll GetLastError=193 (VER_BAD_EXE_FORMAT)

I'll build/upload 32-bit VBoxDD, today, for you. Btw, have you installed 4.1.15 r77799, mentioned in comment 18?

Last edited 2 years ago by Hachiman (previous) (diff)

comment:24 in reply to: ↑ 23 ; follow-up: ↓ 25 Changed 2 years ago by gendouhydeist

Replying to Hachiman:

yes I did.

Replying to gendouhydeist:

Replying to Hachiman:

Ok I've tried what you instructed and replace VBoxDD.dll and got an error Unable to load R3 module VBoxDD.dll GetLastError=193 (VER_BAD_EXE_FORMAT)

I'll build/upload 32-bit VBoxDD, today, for you. Btw, have you installed 4.1.15 r77799, mentioned in comment 18?

comment:25 in reply to: ↑ 24 ; follow-up: ↓ 26 Changed 2 years ago by Hachiman

Replying to gendouhydeist:

Replying to Hachiman:

Could you please try  VBoxDD.dll, it's 32-bit library.

Last edited 2 years ago by Hachiman (previous) (diff)

comment:26 in reply to: ↑ 25 ; follow-up: ↓ 27 Changed 2 years ago by gendouhydeist

Replying to Hachiman:

It's bigger than I though it would be had to compress it.

 http://www.mediafire.com/?ft3niamk1inx35s

Replying to gendouhydeist:

Replying to Hachiman:

Could you please try  VBoxDD.dll, it's 32-bit library.

comment:27 in reply to: ↑ 26 Changed 2 years ago by Hachiman

Replying to gendouhydeist: Thank you for cooperation, I'll take a look.

comment:28 in reply to: ↑ 20 ; follow-up: ↓ 29 Changed 2 years ago by Pinepara

Replying to Hachiman:

I'm back with the crash report here:

 http://file.pinepara.info/crashlog-pinepara-0515.zip

comment:29 in reply to: ↑ 28 Changed 2 years ago by Hachiman

Replying to Pinepara: Thanks for report.

comment:30 follow-ups: ↓ 31 ↓ 33 Changed 2 years ago by Hachiman

Could you please verify following VBoxDD.dll builds: 64-bit  VBoxDD.dll, 32-bit  VBoxDD.dll. Both binaries built again 4.1.15 r77799 so please follow instructions in comment 15 for installation.

Last edited 2 years ago by Hachiman (previous) (diff)

comment:31 in reply to: ↑ 30 ; follow-up: ↓ 32 Changed 2 years ago by Pinepara

Replying to Hachiman:

Comment 18 is mine.

Should I reproduce the crash again using this dll?

comment:32 in reply to: ↑ 31 ; follow-up: ↓ 35 Changed 2 years ago by Hachiman

Replying to Pinepara:

Replying to Hachiman:

Thanks, for correction. indeed comment 15, and yes please try to reproduce the issue.

comment:33 in reply to: ↑ 30 ; follow-up: ↓ 34 Changed 2 years ago by gendouhydeist

Replying to Hachiman:

 http://www.mediafire.com/?iwtybby8uadxlsp

Do you also need the file.pcap? If so then I'll reproduce this later tommorow.

Could you please verify following VBoxDD.dll builds: 64-bit  VBoxDD.dll, 32-bit  VBoxDD.dll. Both binaries built again 4.1.15 r77799 so please follow instructions in comment 15 for installation.

comment:34 in reply to: ↑ 33 Changed 2 years ago by Hachiman

Replying to gendouhydeist:

Do you also need the file.pcap? If so then I'll reproduce this later tommorow.

Thanks for logs, no pcaps files needed.

comment:35 in reply to: ↑ 32 Changed 2 years ago by Pinepara

Replying to Hachiman:

I packed 3 files: file.pcap, nat.log, VBox.log in:

 http://file.pinepara.info/crashlog-pinepara-0517.zip

comment:36 in reply to: ↑ 17 ; follow-up: ↓ 37 Changed 2 years ago by Jacek_

Replying to Hachiman:

Replying to Jacek_: Would you mind to try instructions I've provided in the comment 15 and attach result log to the defect?

Hi,

Sorry for not answering for a while. After the upgrade to 4.1.15 r77799 and changing VBoxDD.dll it all works fine for me. I've not experienced any other crashes since then.

Last edited 2 years ago by Jacek_ (previous) (diff)

comment:37 in reply to: ↑ 36 ; follow-ups: ↓ 38 ↓ 40 Changed 2 years ago by Hachiman

Replying to Jacek_:

Replying to Hachiman:

Replying to Jacek_:

Thanks for feedback. But now I'm confused here, I don't see any crushes here either. But looks like Pinepera and gendouhydeist still experiences some crushes.

comment:38 in reply to: ↑ 37 ; follow-up: ↓ 39 Changed 2 years ago by Pinepara

Replying to Hachiman:

Yes, I'm still experiencing crushes even after I upgraded to 4.1.6

comment:39 in reply to: ↑ 38 ; follow-up: ↓ 41 Changed 2 years ago by Hachiman

Replying to Pinepara:

Replying to Hachiman:

Yes, I'm still experiencing crushes even after I upgraded to 4.1.6

That intended, fixes above wasn't back ported to 4.1, all binaries above were a custom build.

comment:40 in reply to: ↑ 37 Changed 2 years ago by gendouhydeist

Replying to Hachiman:

Yep, still the same here.

Replying to Jacek_:

Replying to Hachiman:

Replying to Jacek_:

Thanks for feedback. But now I'm confused here, I don't see any crushes here either. But looks like Pinepera and gendouhydeist still experiences some crushes.

comment:41 in reply to: ↑ 39 ; follow-up: ↓ 42 Changed 2 years ago by Hachiman

Replying to Hachiman:

Replying to Pinepara:

Could you please try this build  http://www.virtualbox.org/download/testcase/VirtualBox-4.1.17-78168-Win.exe?

no additional actions required, so far.

comment:42 in reply to: ↑ 41 ; follow-up: ↓ 43 Changed 2 years ago by Pinepara

Replying to Hachiman:

Crashed again, during a 'yaourt -Syu'

comment:43 in reply to: ↑ 42 ; follow-up: ↓ 45 Changed 23 months ago by Hachiman

Replying to Pinepara: Ok, perhaps we need to try from other side. Could you please generate the mini dump for this crash please look at Mini Dump for more details?

comment:44 Changed 23 months ago by Hachiman

  • Summary changed from VirtualBox crashes on update of archlinux guest. to NAT: crash with "WSAEnumNetworkEvents tcp error 10038"

comment:45 in reply to: ↑ 43 ; follow-up: ↓ 46 Changed 23 months ago by gendouhydeist

Replying to Hachiman:

Here's what I did on task manager>VirtualBox.exe>right click menu>create dump file.

 http://www.mediafire.com/?9w7s032711040jd

this actually a full dump.

Replying to Pinepara: Ok, perhaps we need to try from other side. Could you please generate the mini dump for this crash please look at Mini Dump for more details?

Last edited 23 months ago by gendouhydeist (previous) (diff)

comment:46 in reply to: ↑ 45 ; follow-up: ↓ 47 Changed 23 months ago by Hachiman

Replying to gendouhydeist:

Replying to Hachiman:

Here's what I did on task manager>VirtualBox.exe>right click menu>create dump file.

thank you, will take a look.

comment:47 in reply to: ↑ 46 Changed 23 months ago by gendouhydeist

Replying to Hachiman:

This is the mini dump created through process explorer.

 http://www.mediafire.com/download.php?1925b49rx2hhrt3

Replying to gendouhydeist:

Replying to Hachiman:

Here's what I did on task manager>VirtualBox.exe>right click menu>create dump file.

thank you, will take a look.

comment:48 follow-up: ↓ 49 Changed 22 months ago by whitemp

I'm seeing something similar but with a different OS Host is Windows 7 x86_64 - my guest OS is PC-BSD 9.0

If I use NAT, the VM will crash if I am using AppCafe (or pbi_installer, which is about the same thing.) The same error, WSAEnumNetworkEvents tcp error 10038, is in the log.

I switched to bridge, and it's been up for about 24hrs - I can get it crash the VM in about 8 minutes otherwise.

comment:49 in reply to: ↑ 48 Changed 22 months ago by Hachiman

Replying to whitemp:

I'm seeing something similar but with a different OS Host is Windows 7 x86_64 - my guest OS is PC-BSD 9.0

Thanks for report I'll try to reproduce this scenario in local environment.

comment:50 follow-ups: ↓ 51 ↓ 53 Changed 22 months ago by Hachiman

Could you please upgrade VBox up to 4.1.18 and replaces VBoxDD.dll in the same manner we've done before with binaries below?

 VBoxDD.dll - 32-bit VBoxDD.dll
 VBoxDD.dll - 64-bit VBoxDD.dll

comment:51 in reply to: ↑ 50 ; follow-up: ↓ 52 Changed 22 months ago by gendouhydeist

Replying to Hachiman:

I would definitely say that it has been fixed, but it didn't have nat.log. Using your VBoxDD.dll posted below. Though I haven't tried the original VBoxDD.dll on the 4.1.18 installer.

Edit: Still crashing on 4.1.18 VBoxDD.dll.

Could you please upgrade VBox up to 4.1.18 and replaces VBoxDD.dll in the same manner we've done before with binaries below?

 VBoxDD.dll - 32-bit VBoxDD.dll
 VBoxDD.dll - 64-bit VBoxDD.dll

Last edited 22 months ago by gendouhydeist (previous) (diff)

comment:52 in reply to: ↑ 51 Changed 22 months ago by Hachiman

Replying to gendouhydeist: Thank you for testing.

comment:53 in reply to: ↑ 50 ; follow-up: ↓ 54 Changed 22 months ago by Pinepara

Replying to Hachiman:

Wow! It seems that this fixed my problem too. Good Job!

comment:54 in reply to: ↑ 53 Changed 22 months ago by Hachiman

  • Summary changed from NAT: crash with "WSAEnumNetworkEvents tcp error 10038" to NAT: crash with "WSAEnumNetworkEvents tcp error 10038" -> fixed in svn

Replying to Pinepara:

Wow! It seems that this fixed my problem too. Good Job!

Thank you for feed back.

comment:55 follow-up: ↓ 56 Changed 21 months ago by mkucharski

virtualbox: 4.1.18 r78361
host: Windows 7 SP1 64-bit
guest: OpenBSD 5.2-beta amd64

VBoxManage.exe modifyvm openbsd-amd64 --natdnshostresolver2 on
VBoxManage.exe modifyvm openbsd-amd64 --natsettings2 1500,128,128,128,128
VBoxManage.exe startvm openbsd-amd64 --type headless

Issue is still present, "WSAEnumNetworkEvents tcp error 10038" is last line in the log when VirtualBox is crashing. It always happens during high network load generated on guest with wget/curl/ftp.

Last edited 21 months ago by mkucharski (previous) (diff)

comment:56 in reply to: ↑ 55 ; follow-up: ↓ 57 Changed 21 months ago by Hachiman

Replying to mkucharski:

Issue is still present, "WSAEnumNetworkEvents tcp error 10038" is last line in the log when VirtualBox is crashing. It always happens during high network load generated on guest with wget/curl/ftp.

Could you please attach the log? Could you please describe how do you generate huge load on the guest?

comment:57 in reply to: ↑ 56 Changed 21 months ago by mkucharski

Replying to Hachiman:

Could you please attach the log? Could you please describe how do you generate huge load on the guest?

Sure, it doesn't always crash. When it crashes again I'll provide the log. FYI: I don't have any debugging DLLs insalled. I'm downloading on that machine OpenBSD snapshots quite often from various http or ftp mirrors. Nothing fancy really.

Changed 21 months ago by mkucharski

VB 4.1.18 crash, Win7 64-bit host, OpenBSD 5.2-beta amd64 guest, NAT

comment:59 Changed 21 months ago by Hachiman

thanks for update.

comment:60 Changed 20 months ago by frank

VirtualBox 4.1.20 contains another fix. Could you please test if the bug was finally fixed?

Changed 20 months ago by mkucharski

Crash still happens with VirtualBox 4.1.20 r80170

comment:61 follow-up: ↓ 62 Changed 20 months ago by mkucharski

Attachment didn't bump last modified time, so bumping by this comment - Yeah, it fails again.

comment:62 in reply to: ↑ 61 Changed 20 months ago by Hachiman

Replying to mkucharski:

Attachment didn't bump last modified time, so bumping by this comment - Yeah, it fails again.

Could you please collect network dump ? (for more details please look Network_tips)

Changed 20 months ago by Eric

Crash on 4.1.20 on eavy bandwidth load

comment:63 follow-up: ↓ 64 Changed 20 months ago by Eric

If you need me for testing, I get a systematic way to make it crash by downloading a FTP file with by 100Mb connection on my dedicated server. Trying to get now to collect "network dump"...

comment:64 in reply to: ↑ 63 ; follow-up: ↓ 65 Changed 20 months ago by Hachiman

Replying to Eric:

If you need me for testing, I get a systematic way to make it crash by downloading a FTP file with by 100Mb connection on my dedicated server. Trying to get now to collect "network dump"...

Thank you Eric for your help. Could you please send it to me (vasily _dot_ levchenko _at_ oracle _dot_ com) by mail?

comment:65 in reply to: ↑ 64 ; follow-up: ↓ 66 Changed 20 months ago by Eric

Replying to Hachiman:

Replying to Eric:

If you need me for testing, I get a systematic way to make it crash by downloading a FTP file with by 100Mb connection on my dedicated server. Trying to get now to collect "network dump"...

Thank you Eric for your help. Could you please send it to me (vasily _dot_ levchenko _at_ oracle _dot_ com) by mail?

My VB crashes typically after 400MB downloaded, which makes the capture very large. Could you provide me a debug version with logs to try? I'm trying to setup a build environnement to help solving this issue with an instrumented slirp/socket classes to handle the 10038 (not a socket error WSAENOTSOCK). It will be faster if you do it by yourself... Eric

comment:66 in reply to: ↑ 65 Changed 20 months ago by Hachiman

Replying to Eric:

Replying to Hachiman:

Replying to Eric:

I'm trying to setup a build environnement to help solving this issue with an instrumented slirp/socket classes to handle the 10038 (not a socket error WSAENOTSOCK). It will be faster if you do it by yourself...

Ok, I will build log enabled bits and share it with you. Btw, Does it change anything for you in case of single CPU guest?

comment:67 Changed 20 months ago by Hachiman

Log enabled build VBoxDD.dll is available at  http://www.virtualbox.org/download/testcase/VBoxDD.dll.4.1.20_10513 (please look at comment 15 for more detail how to install and use it). It'd be better to have both logs and pcap file. I suppose that result files will be huge, so you can upload ones to  ftp://ftp.oracle.com/appsdev/incoming, please note this folder is WO so please let me know the file name(s).

Changed 20 months ago by mkucharski

after replacing VBoxDD.dll with VBoxDD.dll.4.1.20_10513 virtualbox fails to start

comment:68 Changed 20 months ago by mkucharski

After replacing VBoxDD.dll with VBoxDD.dll.4.1.20_10513 virtualbox fails to start, see previously attached file for details. Not sure is that related to the fact, that Oracle_VM_VirtualBox_Extension_Pack-4.1.20.vbox-extpack fails to install on my machine with error

Failed to install the Extension Pack C:/Users/mkucharski/.VirtualBox/Oracle_VM_VirtualBox_Extension_Pack-4.1.20.vbox-extpack.

The installer failed with exit code 1: VBoxExtPackHelperApp.exe: error: Failed to rename the extension pack directory: VERR_ALREADY_EXISTS

rcExit=1.

Result Code: E_FAIL (0x80004005)
Component: ExtPackManager
Interface: IExtPackManager {3295e6ce-b051-47b2-9514-2c588bfe7554}

comment:69 Changed 20 months ago by mkucharski

Reverting VBoxDD.dll to previous (original) version allows to start VM again, even though I have vbox-extpack 4.1.18 installed.

Changed 19 months ago by mkucharski

Issue still happening with 4.1.22

Changed 19 months ago by mkucharski

Crashed during capturing (in different way), 4.1.22

comment:70 follow-up: ↓ 71 Changed 19 months ago by mkucharski

Finally had a chance to look into this again. All below tests are done with 4.1.22 (the latest reported by Help->Check for Updates at the time of writing this). Enabled packet capturing on the guest, which look more or less as following command:

VBoxManage.exe modifyvm openbsd-amd64 --nictrace2 on --nictracefile2 openbsd-amd64.pcap

First started download of:

 http://ftp5.eu.openbsd.org/ftp/pub/OpenBSD/5.1/amd64/install51.iso

however file finished successfully. So I looked again at my previous downloads and noticed that on that particular mirror I was using FTP to trigger the crash. So I decided to download again the same file via:

 ftp://ftp5.eu.openbsd.org/pub/OpenBSD/5.1/amd64/install51.iso

Left VirtualBox unattended for a while. Came back and wget transfer was stalled. Disappointed decided to CTRL+C the transfer (which worked fine) and then typed 'halt -p' to power off the guest OS. In a moment my CPU fan kicked off like crazy. Windows' TaskMgr.exe showed that VBoxHeadless.exe is using more CPU than usual. Few seconds later I see crash report from Windows about VBoxHeadless.

So, this crash is different than previously reported. Not sure why. See file attached to this ticket very recently (log.gz) for the log from that session. The pcap file is around 330MB uncompressed, 289MB gzipped. I'm going to upload it to my web server and send you a link via email given in previous comments in this ticket. In Oracle VM VirtualBox Manager guest is reported as Aborted.

Please let me know, if you need anything else from me. Thanks.

comment:71 in reply to: ↑ 70 ; follow-up: ↓ 72 Changed 19 months ago by Hachiman

Replying to mkucharski:

Left VirtualBox unattended for a while. Came back and wget transfer was stalled. Disappointed decided to CTRL+C the transfer (which worked fine)

Do I understand you right, that CTRL+C stopped the wget ?

and then typed 'halt -p' to power off the guest OS. In a moment my CPU fan kicked off like crazy. Windows' TaskMgr.exe showed that VBoxHeadless.exe is using more CPU than usual. Few seconds later I see crash report from Windows about VBoxHeadless.

And guest is really crashed on 'halt -p'?

I'm going to upload it to my web server and send you a link via email given in previous comments in this ticket. In Oracle VM VirtualBox Manager guest is reported as Aborted.

Thanks for a link. It looks like according to log that crashed VBoxSVC rather than guest.

comment:72 in reply to: ↑ 71 Changed 19 months ago by mkucharski

Replying to Hachiman:

Do I understand you right, that CTRL+C stopped the wget ?

Yes, CTRL+C stopped wget.

And guest is really crashed on 'halt -p'?

I do not understand the question. I'm not sure did guest crashed. I think VirtualBox running the guest crashed. Not 100% sure. It crashed in usual way for me, however triggered in different way that always. This time not by constant network traffic.

Thanks for a link. It looks like according to log that crashed VBoxSVC rather than guest.

Not sure what VBoxSVC is. Is there anything more which I can test? I think I'll repeat the tests few times again.

comment:73 Changed 19 months ago by Hachiman

Could you please generate minidump of your crash?

comment:74 follow-up: ↓ 75 Changed 19 months ago by mkucharski

Can you point me do the document which explains what is minidump and how to generate it?

comment:75 in reply to: ↑ 74 Changed 19 months ago by Hachiman

Replying to mkucharski:

Can you point me do the document which explains what is minidump and how to generate it?

Please look at our Wiki resource in the part related to Windows system.

comment:76 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response. Please reopen if still relevant with VBox 4.2.18.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use