VirtualBox

Ticket #10493 (closed defect: fixed)

Opened 2 years ago

Last modified 13 months ago

Windows 2000 slow boot

Reported by: mikes82 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.2.2 Keywords: 2000 additions
Cc: Guest type: Windows
Host type: Windows

Description

When I have the the latest version of virtualbox additions installed in the windows 2000 guest, the boot is very slow. It hangs for about a minute and a half in "preparing network conections..." But when I install a older version of virtualbox additions (ex: 4.0.8)it becames a lot faster.

Host: Windows 7 64bit

Attachments

VBox.log Download (50.8 KB) - added by mikes82 2 years ago.
vbox2000.png Download (10.4 KB) - added by mikes82 2 years ago.
it hangs here

Change History

Changed 2 years ago by mikes82

Changed 2 years ago by mikes82

it hangs here

comment:1 Changed 22 months ago by mikes82

This bug is continues in version 4.1.18

comment:2 Changed 22 months ago by bob3248

I can confirm this bug. There is a 1.5 minute delay at Preparing Network Connections during Windows 2000 startup in Virtualbox 4.1.16 and 4.1.18 with the guest additions installed. Without the guest additions there is no delay. There is also no delay in Windows XP x86 or Windows Server 2003 x86 or Windows NT 4.0 even with the guest additions installed.

Host: Windows 7 x64 SP1, Intel Core 2 Quad Q9650 CPU, 8GB RAM Guest: Windows 2000 Professional clean install with default VirtualBox options except for 512 MB RAM. VT-x is enabled.

This bug is discussed in the forums at:  https://forums.virtualbox.org/viewtopic.php?f=2&t=49645

Edit: wrong version numbers.

Last edited 22 months ago by bob3248 (previous) (diff)

comment:3 Changed 21 months ago by bob3248

After further testing it appears that this issue is caused by the VirtualBox Guest Additions Service. In services.msc, the status of this service shows "Starting" and it never changes to "Started" like it should. If the Startup type for this service is changed to manual instead of automatic, there is no delay at Preparing Network Connections during Windows startup. If I try to start the service manually with "net start vboxservice" at the command prompt, I receive an error message that says "The VirtualBox Guest Additions Service could not be started."

comment:4 Changed 21 months ago by frank

That is actually a very interesting information. Could you do a bit more debugging? In the guest, please open regedit.exeand add/edit the following keys:

HKLM\SYSTEM\CurrentControlSet\Services\VBoxService\ImagePath = "system32\VBoxService.exe -vvvv --logfile c:\VBoxService.log" (REG_EXPAND_SZ)

After the registry modification were made the guest needs to be restarted. Please then attach the VBoxService.log file(s) (will be written to C:\ on the guest) to this defect. Thanks!

comment:5 Changed 21 months ago by frank

Never mind, I can reproduce it here.

comment:6 Changed 20 months ago by bob3248

I still have the same problem after upgrading to VirtualBox 4.1.20 with the 4.1.20 guest additions.

comment:7 Changed 20 months ago by mikes82

This bug is continues in version 4.1.20

comment:8 Changed 20 months ago by bob3248

This issue is still present in version 4.1.22.

comment:9 Changed 20 months ago by mikes82

This issue is still present in version 4.2.0

comment:10 Changed 18 months ago by bob3248

This issue is still present in version 4.2.2.

comment:11 Changed 18 months ago by frank

  • Version changed from VirtualBox 4.1.14 to VirtualBox 4.2.2

comment:12 Changed 18 months ago by mikes82

This issue is still present in version 4.2.4.

comment:13 Changed 17 months ago by pentagonik

The issue should be fixed in the next upcoming maintenance version.

comment:14 Changed 16 months ago by bob3248

Yes, it is fixed in 4.2.6. Thank you!

comment:15 Changed 16 months ago by pentagonik

  • Status changed from new to closed
  • Resolution set to fixed

comment:16 Changed 15 months ago by toni.homedes

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry to say it is not fixed.

Here running 4.2.6 r82870 on W2003 host and 5 W2000 guests.

Guest side tried both virtio-net and PCnet-FAST III with no change.


My mistake. I had updated VBox but not the Guest Additions. Once updated the Guest additions everything is fine again.

Last edited 15 months ago by toni.homedes (previous) (diff)

comment:17 Changed 13 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use