VirtualBox

Ticket #10426 (closed defect: invalid)

Opened 2 years ago

Last modified 12 months ago

Insane memory usage

Reported by: mwisnicki Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.12 Keywords: memory
Cc: Guest type: Windows
Host type: Windows

Description

Running Win8/x64 limited to 2GB ram out of 8gb and 2 cpus (amd-v,np,nx) out of 4 on Win7/x64 I had huge jump in memory usage where committed heap increased to 13.5GB and system started swapping like crazy. This happened while installing Visual Studio 2011 beta.

Such usage persisted after VM suspend (which BTW took about an hour), reboot of host and resume. After fully restarting VM everything seems normal.

Inside attachment you will find three logs:

  1. first start of vm where vs2011 setup was executed adn vm suspended
  2. from resume to shutdown
  3. fresh start

and a virtual memory map for vmmap.exe utility from sysinternals.

Attachments

VirtualBox.7z Download (78.1 KB) - added by mwisnicki 2 years ago.

Change History

Changed 2 years ago by mwisnicki

comment:1 Changed 2 years ago by frank

Your attached vmmap file indeed looks like there is a memory leak. However, we were not able to reproduce this problem using your testcase (installing VS 2011). This problem could also be related to your graphics hardware or actually your graphics host drivers.

Do you have any chance to reproduce this with a VM where you can disable 3D support? Perhaps also with Windows 8, just without installing the Guest Additions and disable 3D support for that VM. It would be a great help if you (or anybody else) could do these tests. If you experience a similar memory usage with 3D disabled then the problem must be in another code path.

comment:2 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use