VirtualBox

Ticket #10408 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Can't open a Word document located on a shared folder => Fixed in SVN

Reported by: mbutton Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.1.12 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hey guys,

since I upgraded to 4.1.10 and then 4.1.12, I just can't open a Word file located on my shared folder anymore. I tried several times, with different docs and the problem is confirmed. Using 4.1.10, the VM crashes at once, and using 4.1.12, it freezes severly and I have no other choice than to kill it.

Didn't have any problem in 4.0.16 ...

Thanks !

Attachments

20120404_VBoxCrash.tar.gz Download (88.3 KB) - added by mbutton 2 years ago.
Logs of VirtualBox (4.1.8 working, 4.1.10 & 4.1.12 crashing)
Mini080911-01.dmp Download (128.0 KB) - added by mbutton 2 years ago.
WindowsMiniDump
VBoxSF.zip Download (121.0 KB) - added by sunlover 2 years ago.
Windows 32 bit shared folders driver for VBox 4.1

Change History

comment:1 Changed 2 years ago by frank

Please attach a VBox.log file of such a VM session.

comment:2 follow-up: ↓ 3 Changed 2 years ago by sunlover

How exactly do you open the Word file? Do you use the File/Open menu in Word? Or may be double click on the file icon in a folder? If you use Word, which version of Word is that?

comment:3 in reply to: ↑ 2 Changed 2 years ago by mbutton

Replying to sunlover:

How exactly do you open the Word file? Do you use the File/Open menu in Word? Or may be double click on the file icon in a folder? If you use Word, which version of Word is that?

I'm simply double-clicking on the Word file, in a Windows explorer, in my shared folder. Then I can see Word launching, thinking for a sec and then my VM crashes.

Changed 2 years ago by mbutton

Logs of VirtualBox (4.1.8 working, 4.1.10 & 4.1.12 crashing)

comment:4 follow-up: ↓ 5 Changed 2 years ago by sunlover

Which version of Word do you use?

comment:5 in reply to: ↑ 4 Changed 2 years ago by mbutton

Replying to sunlover:

Which version of Word do you use?

Word 2007, more specifically, (12.0.6212.1000) SP1 MSO (12.0.6213.1000)

Last edited 2 years ago by mbutton (previous) (diff)

comment:6 Changed 2 years ago by mbutton

I then switched back to VB4.1.8 and everything's now back to normal.

comment:7 Changed 2 years ago by frank

With 'crash' you mean 'segfault'? In the logs you provided I don't see a crash, it seems the machines powered down normally.

comment:8 follow-up: ↓ 9 Changed 2 years ago by frank

You probably mean a BSOD in the guest. With 'switching back' to VBox 4.1.8 you mean that you downgraded the Guest Additions to 4.1.8, right?

comment:9 in reply to: ↑ 8 Changed 2 years ago by mbutton

Replying to frank:

You probably mean a BSOD in the guest. With 'switching back' to VBox 4.1.8 you mean that you downgraded the Guest Additions to 4.1.8, right?

By "crash", I mean the VM is brutally going back to the VirtualBox welcome screen an then Windows starts, detecting something went wrong since it offers to boot in safe mode.

Yes you're right : I took a look at the log to see what went wrong and I saw nothing there. I thought I wasn't qualified enough to get the messages right.

And switching back means I uninstalled VB4.1.12 and reinstalled 4.1.8 (as well as the Guest Additions)

comment:10 follow-up: ↓ 11 Changed 2 years ago by frank

I think downgrading the Guest Additions should be sufficient. And it would also help to verify that the problem is in the Guest Additions and not in the host part of VirtualBox.

comment:11 in reply to: ↑ 10 Changed 2 years ago by mbutton

Replying to frank:

I think downgrading the Guest Additions should be sufficient. And it would also help to verify that the problem is in the Guest Additions and not in the host part of VirtualBox.

Ok, makes sense. I'll let you know as soon as I update VB back to 4.1.12. For now, I really need to make my work progress ...

comment:12 follow-up: ↓ 13 Changed 2 years ago by sunlover

Do you use Vista 64 bit as the guest OS? I could not reproduce the problem with Vista 64 bit guest, Word 2007 and a Windows Vista host. May be this problem happens with the Linux hosts only.

Also please attach a recent minidump from you guest, if there are any. The minidump is usually located at c:\windows\minidump directory.

Changed 2 years ago by mbutton

WindowsMiniDump

comment:13 in reply to: ↑ 12 Changed 2 years ago by mbutton

Replying to sunlover:

Do you use Vista 64 bit as the guest OS? I could not reproduce the problem with Vista 64 bit guest, Word 2007 and a Windows Vista host. May be this problem happens with the Linux hosts only.

Also please attach a recent minidump from you guest, if there are any. The minidump is usually located at c:\windows\minidump directory.

The minidump has been uploaded. As for the versions of the OS I'm using, here they are : Host : Ubuntu (11.04 Natty Narwhal) 64 bits Guest : Windows Vista SP1 32 bits

I guess it's interesting to see that the problem has evolved between VB4.1.10 & 4.1.12 : with 4.1.10, the VM immediately shuts down (no BSOD : straight to VirtualBox welcome screen), and with 4.1.12, the VM freezes badly : I completely lose control over it (no mouse nor keyboard response).

comment:14 Changed 2 years ago by mbutton

And I have to precise that it works fine with VB4.1.8.

comment:15 Changed 2 years ago by sunlover

The minidump is from August 2011. There are no newer minidumps in the guest, right?

comment:16 Changed 2 years ago by frank

  • Priority changed from blocker to major

comment:17 Changed 2 years ago by mbutton

Yes you're right, the minidump I uploaded is the only one present in that folder.

I'll try to reinstall VBox 4.1.10 without touching to the VBGA, as suggested by Frank

comment:18 Changed 2 years ago by sunlover

BTW, in the VBox.log I see that the VM has RAM size = 3GB. Please decrease the RAM size to 1GB and check if the problem still reproducible. Thanks.

comment:19 Changed 2 years ago by mbutton

Ok, I'll try this test tomorrow too, to help you diagnose more precisely the problem.

Still, I'm not sure this test is relevant since my VM did not have any problem with VB4.1.8 and 3GB RAM. (I didn't change the RAM amount just before the upgrade : it's always run with 3GB)

What do you think ?

Thanks

comment:20 Changed 2 years ago by sunlover

The shared folders code has been updated after 4.1.8. May be the new code fails with a bigger guest RAM. I could not reproduce the problem with a guest with 512MB. And at the moment I can't test a guest with 3+GB.

comment:21 Changed 2 years ago by sunlover

I finally was able to reproduce the problem. You do not have to test with 1GB guest RAM, thanks.

comment:22 Changed 2 years ago by mbutton

Okay great especially since I haven't taken the time to reinstall VB4.1.12 yet (shame on me).

Tell me if you need more information from me, I'll be glad to help (but as my Win VM is a work tool, I'm unfortunately not able to install / uninstall / start / restart as often as I'd like to)

Changed 2 years ago by sunlover

Windows 32 bit shared folders driver for VBox 4.1

comment:23 Changed 2 years ago by sunlover

You can use the attached VBoxSF.sys. It fixes the problem.

How to install: Start a command line window in the guest as administrator. Make a backup copy of c:\windows\system32\drivers\VBoxSF.sys. Copy the attached VBoxSF.sys to c:\windows\system32\drivers\VBoxSF.sys. Reboot the guest.

comment:24 Changed 2 years ago by mbutton

Thanks for your reply.

Just out of curiosity, can you please explain in a line what happened ? Thanks

comment:25 Changed 2 years ago by sunlover

This was a bug introduced in 4.1.10, when we have rewritten the shared folders driver, while fixing other bugs. Some initialization was missed for the file control block.

comment:26 Changed 2 years ago by mbutton

Very nice of you to have explained the problem.

Thanks again for the good work on this excellent product !

comment:27 Changed 2 years ago by frank

  • Summary changed from Can't open a Word document located on a shared folder to Can't open a Word document located on a shared folder => Fixed in SVN

comment:28 Changed 2 years ago by frank

Fix is NOT part of VBox 4.1.14 but will be included in the following maintenance release.

comment:29 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The fix is part of the 4.1.16 release (update the Guest Additions!)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use