VirtualBox

Ticket #10407 (new defect)

Opened 2 years ago

Last modified 2 years ago

version 4.1.12 fails with ubuntu vm initialization

Reported by: djazz44 Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

version 4.1.10 worked perfectly with 4 installed vms (2 Win8, 1 DOS, 1 Ubuntu 11.10). Today I installed version 4.1.12. Everything worked until I tried Ubuntu. When starting, all USB devices became unavailable in the host system (Win7 64K Pro). Using a PS/2 mouse, I was able to use Task Manager to kill the Ubuntu process. I also had to kill the Virtual Box Manager because it no longer responded. After Virtual Box Manager was killed. The USB devices returned to normal operation.

Attachments

Linux-Ubuntu x64 X2-2012-04-03-19-54-16.log Download (58.4 KB) - added by djazz44 2 years ago.
log of Ubuntu VM problem
Linux-Ubuntu x64 X2.vbox Download (9.4 KB) - added by djazz44 2 years ago.

Change History

comment:1 Changed 2 years ago by Hachiman

Could you please attach the log for this session?

comment:2 Changed 2 years ago by frank

To me that sounds like you passed the USB mouse by accident to the VM. There was no USB-related change between 4.1.10 and 4.1.12.

Changed 2 years ago by djazz44

log of Ubuntu VM problem

comment:3 Changed 2 years ago by djazz44

Only Ubuntu has a problem that causes the host (Win7 x64 Pro) to lose connection with all USB devices (mouse, keyboard, external drives, webcam) when Ubuntu is initializing. Ubuntu gets to the login screen but mouse and keyboard are not available in Ubuntu or host. The computer could not do normal shutdown with power switch because Win7 would not shutdown with the VM active. A forced power off was needed. I tried this 3 times with the same results. No other applications were running on the host. Finally, I installed a PS/2 mouse and started Ubuntu. I still had mouse control when all USB devices disappeared. I was able to use Task Manager to kill Ubuntu VM. Also had to kill Virtual Box Manager that went into a coma. The host came back to normal operation and all USB device were again connected and the system ran properly. Using VMs for DOS, Win8 DP and Win8 CP caused no problems.

comment:4 Changed 2 years ago by frank

Sounds to me like you have an empty USB filter active for that VM. The VBox.log shows that a lot of USB devices are attached to the VM. Could you post the VM settings file of that VM?

Changed 2 years ago by djazz44

comment:5 Changed 2 years ago by djazz44

There was no change to the Ubuntu settings when updating Virtual box from one version to another. The problem showed when first running Ubuntu after Virtual box was updated to the latest version. Since then, Ubuntu has never been accessible. I assume that the file recently attached is the one you needed.

comment:6 Changed 2 years ago by frank

Please remove the 'Any USB Device' filter and your VM and your USB device will work like expected. Having such an 'all' filter is never a good idea.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use