VirtualBox

Ticket #10403 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

kmk_sed fails if kBuild was compile with gcc 4.7

Reported by: sergiomb Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: all
Host type: Linux

Description

when we packaging on Fedora we use kBuild compiled by us:  http://koji.fedoraproject.org/koji/packageinfo?packageID=7356

after use kBuild compiled with gcc 4.7 I got this error on building virtuaBox

/usr/bin/kmk_sed: file /builddir/build/BUILD/VirtualBox-4.1.8_OSE/src/VBox/Runtime/common/err/errmsg.sed line 31: Unmatched [ or [^
kmk: *** [/builddir/build/BUILD/VirtualBox-4.1.8_OSE/obj/obj/Runtime/errmsgdata.h] Error 1
kmk: *** Deleting file `/builddir/build/BUILD/VirtualBox-4.1.8_OSE/obj/obj/Runtime/errmsgdata.h'
kmk: *** Waiting for unfinished jobs....

kmk_sed doesn't read well /builddir/build/BUILD/VirtualBox-4.1.10/src/VBox/Runtime/common/err/errmsg.sed

the problem is when is generate errmsgdata.h.

Change History

comment:1 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

kBuild is not part of VirtualBox. Please report this problem at the kBuild bugtracker.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use