VirtualBox

Ticket #10402 (closed defect: duplicate)

Opened 2 years ago

Last modified 21 months ago

NetWare completely unusable in 4.1.x

Reported by: kumba Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.12 Keywords: netware
Cc: Guest type: other
Host type: Windows

Description

I have documented in #9422 that NetWare had issues installing as a guest without some tweaks and that, under a Core2 Quad, it was impossible to boot with Nested Paging and VT-x enabled. But, those issues aside, NetWare is usable in 4.0.x, up through 4.0.16.

Under 4.1.x, Netware is completely unusable. In prior versions of 4.1.x, you could at least boot to a half-functional console prompt, however, the SYS: volume was not mounted for unknown reasons. Under 4.1.12, however, the problem is worse : it doesn't load at all. Assuming you don't get hung up at the loading of FATFS.NLM trying to check the consistency of the boot volume (C:), it will freeze (or it's just SUPER slow, I do not know which) when loading IDEATA.HAM (the driver for an ATAPI IDE device, like a standard PATA hard drive).

There is no sign of disk activity after this point. Changing options such as the system chipset from ICH9 to or PXII3 affects nothing, nor changing the disk controller from ICH6 to PXII3/4, nor changing from PATA to SATA.

VBox.log is attached, but I can't see anything error-wise reprted. One bit indicates ni PCI Bus is present, which is odd? But doesn't seem to account for NetWare not loading.

Attachments

VBox.log Download (82.9 KB) - added by kumba 2 years ago.
VBox.log from NetWare 6.5sp8 under 4.1.12
VBox.2.log Download (75.9 KB) - added by kumba 2 years ago.
VBox.log from NetWare 6.5sp8 under 4.0.16
VBox.3.log Download (78.3 KB) - added by kumba 2 years ago.
NetWare failure in 4.1.12 w/o 3d, PIIX3 MB chipset, and SCSI as host controller.

Change History

Changed 2 years ago by kumba

VBox.log from NetWare 6.5sp8 under 4.1.12

Changed 2 years ago by kumba

VBox.log from NetWare 6.5sp8 under 4.0.16

comment:1 Changed 2 years ago by kumba

Hmm, the missing PCI Bus might indeed be the problem. I've also attached a log from 4.0.16, and at the point where one sees "Guest Log: BIOS: Booting from Hard Disk...", there are no messages about the PCI Bus missing. Bootup is still really slow, even though I allocated the server 1GB of memory and 1 processor. Kind of a "feature" with NW, though, especially when loading the LIBGCC_S.NLM file later in the boot cycle.

I know NW is considered an antiquated OS in some circles, but if someone could look into it, it'd be great. I do have uses for it from time-to-time in various network testing scenarios.

comment:2 Changed 2 years ago by frank

Is there any reason that you enabled 3D support and the ICH9 chipset for that guest? Please disable 3D and use the PIIX3 chipset. I assume that this will make your guest behave like it was with VBox 4.0.16.

comment:3 Changed 2 years ago by kumba

Still unusable. NetWare is unable to load any primary disk drivers, be they IDE, SATA, or SCSI. It sees the hardware change and tries to load the appropriate drivers, but something, I have no idea what, is causing the driver load to fail. Also, the arrow keys on the keyboard are non-functional, too.

I did not try SAS, but I suspect the outcome will be the same. I tried using both PIIX3 and PIIX4 chipsets on IDE, only AHCI on SATA, and LSILogic on SCSI (not BusLogic). I have to switch back to 4.0.16 again until something is fixed in a later 4.1.x update. VBox log is attached from the SCSI instance, if it helps.

Changed 2 years ago by kumba

NetWare failure in 4.1.12 w/o 3d, PIIX3 MB chipset, and SCSI as host controller.

comment:4 Changed 2 years ago by kumba

I am also not certain, but NW might not like swapping of the MB chipset out after an install. It tries to cope, but I may be stuck using ICH9, and I don't have time to re-install it at present. What is holding up proper ICH9 emulation?

comment:5 Changed 22 months ago by kumba

Ping?

comment:6 Changed 21 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10728.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use