VirtualBox

Ticket #10401 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Windows XP guest crashes on OS X 10.7.3 host

Reported by: p3k Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.1.10 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

After a recent update of VirtualBox my long-time running Windows XP guest does not start anymore and crashes after the splash screen (see attachment).

Sometimes I spot a flicker of a BSOD but of course I am not able to read anything. At other times, I get the “safe mode” screen and may choose the system to start this way but the crash obviously is inevitable.

As I am not able to get the machine running at all I cannot create a dump file – except there is a method without booting I am not aware of.

I remember the guest running perfectly last year so I tried previous versions of VirtualBox (4.0.16, 4.1.10). But unfortunately, the machine does not start anymore with versions it in fact must have worked last year…

Although I am sure I did not change any settings I also tried switching various options on and off (like 2D/3D/hardware acceleration), all to no avail.

I attached a VBox.log file from a crashed session hoping for some help or ideas what I could do to make the system running again.

Any feedback is appreciated.

Attachments

Screen Shot 2012-04-02 at 01.34.57.png Download (29.9 KB) - added by p3k 2 years ago.
Splash screen
Windows XP-2012-04-02-01-35-09.log Download (76.6 KB) - added by p3k 2 years ago.
VBox.log of a crashed session
Windows XP-2012-04-02-12-10-09.log Download (77.2 KB) - added by p3k 2 years ago.
Log output running test build

Change History

Changed 2 years ago by p3k

Splash screen

Changed 2 years ago by p3k

VBox.log of a crashed session

comment:1 Changed 2 years ago by frank

The log file does not show any crash, did you attach the wrong logfile? It might be also a duplicate of #10370.

Changed 2 years ago by p3k

Log output running test build

comment:2 Changed 2 years ago by p3k

Frank, I saved the log file immediately after the crash – or whatever it should be called. In any case, the Windows XP host window simply disappears after the splash screen and the machine state returns to “Powered Off”.

Re #10370 I downloaded the OS X test build from the comments but the machine does not start with it, either. I attached another log file Download from today.

Last edited 2 years ago by p3k (previous) (diff)

comment:3 follow-up: ↓ 4 Changed 2 years ago by frank

According to the logfile, the VM was powered off, most probably directly from the guest. Are you able to go into the Windows safe mode (pressing F8 during boot)? According to your description there could be also a BSOD which makes the VM power off. Perhaps you have to change the policy for handling BSOD (therefore my question for being able to boot in safe mode).

comment:4 in reply to: ↑ 3 Changed 2 years ago by p3k

Replying to frank:

According to the logfile, the VM was powered off, most probably directly from the guest. Are you able to go into the Windows safe mode (pressing F8 during boot)? According to your description there could be also a BSOD which makes the VM power off. Perhaps you have to change the policy for handling BSOD (therefore my question for being able to boot in safe mode).

Thanks for the suggestion. I already got the screen for boot mode selection from time to time and I am also able to force its display by pressing F8.

However, if I select the Safe Mode and press Enter the screen still disappears as described. Sometimes I am not even able to move the mode selection with the arrow keys when suddenly I get an OS X dialog window stating the VM has crashed.

Is there another way to get more debugging information from the guest machine?

Last edited 2 years ago by p3k (previous) (diff)

comment:5 follow-up: ↓ 6 Changed 2 years ago by frank

Hmm, but when you get an OS X dialog that the VM crashed then there must be a crash report available, right? I would be interested in such a crash report.

To me it looks like your VM image is somehow corrupted, perhaps some very vital file (e.g. the Windows kernel or some device driver). The only idea I have is to boot a some OS from a CD and do a disk check on the Windows partition. I think this should be doable with a normal Ubuntu Live CD (it has support for NTFS) or just with the Winodws installation CD.

comment:6 in reply to: ↑ 5 Changed 2 years ago by p3k

Replying to frank:

Hmm, but when you get an OS X dialog that the VM crashed then there must be a crash report available, right? I would be interested in such a crash report.

I tried to recreate the crash with dialog but unfortunately it does not happen anymore. (Might be the newer VBox version...?)

To me it looks like your VM image is somehow corrupted, perhaps some very vital file (e.g. the Windows kernel or some device driver). The only idea I have is to boot a some OS from a CD and do a disk check on the Windows partition. I think this should be doable with a normal Ubuntu Live CD (it has support for NTFS) or just with the Winodws installation CD.

Yes, I think that must have been the issue. I repaired the system using the installation CD and at least now I can boot the Windows XP machine again. Need to apply all the Windows updates, though.

Thanks for your quick and reliable help, Frank! Very much appreciated :)

comment:7 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

So let's close this ticket. Feel free to reopen if it happens again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use