VirtualBox

Ticket #10384 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

Kernel Crash while loading vbox module on Ubuntu Oneiric 64 bits with kernel 3.2

Reported by: Nikaiw Owned by:
Priority: major Component: host support
Version: VirtualBox 4.1.10 Keywords: Kernel Crash Module
Cc: Guest type: other
Host type: Linux

Description

After compiling the new vbox kernel module 4.1.10 for Linux 3.2 x86_64 using dkms and /etc/init.d/vboxdrv setup, I got a kernel crash on Ubuntu Oneiric when the module is loaded.

Afaik the probleme was already there for version prior to 4.1.10, like 4.1.X.

dkms is in version 2.2.0.2.

Boot information/Stack trace on the crash are the following (and also attached):

(I hope this is not an already covered ticket sorry if it's a repost)

Mar 27 11:23:41 nicolas-laptop kernel: [   38.413758] vboxdrv: fAsync=0 offMin=0x2c1 offMax=0x13b6
Mar 27 11:23:41 nicolas-laptop kernel: [   38.413821] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
Mar 27 11:23:41 nicolas-laptop kernel: [   38.413823] vboxdrv: Successfully loaded version 4.1.10 (interface 0x00190000).
Mar 27 11:23:41 nicolas-laptop kernel: [   38.413836] BUG: unable to handle kernel paging request at ffff8800effbced0
Mar 27 11:23:41 nicolas-laptop kernel: [   38.415019] IP: [<ffffffff810a7118>] module_put+0x28/0x90
Mar 27 11:23:41 nicolas-laptop kernel: [   38.416116] PGD 1c06063 PUD 0 
Mar 27 11:23:41 nicolas-laptop kernel: [   38.417179] Oops: 0002 [#1] SMP 
Mar 27 11:23:41 nicolas-laptop kernel: [   38.418156] CPU 0 
Mar 27 11:23:41 nicolas-laptop kernel: [   38.418162] Modules linked in: vboxdrv(O) ipt_MASQUERADE iptable_nat xt_CHECKSUM iptable_mangle bridge stp kvm_intel kvm ip6t_LOG xt_hl ip6t_rt nf_conntrack_ipv6 nf_defrag_ipv6 ipt_REJECT ipt_LOG dm_crypt parport_pc ppdev xt_limit xt_tcpudp xt_addrtype xt_state ip6table_filter ip6_tables snd_hda_codec_hdmi nf_conntrack_netbios_ns nf_conntrack_broadcast snd_hda_codec_realtek nf_nat_ftp nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack_ftp nf_conntrack iptable_filter ip_tables x_tables ath3k btusb snd_hda_intel bluetooth snd_hda_codec binfmt_misc arc4 snd_hwdep ath9k snd_pcm uvcvideo mac80211 videodev v4l2_compat_ioctl32 hid_logitech_dj snd_seq_midi ath9k_common ath9k_hw snd_rawmidi ath snd_seq_midi_event joydev snd_seq snd_timer snd_seq_device snd toshiba_acpi soundcore snd_page_alloc mei(C) cfg80211 psmouse sparse_keymap toshiba_bluetooth serio_raw lp parport nbd usbhid hid i915 e1000e drm_kms_helper drm sdhci_pci sdhci i2c_algo_bit video
Mar 27 11:23:41 nicolas-laptop kernel: [   38.425173] 
Mar 27 11:23:41 nicolas-laptop kernel: [   38.426132] Pid: 1862, comm: modprobe Tainted: G         C O 3.2.0-030200-generic #201201042035 TOSHIBA SATELLITE R830/Portable PC
Mar 27 11:23:41 nicolas-laptop kernel: [   38.427119] RIP: 0010:[<ffffffff810a7118>]  [<ffffffff810a7118>] module_put+0x28/0x90
Mar 27 11:23:41 nicolas-laptop kernel: [   38.428101] RSP: 0018:ffff880143cf7f28  EFLAGS: 00010286
Mar 27 11:23:41 nicolas-laptop kernel: [   38.429124] RAX: ffffffffa05bcecc RBX: ffffffffa05ccfa0 RCX: 0000000000000000
Mar 27 11:23:41 nicolas-laptop kernel: [   38.430108] RDX: 0000000000000000 RSI: 0000000000000282 RDI: ffffffffa05ccfa0
Mar 27 11:23:41 nicolas-laptop kernel: [   38.431095] RBP: ffff880143cf7f48 R08: 0000000000000000 R09: 0000000000000000
Mar 27 11:23:41 nicolas-laptop kernel: [   38.432059] R10: 0000000000000000 R11: 0000000000000002 R12: ffffffffa05ccfa0
Mar 27 11:23:41 nicolas-laptop kernel: [   38.433027] R13: 0000000001586430 R14: 0000000000000000 R15: 0000000000405e30
Mar 27 11:23:41 nicolas-laptop kernel: [   38.433948] FS:  00007fa96cfe0720(0000) GS:ffff88014fa00000(0000) knlGS:0000000000000000
Mar 27 11:23:41 nicolas-laptop kernel: [   38.434857] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Mar 27 11:23:41 nicolas-laptop kernel: [   38.435745] CR2: ffff8800effbced0 CR3: 0000000145438000 CR4: 00000000000426f0
Mar 27 11:23:41 nicolas-laptop kernel: [   38.436643] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Mar 27 11:23:41 nicolas-laptop kernel: [   38.437564] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Mar 27 11:23:41 nicolas-laptop kernel: [   38.438442] Process modprobe (pid: 1862, threadinfo ffff880143cf6000, task ffff880143632dc0)
Mar 27 11:23:41 nicolas-laptop kernel: [   38.439310] Stack:
Mar 27 11:23:41 nicolas-laptop kernel: [   38.440178]  ffff880143cf7f48 ffffffffa05ccfa0 0000000000000000 0000000001586430
Mar 27 11:23:41 nicolas-laptop kernel: [   38.441103]  ffff880143cf7f78 ffffffff810a9686 0000000000405e30 0000000001586470
Mar 27 11:23:41 nicolas-laptop kernel: [   38.441979]  0000000000000000 0000000001585080 0000000001586430 ffffffff8164f242
Mar 27 11:23:41 nicolas-laptop kernel: [   38.442859] Call Trace:
Mar 27 11:23:41 nicolas-laptop kernel: [   38.443736]  [<ffffffff810a9686>] sys_init_module+0x126/0x220
Mar 27 11:23:41 nicolas-laptop kernel: [   38.444602]  [<ffffffff8164f242>] system_call_fastpath+0x16/0x1b
Mar 27 11:23:41 nicolas-laptop kernel: [   38.445497] Code: 44 00 00 55 48 89 e5 48 83 ec 20 48 89 5d e8 4c 89 65 f0 4c 89 6d f8 66 66 66 66 90 48 85 ff 49 89 fc 74 20 48 8b 87 48 02 00 00 <65> ff 40 04 8b 05 e6 ae c2 00 4c 8b 6d 08 85 c0 75 15 41 83 3c 
Mar 27 11:23:41 nicolas-laptop kernel: [   38.447411] RIP  [<ffffffff810a7118>] module_put+0x28/0x90
Mar 27 11:23:41 nicolas-laptop kernel: [   38.448367]  RSP <ffff880143cf7f28>
Mar 27 11:23:41 nicolas-laptop kernel: [   38.449344] CR2: ffff8800effbced0
Mar 27 11:23:41 nicolas-laptop kernel: [   38.508629] ---[ end trace 257966086281a199 ]---

Attachments

kernel crash Download (4.7 KB) - added by Nikaiw 2 years ago.
Kernel Crash - Boot log

Change History

Changed 2 years ago by Nikaiw

Kernel Crash - Boot log

comment:1 Changed 2 years ago by Nikaiw

( vbox was installed throught the depot : deb  http://download.virtualbox.org/virtualbox/debian oneiric contrib )

comment:2 Changed 2 years ago by frank

I think I saw such a problem some weeks or months ago. The cause was that the kernel headers did not really match the actual running kernel. Where do you have that kernel from (Oneiric is currently at linux 3.0.0-16)?

comment:3 Changed 2 years ago by frank

See #9482. I assume a similar problem here.

comment:4 Changed 2 years ago by Nikaiw

I don't think it's exactly the same problem as I think I don't have issue when unloading the module nor compiling it. I think The kernel crash occure while loading the new module. I'll try to reproduce it one more time to confirm.

Nevertheless it can possibly be linked to what you said as it's working without any issue on the officiel "3.0.0-16-generic" kernel.

As far as I can tell I got my kernel from  http://kernel.ubuntu.com/~kernel-ppa/ as a .deb package.

a dpkg -l |grep kernel is also giving me:

ii  linux-headers-3.2.0-030200                                  3.2.0-030200.201201042035                       Header files related to Linux kernel version 3.2.0
ii  linux-headers-3.2.0-030200-generic                          3.2.0-030200.201201042035                       Linux kernel headers for version 3.2.0 on x86/x86_64
iF  virtualbox-dkms                                             4.1.2-dfsg-1ubuntu1                             x86 virtualization solution - kernel module sources for dkms

Last edited 2 years ago by Nikaiw (previous) (diff)

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

I just checked these packages and it's indeed the very same problem as in #9482 :-/

comment:6 Changed 2 years ago by Nikaiw

Erz Okay I juste backlogged the whole 9482 and 9891 tickets sorry about that :-/

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use